LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-22-2007, 12:29 PM   #1
richinsc
Member
 
Registered: Mar 2007
Location: Utah
Distribution: Gentoo Linux (3.0.6-gentoo)
Posts: 222

Rep: Reputation: 32
Exim4 SMTP Relay


I am trying to setup a Relay to send out emails for a monitoring system. I used
Quote:
dpkg-reconfigure exim4-config
to reconfigure exim4 to send email to a smart host with no local mail. The server is doing it's job and is trying to send but is getting rejection notices from the ISP smarthost because they used SMTP authentication and I can find nowhere where I can specify the authentication information. It keeps saying that
Quote:
553 Sorry, that domain isn't in my list of allowed rcpthosts.
I know that this is because it can't authenticate my server because my server isn't sending the username and password to the smarthost for authentication.

I have searched google, but haven't found anything.. I think I might just have to learn to setup an email server. Although all this email server would be doing is sending logs and notifications. I would prefer to just relay the logs to an external smtp server that would then deliver the messages to me. Any help would be much appreciated.

Last edited by richinsc; 04-22-2007 at 12:30 PM. Reason: Fix Title Spelling
 
Old 04-22-2007, 01:56 PM   #2
richinsc
Member
 
Registered: Mar 2007
Location: Utah
Distribution: Gentoo Linux (3.0.6-gentoo)
Posts: 222

Original Poster
Rep: Reputation: 32
Well the Exim4 config is working but I can't figure out how to get the other server (GoDaddy's smtopout.SecureServer.net) to accept my domain when that domain is hosted with them. Here is output of logs. Could someone please help. I have added my username and password to the passwd.clients file in /etc/exim4/

Code:
2007-04-22 12:49:45 1Hfh85-0000Hq-K6 <= nagios@domain.org U=nagios P=local S=499
2007-04-22 12:49:55 1Hfh8F-0000Hw-Lz <= nagios@domain.org U=nagios P=local S=579
2007-04-22 12:49:56 1Hfh85-0000Hq-K6 ** 9999999999@vtext.com R=smarthost T=remote_smtp_smarthost: SMTP error from remote mail server after RCPT TO:<9999999999@vtext.com>: host smtpout.secureserver.net [64.202.165.58]: 553 Sorry, that domain isn't in my list of allowed rcpthosts.
2007-04-22 12:50:02 1Hfh8M-0000I6-4y <= <> R=1Hfh85-0000Hq-K6 U=Debian-exim P=local S=1508
2007-04-22 12:50:02 1Hfh85-0000Hq-K6 Completed
2007-04-22 12:50:06 1Hfh8F-0000Hw-Lz ** webmaster@domain.org R=smarthost T=remote_smtp_smarthost: SMTP error from remote mail server after RCPT TO:<webmaster@domain.org>: host smtpout.secureserver.net [64.202.165.58]: 553 Sorry, that domain isn't in my list of allowed rcpthosts.
2007-04-22 12:50:12 1Hfh8W-0000IH-0X <= <> R=1Hfh8F-0000Hw-Lz U=Debian-exim P=local S=1606
2007-04-22 12:50:12 1Hfh8F-0000Hw-Lz Completed
2007-04-22 12:50:13 1Hfh8M-0000I6-4y ** nagios@domain.org R=smarthost T=remote_smtp_smarthost: SMTP error from remote mail server after RCPT TO:<nagios@domain.org>: host smtpout.secureserver.net [64.202.165.58]: 553 Sorry, that domain isn't in my list of allowed rcpthosts.
2007-04-22 12:50:13 1Hfh8M-0000I6-4y Frozen (delivery error message)
2007-04-22 12:50:23 1Hfh8W-0000IH-0X ** nagios@domain.org R=smarthost T=remote_smtp_smarthost: SMTP error from remote mail server after RCPT TO:<nagios@domain.org>: host smtpout.secureserver.net [64.202.165.58]: 553 Sorry, that domain isn't in my list of allowed rcpthosts.
2007-04-22 12:50:23 1Hfh8W-0000IH-0X Frozen (delivery error message)
domain.org is just an example domain.. Don't want to have my domain spammed.

Last edited by richinsc; 04-22-2007 at 02:01 PM.
 
Old 04-22-2007, 03:26 PM   #3
richinsc
Member
 
Registered: Mar 2007
Location: Utah
Distribution: Gentoo Linux (3.0.6-gentoo)
Posts: 222

Original Poster
Rep: Reputation: 32
IT WORKS!!!. YAHOOO.. Wrong on my part.
 
Old 03-25-2008, 12:13 PM   #4
elfsie
LQ Newbie
 
Registered: Mar 2008
Posts: 2

Rep: Reputation: 0
I'm having the exact same problem (with GoDaddy as well). I've put my username and password in the passwd.client file, but can't seem to get past the 553 error. Can you explain what you did to solve this? Many thanks!
 
Old 03-25-2008, 07:36 PM   #5
elfsie
LQ Newbie
 
Registered: Mar 2008
Posts: 2

Rep: Reputation: 0
Never got this to work on GoDaddy, but was able to relay through my ISP (verizon) after I created the file /etc/exim4/exim4.conf.localmacros and typed in AUTH_CLIENT_ALLOW_NOTLS_PASSWORDS=1

..in addition to setting up the /etc/exim4/passwd.client file.

I found this thread helpful:
http://lists.alioth.debian.org/piper...ay/001760.html

Thanks to Drew Parsons for that.

BTW: running Exim 4 on Debian Etch

Last edited by elfsie; 03-25-2008 at 07:37 PM. Reason: system info
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
exim4 relay upload-3 Linux - Networking 0 06-28-2006 03:49 PM
Exim4 relay to hosting prob ALInux Debian 1 05-08-2006 04:07 PM
Exim4 relay to hosting prob ALInux Linux - Networking 2 05-08-2006 02:23 AM


All times are GMT -5. The time now is 05:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration