LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 01-31-2008, 05:34 AM   #1
zenlord
LQ Newbie
 
Registered: Feb 2006
Location: Belgium
Distribution: Arch Linux / Debian testing
Posts: 14

Rep: Reputation: 0
Evolution in debian lenny


I'm really considering leaving evolution, since I don't use any of the exchange-features, but at the moment I don't have the time to do so for all the worksttions here, so...

Anyhoo: yesterday I upgraded the systems and evolution couldn't connect to SSL-servers, which is a known bug. Upgrading to e-d-s from unstable solved this issue.

Now new problem occurs: I cannot open attachments directly in evolution. I can save them to my hard drive and then open them, so it's no dealbreaker, but I'm kinda getting fed up with this.

Some information:
Code:
# dpkg -l evo*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                             Version                          Description
+++-================================-================================-================================================================================
ii  evolution                        2.12.3-1                         groupware suite with mail client and organizer
ii  evolution-common                 2.12.3-1                         architecture independent files for Evolution
ii  evolution-data-server            1.12.3-1                         evolution database backend server
ii  evolution-data-server-common     1.12.3-1                         architecture independent files for Evolution Data Server
un  evolution-data-server-dbg        <none>                           (no description available)
un  evolution-data-server1.2         <none>                           (no description available)
un  evolution-dbg                    <none>                           (no description available)
un  evolution-exchange               <none>                           (no description available)
ii  evolution-plugins                2.12.3-1                         standard plugins for Evolution
un  evolution-plugins-experimental   <none>                           (no description available)
ii  evolution-webcal                 2.12.0-1                         webcal: URL handler for GNOME and Evolution
Starting evolution in a terminal outputs the following:
Code:
$ evolution
evolution-shell-Message: Killing old version of evolution-data-server...
** (evolution:17585): DEBUG: mailto URL command: evolution %s
** (evolution:17585): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files
in emp_apps_open_in

$
If I remember correctly, the dbus-error has been there for a while - I don't know how to solve this but I don't know if it is problematic to leave it.

The other entry (in emp_apps_open_in) occurs together with my doubleclick on the attachments name and consecutively evolution stalls. killall evolu* is needed in order to be able to restart evolution...

Anyone?

Zl.
/EDIT: I did some more testing:
- disabling plugins didn't solve the problem
- upon double-clicking the attachment, I see in the bottom-left corner the message "saving attachment(...)", so it might be related to saving the message to a temporary folder to open it.
- Last time I double-clicked a PDF-attachement, I got an extra line of output before evolution crashed:
Code:
(evolution:20535): libebook-WARNING **: EBookView: Exception while releasing BookView

in emp_apps_open_in

Last edited by zenlord; 01-31-2008 at 06:13 AM. Reason: extra info
 
Old 01-31-2008, 02:14 PM   #2
Dankles
Member
 
Registered: May 2004
Location: /dev/null
Distribution: Slackware
Posts: 245

Rep: Reputation: 31
You problem is definitely evolutions fault and not the underlying system. Do you know how to compile your own deb packages? You might need to get sources and compile a custom evolution setup.
 
  


Reply

Tags
attachment, crash, evolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Debian Lenny on the $0 Laptop LXer Syndicated Linux News 0 01-03-2008 05:20 PM
Tuxguitar on Debian Lenny real_archer Linux - Software 5 12-16-2007 09:18 AM
Debian Lenny on AMB64? jlinkels Debian 4 11-18-2007 08:45 PM
USB dies after a while (Debian Lenny) kaz2100 Debian 7 10-17-2007 03:53 PM
Debian Lenny ugly fonts arnuld Debian 16 06-23-2007 03:40 AM


All times are GMT -5. The time now is 10:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration