LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-15-2006, 04:58 PM   #1
cougyr
Member
 
Registered: Nov 2003
Posts: 98

Rep: Reputation: 15
Etch Xorg 7 and fonts


When upgrading from Sarge to Etch, and XFree86 to Xorg 7, many of us wind up with font problems. Has anyone written a reliable, easy to follow font Howto for Xorg 7?
 
Old 08-15-2006, 05:11 PM   #2
robingazi
Member
 
Registered: Jul 2006
Location: Bangladesh
Distribution: Ubuntu
Posts: 93

Rep: Reputation: 15
I have a fresh install of etch but I have a problem of that sort too.

Quote:
robin:/etc# dpkg-reconfigure sound-server
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_BD:en_US:en_GB:en",
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Package `sound-server' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: sound-server is not installed
I cant run base-config either.
 
Old 08-15-2006, 09:21 PM   #3
cougyr
Member
 
Registered: Nov 2003
Posts: 98

Original Poster
Rep: Reputation: 15
I get several versions of "(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/truetype/ttf-bitstream-vera".
Entry deleted from font path."

and several more of "Could not init font path element /var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

As well, fonts which I used to have are no longer available, even though they look to be there.
 
Old 08-16-2006, 10:05 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
http://wiki.debian.org/Xorg69To7
 
Old 08-16-2006, 10:06 AM   #5
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
Originally Posted by robingazi
I have a fresh install of etch but I have a problem of that sort too.
Your problem is different, you have a localisation problem.

Code:
dpkg-reconfigure locale
and select the ones you're interested
 
Old 08-16-2006, 06:32 PM   #6
cougyr
Member
 
Registered: Nov 2003
Posts: 98

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by nx5000
I have been through that Wiki, including the last step, without success. There's some legasy instructions hanging around in my machine.
 
Old 08-17-2006, 06:11 AM   #7
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
Originally Posted by cougyr
I have been through that Wiki, including the last step, without success. There's some legasy instructions hanging around in my machine.
Ok
What do you mean by legasy instructions hanging around?

Quote:
I get several versions of "(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/truetype/ttf-bitstream-vera".
Entry deleted from font path."
Try this and restart X window:
Code:
mkfontscale /usr/share/fonts/truetype/ttf-bitstream-vera
mkfontdir /usr/share/fonts/truetype/ttf-bitstream-vera

Quote:
several more of "Could not init font path element /var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
Maybe these directories don't exist on your system?
Try this:
Code:
apt-get --reinstall install x-ttcidfont-conf
 
Old 08-17-2006, 11:01 AM   #8
cougyr
Member
 
Registered: Nov 2003
Posts: 98

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by nx5000
Ok
What do you mean by legasy instructions hanging around?
This install started out as Libranet 2.8.0 several years ago. I've done my apt-get upgrades many times. I can't find any Libranet at this point, but who can guess what links are left behind.


Quote:
Maybe these directories don't exist on your system?
Try this:
Code:
apt-get --reinstall install x-ttcidfont-conf
If they don't exist, why is it looking?

I thought that last instruction would work, but here's what I got:

Quote:
Could not init font path element /usr/share/fonts/truetype/, removing from list!
Could not init font path element /var/lib/defoma/x-ttcidfont-conf.d/dirs/CID, removing from list!
Could not init font path element /usr/share/fonts/X11/TTF/, removing from list!
Could not init font path element /usr/share/fonts/X11/OTF, removing from list!
Could not init font path element /usr/share/fonts/X11/CID/, removing from list!
 
Old 08-17-2006, 12:51 PM   #9
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
What exactly are your problems? Because these messages are warnings! I also have one or two of these and have no problem whatsoever.Anyway.

Quote:
If they don't exist, why is it looking?
Because its in your xorg configuration file

1)For /usr/share/fonts/truetype/ , have a look there:
http://packages.debian.org/cgi-bin/s...sting&arch=all
you should download for example the package ttf-bitstream-vera

2)
On testing, the package I adviced you doesn't contain the file:
http://packages.debian.org/cgi-bin/s...sting&arch=all
While it does on unstable:
http://packages.debian.org/cgi-bin/s...table&arch=all
So no real clue for this one, I'm using unstable.

3)
Remove all references to /usr/share/fonts/X11/ in xorg.conf

Other solution:
Have a look at your xorg configuration file, there could be some advice on the first line on how to reconfigure xorg.
You seem to have the configuration file of unstable on an etch system.
 
Old 08-17-2006, 03:21 PM   #10
cougyr
Member
 
Registered: Nov 2003
Posts: 98

Original Poster
Rep: Reputation: 15
The reason I got into this is that my aterm was coming up all boxes because the fonts didn't work. I found a font that works, but figured that I would try to straighten out the mess.

I thought that xorg 7 used /usr/share/fonts/X11/.

My xorg.conf is actually XFree86.conf. For some reason, when I did the upgrade, it just renamed the old config.
 
Old 08-18-2006, 07:17 AM   #11
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
Originally Posted by cougyr
The reason I got into this is that my aterm was coming up all boxes because the fonts didn't work. I found a font that works, but figured that I would try to straighten out the mess.

I thought that xorg 7 used /usr/share/fonts/X11/.
And you are right . (hence the fonts.dir inside for X11) Sorry for the wrong advice. Remove only the reference to the three lines you mentionned
Quote:
Could not init font path element /usr/share/fonts/X11/TTF/, removing from list!
Could not init font path element /usr/share/fonts/X11/OTF, removing from list!
Could not init font path element /usr/share/fonts/X11/CID/, removing from list!
Quote:
My xorg.conf is actually XFree86.conf. For some reason, when I did the upgrade, it just renamed the old config.
Humm I think the difference is only on the font directories, before they were using /usr/X11R6 I think.
So do it yourself or use the automatic reconfigure tool:
dpkg-reconfigure -phigh xserver-xorg
 
Old 08-18-2006, 10:58 AM   #12
cougyr
Member
 
Registered: Nov 2003
Posts: 98

Original Poster
Rep: Reputation: 15
Thankyou for your replies.

I think the xorg96 to 7 Wiki is incomplete. Judging from my Google responses, there are frequent problems with fonts when migrating up. As usual, the documentation is lagging behind the changes. I'm trying to sort mine out now partly because I like a clean install and partly because future upgrades will build upon what I have.
 
Old 08-19-2006, 01:33 AM   #13
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,591

Rep: Reputation: 162Reputation: 162
You can use dselect to reinstall the fonts. The problem is the soft links get lost, and xorg 7 doesn't keep track of these and put them back properly. So, you have to reinstall the fonts and xorg itself after you upgrade to etch. It's really not that hard. In dselect you hit / to search and \ to repeat search.
 
Old 08-19-2006, 09:38 PM   #14
cougyr
Member
 
Registered: Nov 2003
Posts: 98

Original Poster
Rep: Reputation: 15
Hey, it's working better. My aterm can use my fonts again. One of the tips above (I'm not sure which one) has enabled mkfontscale and mkfontdir to do what they are supposed to. Thanks all for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installing ttf fonts in debian(etch).... deepclutch Debian 0 07-24-2006 03:01 PM
xorg replacing xfree86 on Sarge/Etch causing upgrade problems farpoint Debian 5 06-29-2006 09:45 PM
multi screen etch and xorg.conf knobby67 Debian 2 06-23-2006 12:54 PM
Installing XFree86 on Etch (xorg was installed as default) BillyGalbreath Debian 7 03-20-2006 09:59 PM
upgraded to etch, xorg causing errors, HELP!!! microsoft/linux Debian 10 09-27-2005 06:02 PM


All times are GMT -5. The time now is 09:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration