LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-19-2006, 03:17 AM   #1
max_mad
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSE Linux 9.3
Posts: 21

Rep: Reputation: 15
Etch KDE 3.5.3 CUPS


Hello, I changed to Debian/Etch with KDE 3.5.3
CUPS is installed and running, printing from within oO is possible: lp0 with lex and HPDJ895.
Cannot print from any KDE-related application (Kate, Acroread,Firefox): Print error.
Trying to install a printer with KDE:

Liste der Drucker lässt sich nicht übertragen. Fehlermeldung des
Verwaltungsprogramms:
Verbindung zu CUPS-Server fehlgeschlagen. Überprüfen Sie, ob der CUPS-Server
korrekt installiert wurde und aktiv ist. Fehler: Rechner ist nicht
auffindbar.
List of printers could not be found. No connection to CUPS-SERVER. Check installation.

Additional error-reports:

Erstellung eines temporären Druckers nicht möglich.
No installation of temporary printer possible

Erstellung des Druckeranschlusses ist nicht möglich. Fehlermeldung des
Verwaltungsprogramms:
client-error-bad-request

The lpq returns:
lpq: lp: unknown printer

Any clue?
Thank you for helping
Max
 
Old 08-19-2006, 08:11 AM   #2
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
If you have been getting
Quote:
Unable to retrieve the printer list. Error message received from manager:
Connection to CUPS server failed. Check that the CUPS server is correctly installed and running. Error: the IPP request failed for an unknown reason.
when trying to run kdeprint here is a fix:

edit
Code:
/etc/cups/cupsd.conf
and comment out the line
Quote:
Listen /var/run/cups/cups.sock
(Its within the first 20 lines - line17 on mine)

Finally

Code:
/etc/init.d/cupsys restart
Then open kdeprint. The error should be gone
 
Old 08-19-2006, 09:16 AM   #3
max_mad
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSE Linux 9.3
Posts: 21

Original Poster
Rep: Reputation: 15
Thank you!
Everything is working fine now!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Etch and KDE 3.5 slowness knowledgeispwr Debian 3 11-19-2006 12:03 PM
XGL on Debian Etch with KDE RodWC Debian 1 08-10-2006 02:27 PM
cups broken in kde? Using Etch mohtech Debian 3 07-09-2006 10:54 PM
Major update in etch (kde 3.5) acanton Debian 24 02-21-2006 02:26 AM
Has the KDE 3.4 upgrade in Etch broken anything for you? vharishankar Debian 12 12-15-2005 08:33 PM


All times are GMT -5. The time now is 04:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration