LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-16-2007, 01:01 AM   #1
chip&chop
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Rep: Reputation: 0
Etch - Black screen with nvidia drivers.


Hi all.
I just tried to install the drivers for my nforce 430/geforce 6150 videocard(nvidia). I did exactely as the Debian Wiki, but, once the pc restarts, i obtain a black screen at x server loading. I cant see anything, but i can say my monitor remains ON which means it receives a signal else it would turn off itself after some seconds. I tried also lowering H/V refresh rates, but it didnt help, i got the correct refresh rates with the command xvidtune, and those work fine, i use em in windows. I checked it doesnt load DRI. I re-installed again...still black screen at startup. Tried reconfiguring the xserver with "dpkg-reconfigure xserver-xorg", it didnt work. No idea how to fix it.
I also have a problem with the resolution and refresh rate, it seems once logged-in i can only chose a couple of resolution (1024x and 1152x, sometime only 1024x) and only a refresh of 75 or 85hz, when it should be much higher, like 120 at 1024px.
This is my current xorg.conf(if i use the nv driver it does work, framebuffer ON of OFF it doesnt work both ways):
Code:
Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"v4l"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"it"
	Option		"XkbVariant"	"---..*òò**ùù"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "Device"
	Identifier	"MPC6150"
	Driver		"nvidia"
	BusID		"PCI:0:13:0"
	VideoRam	256000
	Option		"UseFBDev"		"true"
EndSection

Section "Monitor"
	Identifier	"Viewsonic P97f+"
	Option		"DPMS"
	HorizSync	60-75
	VertRefresh	75-150
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"MPC6150"
	Monitor		"Viewsonic P97f+"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection
My Xorg.0.log
Code:
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: UNKNOWN 
Current Operating System: Linux debian 2.6.18-4-k7 #1 SMP Mon Mar 26 17:57:15 UTC 2007 i686
Build Date: 04 April 2007
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 16 07:22:45 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Viewsonic P97f+"
(**) |   |-->Device "MPC6150"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/X11R6/lib/X11/fonts/misc" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi/" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi/" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/Type1" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi" does not exist.
	Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/75dpi" does not exist.
	Entry deleted from font path.
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
	Entry deleted from font path.
(**) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi
(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.3
	X.Org Video Driver: 1.0
	X.Org XInput driver : 0.6
	X.Org Server Extension : 0.3
	X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org Video Driver, version 1.0
(++) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 10de,03ea card 1849,03ea rev a1 class 05,00,00 hdr 00
(II) PCI: 00:01:0: chip 10de,03e0 card 1849,03e0 rev a2 class 06,01,00 hdr 80
(II) PCI: 00:01:1: chip 10de,03eb card 1849,03eb rev a2 class 0c,05,00 hdr 80
(II) PCI: 00:01:2: chip 10de,03f5 card 1849,03eb rev a2 class 05,00,00 hdr 80
(II) PCI: 00:02:0: chip 10de,03f1 card 1849,03f1 rev a2 class 0c,03,10 hdr 80
(II) PCI: 00:02:1: chip 10de,03f2 card 1849,03f2 rev a2 class 0c,03,20 hdr 80
(II) PCI: 00:04:0: chip 10de,03f3 card 0000,0000 rev a1 class 06,04,01 hdr 01
(II) PCI: 00:05:0: chip 10de,03f0 card 1849,0888 rev a2 class 04,03,00 hdr 80
(II) PCI: 00:06:0: chip 10de,03ec card 1849,03ec rev a2 class 01,01,8a hdr 00
(II) PCI: 00:07:0: chip 10de,03ef card 1849,03ef rev a2 class 06,80,00 hdr 00
(II) PCI: 00:08:0: chip 10de,03f6 card 1849,03f6 rev a2 class 01,01,85 hdr 80
(II) PCI: 00:08:1: chip 10de,03f6 card 1849,03f6 rev a2 class 01,01,85 hdr 80
(II) PCI: 00:09:0: chip 10de,03e8 card 0000,0000 rev a2 class 06,04,00 hdr 01
(II) PCI: 00:0b:0: chip 10de,03e9 card 0000,0000 rev a2 class 06,04,00 hdr 01
(II) PCI: 00:0c:0: chip 10de,03e9 card 0000,0000 rev a2 class 06,04,00 hdr 01
(II) PCI: 00:0d:0: chip 10de,03d0 card 1849,03d0 rev a2 class 03,00,00 hdr 00
(II) PCI: 00:18:0: chip 1022,1100 card 0000,0000 rev 00 class 06,00,00 hdr 80
(II) PCI: 00:18:1: chip 1022,1101 card 0000,0000 rev 00 class 06,00,00 hdr 80
(II) PCI: 00:18:2: chip 1022,1102 card 0000,0000 rev 00 class 06,00,00 hdr 80
(II) PCI: 00:18:3: chip 1022,1103 card 0000,0000 rev 00 class 06,00,00 hdr 80
(II) PCI: End of PCI scan
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:1:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(II) Subtractive PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:4:0), (0,1,1), BCTRL: 0x0202 (VGA_EN is cleared)
(II) PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:9:0), (0,2,2), BCTRL: 0x0002 (VGA_EN is cleared)
(II) PCI-to-PCI bridge:
(II) Bus 3: bridge is at (0:11:0), (0,3,3), BCTRL: 0x0002 (VGA_EN is cleared)
(II) PCI-to-PCI bridge:
(II) Bus 4: bridge is at (0:12:0), (0,4,4), BCTRL: 0x0002 (VGA_EN is cleared)
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:24:0), (0,0,4), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
	[0] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
(--) PCI:*(0:13:0) nVidia Corporation unknown chipset (0x03d0) rev 162, Mem @ 0xde000000/24, 0xc0000000/28, 0xdd000000/24, BIOS @ 0xdffc0000/17
(II) Addressable bus resource ranges are
	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
	[1] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
	[0] -1	0	0xdfff7000 - 0xdfff7fff (0x1000) MX[B]
	[1] -1	0	0xdfffc000 - 0xdfffcfff (0x1000) MX[B]
	[2] -1	0	0xdfffd000 - 0xdfffdfff (0x1000) MX[B]
	[3] -1	0	0xdfff8000 - 0xdfffbfff (0x4000) MX[B]
	[4] -1	0	0xdfffec00 - 0xdfffecff (0x100) MX[B]
	[5] -1	0	0xdffff000 - 0xdfffffff (0x1000) MX[B]
	[6] -1	0	0xdffc0000 - 0xdffdffff (0x20000) MX[B](B)
	[7] -1	0	0xdd000000 - 0xddffffff (0x1000000) MX[B](B)
	[8] -1	0	0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
	[9] -1	0	0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
	[10] -1	0	0x0000d000 - 0x0000d00f (0x10) IX[B]
	[11] -1	0	0x00000ee0 - 0x00000ee3 (0x4) IX[B]
	[12] -1	0	0x00000ec0 - 0x00000ec7 (0x8) IX[B]
	[13] -1	0	0x00000ea0 - 0x00000ea3 (0x4) IX[B]
	[14] -1	0	0x00000e80 - 0x00000e87 (0x8) IX[B]
	[15] -1	0	0x0000d880 - 0x0000d88f (0x10) IX[B]
	[16] -1	0	0x00000e60 - 0x00000e63 (0x4) IX[B]
	[17] -1	0	0x00000e40 - 0x00000e47 (0x8) IX[B]
	[18] -1	0	0x00000e20 - 0x00000e23 (0x4) IX[B]
	[19] -1	0	0x00000e00 - 0x00000e07 (0x8) IX[B]
	[20] -1	0	0x0000e480 - 0x0000e487 (0x8) IX[B]
	[21] -1	0	0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
	[22] -1	0	0x00006000 - 0x0000603f (0x40) IX[B]
	[23] -1	0	0x00005000 - 0x0000503f (0x40) IX[B]
	[24] -1	0	0x0000ec00 - 0x0000ec3f (0x40) IX[B]
(II) Active PCI resource ranges after removing overlaps:
	[0] -1	0	0xdfff7000 - 0xdfff7fff (0x1000) MX[B]
	[1] -1	0	0xdfffc000 - 0xdfffcfff (0x1000) MX[B]
	[2] -1	0	0xdfffd000 - 0xdfffdfff (0x1000) MX[B]
	[3] -1	0	0xdfff8000 - 0xdfffbfff (0x4000) MX[B]
	[4] -1	0	0xdfffec00 - 0xdfffecff (0x100) MX[B]
	[5] -1	0	0xdffff000 - 0xdfffffff (0x1000) MX[B]
	[6] -1	0	0xdffc0000 - 0xdffdffff (0x20000) MX[B](B)
	[7] -1	0	0xdd000000 - 0xddffffff (0x1000000) MX[B](B)
	[8] -1	0	0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
	[9] -1	0	0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
	[10] -1	0	0x0000d000 - 0x0000d00f (0x10) IX[B]
	[11] -1	0	0x00000ee0 - 0x00000ee3 (0x4) IX[B]
	[12] -1	0	0x00000ec0 - 0x00000ec7 (0x8) IX[B]
	[13] -1	0	0x00000ea0 - 0x00000ea3 (0x4) IX[B]
	[14] -1	0	0x00000e80 - 0x00000e87 (0x8) IX[B]
	[15] -1	0	0x0000d880 - 0x0000d88f (0x10) IX[B]
	[16] -1	0	0x00000e60 - 0x00000e63 (0x4) IX[B]
	[17] -1	0	0x00000e40 - 0x00000e47 (0x8) IX[B]
	[18] -1	0	0x00000e20 - 0x00000e23 (0x4) IX[B]
	[19] -1	0	0x00000e00 - 0x00000e07 (0x8) IX[B]
	[20] -1	0	0x0000e480 - 0x0000e487 (0x8) IX[B]
	[21] -1	0	0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
	[22] -1	0	0x00006000 - 0x0000603f (0x40) IX[B]
	[23] -1	0	0x00005000 - 0x0000503f (0x40) IX[B]
	[24] -1	0	0x0000ec00 - 0x0000ec3f (0x40) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0xdfff7000 - 0xdfff7fff (0x1000) MX[B]
	[5] -1	0	0xdfffc000 - 0xdfffcfff (0x1000) MX[B]
	[6] -1	0	0xdfffd000 - 0xdfffdfff (0x1000) MX[B]
	[7] -1	0	0xdfff8000 - 0xdfffbfff (0x4000) MX[B]
	[8] -1	0	0xdfffec00 - 0xdfffecff (0x100) MX[B]
	[9] -1	0	0xdffff000 - 0xdfffffff (0x1000) MX[B]
	[10] -1	0	0xdffc0000 - 0xdffdffff (0x20000) MX[B](B)
	[11] -1	0	0xdd000000 - 0xddffffff (0x1000000) MX[B](B)
	[12] -1	0	0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
	[13] -1	0	0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
	[14] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[15] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
	[16] -1	0	0x0000d000 - 0x0000d00f (0x10) IX[B]
	[17] -1	0	0x00000ee0 - 0x00000ee3 (0x4) IX[B]
	[18] -1	0	0x00000ec0 - 0x00000ec7 (0x8) IX[B]
	[19] -1	0	0x00000ea0 - 0x00000ea3 (0x4) IX[B]
	[20] -1	0	0x00000e80 - 0x00000e87 (0x8) IX[B]
	[21] -1	0	0x0000d880 - 0x0000d88f (0x10) IX[B]
	[22] -1	0	0x00000e60 - 0x00000e63 (0x4) IX[B]
	[23] -1	0	0x00000e40 - 0x00000e47 (0x8) IX[B]
	[24] -1	0	0x00000e20 - 0x00000e23 (0x4) IX[B]
	[25] -1	0	0x00000e00 - 0x00000e07 (0x8) IX[B]
	[26] -1	0	0x0000e480 - 0x0000e487 (0x8) IX[B]
	[27] -1	0	0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
	[28] -1	0	0x00006000 - 0x0000603f (0x40) IX[B]
	[29] -1	0	0x00005000 - 0x0000503f (0x40) IX[B]
	[30] -1	0	0x0000ec00 - 0x0000ec3f (0x40) IX[B]
(II) LoadModule: "bitmap"
(II) Reloading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/lib/xorg/modules/libddc.so
(II) Module ddc: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org Video Driver, version 1.0
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
	compiled for 7.1.1, module version = 2.1.0
	Module class: X.Org Font Renderer
	ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.8776
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/lib/xorg/modules/libint10.so
(II) Module int10: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org Video Driver, version 1.0
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 0.3
(II) Loading extension RECORD
(II) LoadModule: "v4l"
(II) Loading /usr/lib/xorg/modules/drivers/v4l_drv.so
(II) Module v4l: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 0.1.1
	ABI class: X.Org Video Driver, version 1.0
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules/libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.1.0
	ABI class: X.Org Video Driver, version 1.0
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.8776
	Module class: X.Org Video Driver
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.1.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.1.1
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 0.6
(II) v4l driver for Video4Linux
(II) NVIDIA X Driver  1.0-8776  Mon Oct 16 21:58:46 PDT 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 00:0d:0
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/lib/xorg/modules/libramdac.so
(II) Module ramdac: vendor="X.Org Foundation"
	compiled for 7.1.1, module version = 0.1.0
	ABI class: X.Org Video Driver, version 1.0
(II) resource ranges after xf86ClaimFixedResources() call:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0xdfff7000 - 0xdfff7fff (0x1000) MX[B]
	[5] -1	0	0xdfffc000 - 0xdfffcfff (0x1000) MX[B]
	[6] -1	0	0xdfffd000 - 0xdfffdfff (0x1000) MX[B]
	[7] -1	0	0xdfff8000 - 0xdfffbfff (0x4000) MX[B]
	[8] -1	0	0xdfffec00 - 0xdfffecff (0x100) MX[B]
	[9] -1	0	0xdffff000 - 0xdfffffff (0x1000) MX[B]
	[10] -1	0	0xdffc0000 - 0xdffdffff (0x20000) MX[B](B)
	[11] -1	0	0xdd000000 - 0xddffffff (0x1000000) MX[B](B)
	[12] -1	0	0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
	[13] -1	0	0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
	[14] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[15] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
	[16] -1	0	0x0000d000 - 0x0000d00f (0x10) IX[B]
	[17] -1	0	0x00000ee0 - 0x00000ee3 (0x4) IX[B]
	[18] -1	0	0x00000ec0 - 0x00000ec7 (0x8) IX[B]
	[19] -1	0	0x00000ea0 - 0x00000ea3 (0x4) IX[B]
	[20] -1	0	0x00000e80 - 0x00000e87 (0x8) IX[B]
	[21] -1	0	0x0000d880 - 0x0000d88f (0x10) IX[B]
	[22] -1	0	0x00000e60 - 0x00000e63 (0x4) IX[B]
	[23] -1	0	0x00000e40 - 0x00000e47 (0x8) IX[B]
	[24] -1	0	0x00000e20 - 0x00000e23 (0x4) IX[B]
	[25] -1	0	0x00000e00 - 0x00000e07 (0x8) IX[B]
	[26] -1	0	0x0000e480 - 0x0000e487 (0x8) IX[B]
	[27] -1	0	0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
	[28] -1	0	0x00006000 - 0x0000603f (0x40) IX[B]
	[29] -1	0	0x00005000 - 0x0000503f (0x40) IX[B]
	[30] -1	0	0x0000ec00 - 0x0000ec3f (0x40) IX[B]
(II) resource ranges after probing:
	[0] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0xdfff7000 - 0xdfff7fff (0x1000) MX[B]
	[5] -1	0	0xdfffc000 - 0xdfffcfff (0x1000) MX[B]
	[6] -1	0	0xdfffd000 - 0xdfffdfff (0x1000) MX[B]
	[7] -1	0	0xdfff8000 - 0xdfffbfff (0x4000) MX[B]
	[8] -1	0	0xdfffec00 - 0xdfffecff (0x100) MX[B]
	[9] -1	0	0xdffff000 - 0xdfffffff (0x1000) MX[B]
	[10] -1	0	0xdffc0000 - 0xdffdffff (0x20000) MX[B](B)
	[11] -1	0	0xdd000000 - 0xddffffff (0x1000000) MX[B](B)
	[12] -1	0	0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
	[13] -1	0	0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
	[14] 0	0	0x000a0000 - 0x000affff (0x10000) MS[B]
	[15] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[B]
	[16] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[B]
	[17] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[18] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
	[19] -1	0	0x0000d000 - 0x0000d00f (0x10) IX[B]
	[20] -1	0	0x00000ee0 - 0x00000ee3 (0x4) IX[B]
	[21] -1	0	0x00000ec0 - 0x00000ec7 (0x8) IX[B]
	[22] -1	0	0x00000ea0 - 0x00000ea3 (0x4) IX[B]
	[23] -1	0	0x00000e80 - 0x00000e87 (0x8) IX[B]
	[24] -1	0	0x0000d880 - 0x0000d88f (0x10) IX[B]
	[25] -1	0	0x00000e60 - 0x00000e63 (0x4) IX[B]
	[26] -1	0	0x00000e40 - 0x00000e47 (0x8) IX[B]
	[27] -1	0	0x00000e20 - 0x00000e23 (0x4) IX[B]
	[28] -1	0	0x00000e00 - 0x00000e07 (0x8) IX[B]
	[29] -1	0	0x0000e480 - 0x0000e487 (0x8) IX[B]
	[30] -1	0	0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
	[31] -1	0	0x00006000 - 0x0000603f (0x40) IX[B]
	[32] -1	0	0x00005000 - 0x0000503f (0x40) IX[B]
	[33] -1	0	0x0000ec00 - 0x0000ec3f (0x40) IX[B]
	[34] 0	0	0x000003b0 - 0x000003bb (0xc) IS[B]
	[35] 0	0	0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
Thanks.
 
Old 04-16-2007, 06:03 AM   #2
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,672

Rep: Reputation: 122Reputation: 122
Okay, change your settings back to the nv driver at 1024*768 so you'll have something to look at I've tried installing the nVidia driver the Debian way (I used the same wiki you did), but it failed several times so I did it the tried and trusted way of nVidia's own installer. Some have problems with that and report it as "buggy" but I found it's quite stable.
 
Old 04-16-2007, 06:09 AM   #3
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Rep: Reputation: 30
When you try to log in and get the black screen, you can switch to a terminal prompt by holding Ctrl+Alt+F1. Log in and change you nvidia to nv or vesa.
 
Old 04-16-2007, 08:11 AM   #4
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Quote:
Option "UseFBDev" "true"
If you are using the nvidia driver, why would you use the option of FrameBuffer Device?
I would remove this line as fbdev refers to a NON-accelerated video driver, which to my thinking would be a conflict.
Quote:
fbdev(4) is a non-accelerated driver which runs on top of the fbdevhw module. fbdevhw can be used by other drivers too, this is usually activated with `Option "UseFBDev"' in the device section..

Also according the the manual for your monitor the refresh rates are as follows. .
HorizSync 30-110
VertRefresh 50-160


Incorrect setting in these refresh rate fields can cause your display not to function properly..
http://www.viewsonic.com/pdf/usergui...s-1_ug_eng.pdf
 
Old 04-16-2007, 10:32 AM   #5
chip&chop
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for the replies.

Fixed refresh rates with those values. About "UseFBDev" i just tried it to see if it works, well it didnt (btw thats the framebuffer im talking about in my first post).

Ctrl+Alt+F1 doesnt seem to work since i still see a black screen. But thanks anyway, i already accessed linux and edited xorg.conf from Windows with the ext2 driver and i did substitutued nvidia with nv. With nv or vesa it works. I just cant get it to work with the nvidia.

So, at the end, still black screen. This is my current xorg.conf:
Code:
Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"v4l"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"it"
	Option		"XkbVariant"	"---..*òò**ùù"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "Device"
	Identifier	"MPC6150"
	Driver		"nvidia"
	BusID		"PCI:0:13:0"
	VideoRam	256000
EndSection

Section "Monitor"
	Identifier	"Viewsonic P97f+"
	Option		"DPMS"
	HorizSync 30-110
	VertRefresh 50-160
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"MPC6150"
	Monitor		"Viewsonic P97f+"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection
EDIT: At least now i can select more resolutions, the strange thing is that there are lots more resolutions that i've actually selected in the xorg.conf O_o. The only refresh rates selectable still are 75 and 85hz. Hmm.

Last edited by chip&chop; 04-16-2007 at 10:47 AM.
 
Old 04-16-2007, 12:14 PM   #6
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
When X is started CTRL+ALT+F1 will not get you to a terminal..
you would need to use CTRL+ALT+F2 through CTRL+ALT+F6.

CTRL+ALT+F7 would return you to your running X-session after switching to a different virtual terminal session.

You installed the nvidia drivers using the module assistant I assume.. did you also install nvidia-glx after installing the drivers ?



basically it should have proceeded like this.. their how-to's drive me nuts because they jump around and split up the parts of the install process..

CTRL+ALT+F2 to switch to a terminal then log in as root
/etc/init.d/gdm stop
aptitude keep-all
aptitude update
aptitude install module-assistant gcc nvidia-kernel-source
m-a update
m-a prepare
m-a a-i nvidia
aptitude install nvidia-glx

edit your /etc/X11/xorg.conf

nano /etc/X11/xorg.conf

Comment out any lines pertaining to dri or glcore in the modules section
# load "dri"
# load "glcore"


edit the device section and change the driver to "nvidia"

Make sure the refresh rates are correct for your display...
Consult the owners manual or manufacturers website for this information.

save the changes to your xorg.conf file then restart gdm.

/etc/init.d/gdm start


Should be that easy, and since your xorg.conf file is already edited that part you can skip at this point..
If you did the driver install correctly I'm not sure why it isn't working for you at this point..
 
Old 04-16-2007, 02:01 PM   #7
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,238

Rep: Reputation: 121Reputation: 121
Quote:
When X is started CTRL+ALT+F1 will not get you to a terminal..
You might want to check the F1 key on your keyboard.
 
Old 04-16-2007, 02:22 PM   #8
chip&chop
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Re-installed following your mini-guide, but still got black screen.

edit: it's not a tragedy because i can use the nv driver, but with the nvidia it works smoother and i dont understand why i shouldnt be able to use it. I read somewhere googling that there's a bug with a certain driver version. Since i dont know what version i installed, how could i try another version, maybe an old one?

Last edited by chip&chop; 04-16-2007 at 02:25 PM.
 
Old 04-16-2007, 03:52 PM   #9
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
you could purge the nvidia-glx package then go download the Linux driver directly from nVidia and install it.. How about the newest version ?

http://www.nvidia.com/object/unix.html

Drop to a shell

CTRL+ALT+F2
Login as root

/etc/init.d/gdm stop
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.chipchop
aptitude purge nvidia-glx
wget http://us.download.nvidia.com/XFree8...-9755-pkg1.run
chmod +x NVIDIA-Linux-x86-1.0-9755-pkg1.run
./NVIDIA-Linux-x86-1.0-9755-pkg1.run


Follow the prompts through the install script, you can let the script modify your xorg.conf (since we backed up your original in step 2)

Once the script completes successfully the driver should be installed and working.. I don't believe you need to reboot, so go ahead and try starting X again..

/etc/init.d/gdm start

Last edited by farslayer; 04-16-2007 at 03:53 PM.
 
Old 04-16-2007, 10:17 PM   #10
chip&chop
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Alright that worked at first try! Thank You All! Now im happier watching that "nice" nvidia logo at startup..
So, the moral is: if you have troubles the Debian way, use the normal nvidia installer and it'll prob'ly work. Problem solved.

---------------------------------------------------------

The only little problem that remains is the selectable refresh rates from x, eventho i set in xorg.conf:

HorizSync 30-110
VertRefresh 50-160

I get at 1152x864 only 71hz, when in windows i can set it at 100hz and more. Perhaps i must force the resolution/refresh in the conf file without giving it a min-max but just a number appropriate to the resolution i want? I'd prefer another way...

Last edited by chip&chop; 04-16-2007 at 10:23 PM.
 
Old 04-16-2007, 10:42 PM   #11
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Glad that worked for you.

now if you want to generate specific resolution / Refresh rate settings you should use mode-lines.

http://julipedia.blogspot.com/2007/0...generator.html

mode-line generators
http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
http://www.sh.nu/nvidia/gtf.php

Last edited by farslayer; 04-16-2007 at 10:44 PM.
 
Old 04-16-2007, 11:27 PM   #12
chip&chop
LQ Newbie
 
Registered: Apr 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Ok, tried that but i still have only 52hz, 71 and 72hz selectable. But maybe i didnt configured the xorg.conf correctly, do i have to delete the other resolutions? This is my current xorg.conf with the mode-line added:
Code:
Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"v4l"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"it"
	Option		"XkbVariant"	"---.."
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "Device"
	Identifier	"MPC6150"
	Driver		"nvidia"
	BusID		"PCI:0:13:0"
	VideoRam	256000
EndSection

Section "Monitor"
	Identifier	"Viewsonic p97f+"
	Option		"DPMS"
	HorizSync	30-110
	VertRefresh	50-160
	# 1152x864 @ 100.00 Hz (GTF) hsync: 91.50 kHz; pclk: 143.47 MHz
	Modeline "1152x864_100.00"  143.47  1152 1232 1360 1568  864 865 868 915  -HSync +Vsync
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"MPC6150"
	Monitor		"Viewsonic p97f+"
	DefaultDepth	24
	SubSection "Display"
		Depth		16
		Modes		"1600x1200" "1280x1024" "1152x864" "1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1600x1200" "1280x1024" "1152x864" "1024x768" "800x600"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection
 
Old 04-17-2007, 07:51 AM   #13
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
from looking at several well commented configs it appears you should change the modes in the "Screen" Section to match the mode-lines you generated.

Code:
SubSection "Display"
		Depth		16
		Modes		"1152x864_100.00" "1024x768" "800x600"
	EndSubSection

examples
http://voltaire.nfshost.com/transfer/xorg.conf
 
Old 04-17-2007, 11:13 AM   #14
Piccolo_Pete
LQ Newbie
 
Registered: Jun 2005
Location: Boston
Distribution: Mandriva 2008.1
Posts: 26

Rep: Reputation: 15
Well, I'm glad to hear that someone else is having the same problem, I thought I was the only one.
 
Old 04-17-2007, 12:06 PM   #15
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Quote:
Originally Posted by Piccolo_Pete
Well, I'm glad to hear that someone else is having the same problem, I thought I was the only one.

Well this thread is pretty complete..
covering both the Debian way of installing the drivers as well as the nVidia method..

Follow along and see if it will help resolve your issue, then post back in your original thread (referencing this one as things you've tried.) and hopefully we can get you up and running too

I've used both methods for installing drivers on Etch and they both work, so theres hope for your system yet
 
  


Reply

Tags
debian, modeline, monitor, nvidia drivers, refresh


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia drivers 8178 cause black screen (10.0) duncky Suse/Novell 35 03-24-2006 06:18 AM
Black screen after installing nvidia 6106 drivers Doktor Prokt Fedora 7 08-10-2004 04:39 AM
Weird...Riva TNT2 Black Screen Nvidia Drivers... Skorpyo Linux - Newbie 2 01-30-2004 06:53 AM
new nvidia drivers bring black screen brandonloserkid Slackware 4 01-20-2004 08:35 PM
redhat 9 geforce 4 mx 440 nvidia drivers black screen baronsam Linux - Software 9 11-06-2003 07:04 PM


All times are GMT -5. The time now is 11:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration