LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-22-2007, 06:47 AM   #1
knobby67
Member
 
Registered: Mar 2006
Posts: 546

Rep: Reputation: 42
Etch and turning off screen saver


Hi all, hope someone can help out.
I've got a new system, installed Etch and all is well except when running video etc the system still goes into screen saver. Once more after a few minuets of screen saver the screen goes blank and won't "wake up".

What I've done

1. in GNOME changed the power save option not to come on
This had no effect.

2. From shell used
a xset s noblank
b setterm -blank 0
c xset s off

xset -q tells me power save is off and screensaver is off.

However it still drops into screen saver but now after a few minuets instead of going to a blank screen and locking it, it goes to a white screen with a large X, this moves every so often. However it still locks up my keyboard and mouse, ie I can't come out of this screen

3. Went into bios and disabled all power save options.
No effect.



Can anyone offer any further advise? Thanks in advance

ps using etch daily build, gnome (think just core)

Last edited by knobby67; 02-22-2007 at 06:50 AM.
 
Old 02-22-2007, 07:04 AM   #2
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,684

Rep: Reputation: 124Reputation: 124
Changing settings in X only take effect after a restart. The easiest way is rebooting your system.
 
Old 02-22-2007, 09:04 AM   #3
knobby67
Member
 
Registered: Mar 2006
Posts: 546

Original Poster
Rep: Reputation: 42
Quote:
Originally Posted by Dutch Master
Changing settings in X only take effect after a restart. The easiest way is rebooting your system.
Hi,
so I ran
xset s noblank
setterm -blank 0
xset s off
xset -dpms

restarted X, and the screen saver is still coming on.

xset -q says
DPMS (Energy star)
standby : 0 suspend: 0 off: 0
DPMS is Enabled
Monitor is Enabled
Monitor is on

Am I missing something? Thanks. (sure I never had this trouble in sarge)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Goes Blan Instead Of Screen Saver mrkstapleton Suse/Novell 7 09-24-2006 11:25 AM
ATI 9200 SE screen flicker in screen saver gargamel Slackware 12 07-09-2005 05:10 PM
screen saver goes off and screen goes black Doug.Gentry Suse/Novell 2 03-26-2005 06:08 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
Blank screen - screen saver ??? cstehle Linux - Newbie 8 03-13-2002 10:44 PM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration