LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 12-28-2005, 05:18 PM   #1
ravenslay3r
LQ Newbie
 
Registered: Jul 2005
Distribution: Suse
Posts: 7

Rep: Reputation: 0
enable scsi support for removable USB drives? How to?


Ok i just recently reinstalled Debian stable than 'apt-get upgrade'ed to testing.. I have the 2.6 kerenl etc.

I'm trying to use removable USB devices such as a flash HDD, and an IPOD. This worked before I screwed everything up (forcing the reinstall) but I can't get it working now.

My problem is similar to this thread's:http://www.linuxquestions.org/questi...lash+harddrive

Where-in the poster suggests the solution was to "enable scsi generic support. However he offers no clue on how that is accomplished. I also don't know if I have 'scsi disk support' enabled.

if I run 'tail /var/log/messages' i get:
-----------------------------------------

Dec 28 17:04:48 localhost kernel: usb 1-2: new full speed USB device using address 3
Dec 28 17:04:48 localhost kernel: usb 1-2: configuration #1 chosen from 2 choices
Dec 28 17:26:52 localhost -- MARK --
Dec 28 17:33:02 localhost kernel: usb 1-1: new full speed USB device using address 4


The first one is plugging in the IPOD the second is the flash drive. No reference is made to SCSI or sda1 etc. and mounting sda(x) doesn't seem to work.

Any ideas?

Thanks.
 
Old 12-28-2005, 09:07 PM   #2
ravenslay3r
LQ Newbie
 
Registered: Jul 2005
Distribution: Suse
Posts: 7

Original Poster
Rep: Reputation: 0
I guess my question is how do I enable the SCSI support modules in the kernel?

I saw several places that said "turn these options on..." but they never said where or how to turn them on..

thanks
 
Old 12-31-2005, 02:43 AM   #3
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Quote:
Originally Posted by ravenslay3r
I guess my question is how do I enable the SCSI support modules in the kernel?

I saw several places that said "turn these options on..." but they never said where or how to turn them on..

thanks
Bring up a console and become root (su) and then do modconf (if command not found apt-get install modconf). The first line in the menu should be kernel/drivers/scsi modules - select and then go down the list and select scsi_mod and also sd_mod. You can exit. You will probably need to reboot the system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enable or disable legacy USB support johnMG Linux - Hardware 1 04-08-2005 01:16 PM
USB Camera Mandy 9.2 and lack of SCSI support - help? iainagray Linux - Hardware 7 08-02-2004 06:27 AM
does fedora support SCSI hard drives? franklin97355 Fedora - Installation 1 07-31-2004 10:47 AM
K3b says to enable ide-scsi to read from drives but its already doner in lilo Bradster Linux - Software 5 04-21-2004 03:22 AM
Linux Support for USB 2.0 External Hard Drives cblucher Linux - Newbie 9 12-28-2003 10:04 PM


All times are GMT -5. The time now is 05:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration