LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Easy file sharing option in gnome grayed out (http://www.linuxquestions.org/questions/debian-26/easy-file-sharing-option-in-gnome-grayed-out-798934/)

twinkers 03-30-2010 12:31 PM

Easy file sharing option in gnome grayed out
 
I'm using Gnome for the first time (after a long time with KDE) and am trying to share a folder the easy way. After installing nautilus-share (and samba, samba-common and samba-common-bin)I can right click on a folder and make it shared. Problem is that the option 'Guest access (for people with no user account)' is always grayed out.
On some Ubuntu forums I saw people fix it by purging and reinstalling samba but that didn't work for me.

I know how to manually setup a share in samba, just want to figure out why this isn't working and how to get this going.

Regards

twinkers 03-30-2010 04:57 PM

I had a look in /usr/share/doc/nautilus-share/examples/smb.conf and renamed smb.conf to smb.bak and copied the example to /etc/samba/smb.conf. I added everything from smb.bak that doesn't set folder permissions. Final file looks like:

Code:

[global]
workgroup = HOME
security = share

usershare path = /var/lib/samba/usershares
usershare max shares = 100
usershare allow guests = yes
usershare owner only = yes
wins support = no

#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
  log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
  max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
#  syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
  syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
  panic action = /usr/share/samba/panic-action %d

####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/ServerType.html
# in the samba-doc package for details.
#  security = user

# You may wish to use password encryption.  See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
  encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using. 
  passdb backend = tdbsam

  obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
  unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
  passwd program = /usr/bin/passwd %u
  passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
  pam password change = yes


Everything works fine now.

Regards


All times are GMT -5. The time now is 01:16 PM.