LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-21-2004, 12:35 PM   #1
hasanito
LQ Newbie
 
Registered: Sep 2004
Posts: 8

Rep: Reputation: 0
"Dynamic MMap ran out of room" error when adding new apt source list


G'day

I've just installed Debian 3.0
I try to install xfce4 as the desktop manager but my "wajig install xfce" installed xfce3... so I added following apt source list to my source list:

# Unstable
deb ftp.de.debian.org/debian unstable main contrib non-free
deb ftp.de.debian.org/debian-non-US unstable/non-US main contrib non-free

# Testing
deb ftp.de.debian.org/pub/debian testing main contrib non-free
deb ftp.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free

*add http after deb :-)*
but this time I get following error when I do a wajig update:

- - - - - - - - - -
Reading Package Lists... Error!
E: Dynamic MMap ran out of room
E: Error occured while processing orange (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp.de.debian.org_debian_dists_unstable_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.

update available list script returned error exit status 1.
Press <enter> to continue.
- - - - - - - - - -

any help?

cheers

ps:
Alternative to that, how can I install Gnome2+? everytime I try wajig install gnome or gnome core, it can't find it?

cheers
 
Old 09-21-2004, 12:39 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Add the following line to either /etc/apt/apt.conf or /etc/apt/apt.conf.d/70debconf

Code:
APT::Cache-Limit "8388608";
 
Old 09-08-2007, 01:22 PM   #3
Abject
Member
 
Registered: Mar 2002
Location: Studio City, CA
Distribution: Debian (Sarge-Sid)
Posts: 76

Rep: Reputation: 15
Thanks, that will probably work for many folks. Didn't for me, but
Code:
APT::Cache-Limit "16777216";
(... twice the size), did the trick.

- Ab
 
Old 09-08-2007, 02:20 PM   #4
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
I'll raise that to: APT::Cache-Limit 50000000;

Seriously, you can set it to how much you like but keep in mind not to let it fill /var or worse /.
"apt-get clean" or "aptitude clean" now and then would clean up the /var/cache/apt/archives so you can manage with a lower limit.

EDIT: Might want to wade through some of the user's manuals here: http://www.debian.org/doc/index.en.html

Last edited by makuyl; 09-08-2007 at 02:25 PM.
 
Old 10-13-2007, 12:50 PM   #5
MooseMagnet
Member
 
Registered: Oct 2007
Location: U.S.
Distribution: Ubuntu Lucid Lynx 10.04
Posts: 168
Blog Entries: 1

Rep: Reputation: 15
Increases Cache

Howdy:
I had the same problem. I increased the cache size, and it did allow me to run sudo apt-get upgrade. But now my sound card is dead. I've had this problem before many times. I'm running Ubuntu Feisty Fawn on a Dell Laptop. Any way to permanently solve this problem without re-installing XP? Thanks.
 
Old 10-13-2007, 01:06 PM   #6
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,610

Rep: Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518
Quote:
Originally Posted by MooseMagnet View Post
Howdy:
I had the same problem. I increased the cache size, and it did allow me to run sudo apt-get upgrade. But now my sound card is dead. I've had this problem before many times. I'm running Ubuntu Feisty Fawn on a Dell Laptop. Any way to permanently solve this problem without re-installing XP? Thanks.
yes, but your problem is completely unrelated and you need to create your own thread.
 
Old 10-30-2007, 08:50 PM   #7
Aleora
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Rep: Reputation: 0
I am having this same problem, and editing the /etc/apt/apt.conf.d file 70debconf is having no effect. I also ran apt-get clean. The whole error message is:
Reading package lists... Error!
E: Dynamic MMap ran out of room
E: Error occurred while processing xmcd (NewFileVer1)
E: Problem with MergeList /var/lib/apt/lists/ftp.debian.org_debian_dists_testing_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.

which looks a lot like the error message in the original post. Does anyone know what's wrong?
 
Old 10-30-2007, 10:36 PM   #8
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,610

Rep: Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518
up the APT::Cache-Limit more and try again
 
Old 10-31-2007, 07:19 AM   #9
Aleora
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Rep: Reputation: 0
I've taken it up to 20 times what makuyl suggested in jest, and nothing changes.
 
Old 10-31-2007, 12:56 PM   #10
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 59
Quote:
Originally Posted by Aleora View Post
I've taken it up to 20 times what makuyl suggested in jest, and nothing changes.
Can you post what's in your /etc/apt/sources.list file, please?
 
Old 10-31-2007, 01:47 PM   #11
Aleora
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Rep: Reputation: 0
In /etc/apt/sources.list I have this:

#
# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

deb http://ftp.us.debian.org/debian/ etch main
deb-src http://ftp.us.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib
deb ftp://ftp.debian.org/debian unstable main contrib non-free
deb ftp://ftp.debian.org/debian testing main contrib non-free

#Added to get codecs
deb http://mirror.home-dn.net/debian-multimedia stable main
deb-src http://mirror.home-dn.net/debian-multimedia stable main

As a side-note, I am very new to linux (as you have probably guessed) and my boyfriend has most often been the one to make changes. He added some of these- I think everything after the first two...
 
Old 10-31-2007, 02:00 PM   #12
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 59
Ok, well the sources list is a bit of a mess. You have all three branches of Debian enabled (etch/stable, testing and unstable). No matter what else, you probably don't want that. Maybe try to trim it down a bit to this (the # in front of a line makes apt ignore the line):

Quote:
#
# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

#deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

deb http://ftp.us.debian.org/debian/ etch main
deb-src http://ftp.us.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib
deb-src http://security.debian.org/ etch/updates main contrib
#deb ftp://ftp.debian.org/debian unstable main contrib non-free
#deb ftp://ftp.debian.org/debian testing main contrib non-free

#Added to get codecs
#deb http://mirror.home-dn.net/debian-multimedia stable main
#deb-src http://mirror.home-dn.net/debian-multimedia stable main
Still, you should be able to update your sources list if you have made the cache that large. Try again to do "apt-get clean && apt-get update" after trimming down the sources list. My only other guess is that maybe you have /var in a partition that it filled up? I took out the multimedia repos for the moment, just to see if you can get apt working again.
 
Old 10-31-2007, 02:25 PM   #13
Aleora
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Rep: Reputation: 0
So, I went and changed the file as directed. Now it doesn't like the sources.list file, though. It says:
E: Type '' is not known on line 1 in source list /etc/apt/sources.list

When cat sources.list, there is a leading space. When I open it in vi, there isn't, so I can't remove it. *sigh*
 
Old 10-31-2007, 03:24 PM   #14
Telemachos
Member
 
Registered: May 2007
Distribution: Debian
Posts: 754

Rep: Reputation: 59
The whole first line is not needed, so you could open in vim, move up to the first line (you may start there, you may not) and then use "dd" to delete that one line.
 
Old 10-31-2007, 08:49 PM   #15
Aleora
LQ Newbie
 
Registered: Oct 2007
Posts: 7

Rep: Reputation: 0
No difference. Should I maybe make a new file to replace it with?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dynamic MMap ran out of room +APT bassclarinet Debian 3 12-26-2008 07:46 PM
Dynamic MMap out of room dekket Debian 6 12-25-2006 12:23 AM
smbclient "Error returning browse list: NT_STATUS_OK" b0nes Linux - Networking 2 02-18-2005 07:13 AM
Can't "stat source package list" irvken Debian 3 01-31-2005 01:52 PM
apt-get -> testing, errors processing package lists, Dynamic MMap??? gaffel Debian 5 07-16-2004 01:30 PM


All times are GMT -5. The time now is 12:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration