LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-11-2006, 10:40 AM   #1
baldy1324
Member
 
Registered: Aug 2005
Distribution: debian unstable/SID
Posts: 39

Rep: Reputation: 15
Question dpkg wont install gmail-notify b/c depends on obselete python package


hi i just download the gmail-notifer .deb package (http://gmail-notify.sourceforge.net/download.php).

Code:
debian:/home/robert# dpkg -i Desktop/gmail-notify-1.6.deb
Selecting previously deselected package gmail-notify.
(Reading database ... 58566 files and directories currently installed.)
Unpacking gmail-notify (from Desktop/gmail-notify-1.6.deb) ...
dpkg: dependency problems prevent configuration of gmail-notify:
 gmail-notify depends on python2.3-gtk2 (>= 2.2.0); however:
  Package python2.3-gtk2 is not installed.
dpkg: error processing gmail-notify (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 gmail-notify
this installs it but dosent configure even if i run dpkg --configure gmail...

i did an apt-cache show python-gtk2 (the package that i have on my system) and it says it conflicts with python2.3-gtk2. i guess python2.3-gtk2 is replaced by python-gtk2.

please help me
thank you
 
Old 08-11-2006, 01:44 PM   #2
pda_h4x0r
Member
 
Registered: Feb 2006
Location: somewhere in cyberspace
Distribution: Debian, Familiar
Posts: 380

Rep: Reputation: 30
What would happen if you were to install python2.3-gtk2? I think python-gtk2 is a metapackage that refers to the latest python/GTK2 package--replacing it shouldn't be a problem.
 
Old 08-11-2006, 02:00 PM   #3
baldy1324
Member
 
Registered: Aug 2005
Distribution: debian unstable/SID
Posts: 39

Original Poster
Rep: Reputation: 15
python gtk

Code:
debian:/home/robert# apt-get install python2.3-gtk2
Reading package lists... Done
Building dependency tree... Done
Note, selecting python-gtk2 for regex ‘python2.3-gtk2’
python-gtk2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 
Old 08-11-2006, 04:56 PM   #4
pda_h4x0r
Member
 
Registered: Feb 2006
Location: somewhere in cyberspace
Distribution: Debian, Familiar
Posts: 380

Rep: Reputation: 30
Weird. Have you tried this?

# dpkg-reconfigure python2.3-gtk2 gmail-notify
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Depends on Python 2.4 wont install w. 2.4.2-0ubuntu3 computergee Linux - Software 0 06-21-2006 02:19 PM
how to manually install a package when dpkg, apt-get are broken and system wont boot. hisnumber666 Linux - Software 17 05-02-2006 11:12 AM
Gmail Notify troubles - cannot install xTheLostx Linux - Software 2 05-28-2005 07:18 AM
debian dpkg cpp depends on cpp error darkleaf Linux - Software 2 06-25-2004 01:47 AM
URGENT!: vsftpd chroot config wont take changes. Major business depends on this. Help CrewXp Linux - Newbie 5 01-02-2004 07:27 PM


All times are GMT -5. The time now is 06:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration