LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-21-2011, 03:11 PM   #1
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,311

Rep: Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591
Does someone REALLY know how to disable the &&(#_)@(**&%*%#@# screensaver in KDE4?


OK, I am frustrated. Installed Debian Squeeze. I use this system as monitor for a security camera. The screensaver continues to kick in after 10 minutes.

Sure, it's jlinkels again with his non-functioning Linux bs. Not nice to hear.

This is what I did:

- System settings -> Desktop -> Screen saver: disabled
- System settings -> Power Save: Presentation
- System settings -> Power Save -> Profiles -> Presentation: after 280 minutes: do NOTHING
- Deleted xscreensaver*

These were the options I found in several Google results. Still I am getting a black screen after 10 minutes. That is too weird, isn't it?

Now what do I have to do to get NO BLACK SCREEN EVER??

Thanks anyone who knows how to do this in Debian

jlinkels

Edit: in Squeeze it's KDE4.4, right?

Last edited by jlinkels; 02-21-2011 at 03:12 PM.
 
Old 02-21-2011, 04:16 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
I'm not in front of my squeeze box right now, but I feel like there is a separate power setting for the Display only.

And did you remember after changing the power settings to set that as the default power profile?

EDIT: Also, if you just wanted a hack, you could install the xautomation package and create a script that automatically moves the mouse with xte 'mousemove 250 250' or the like.

Last edited by pljvaldez; 02-21-2011 at 04:22 PM.
 
Old 02-22-2011, 08:14 AM   #3
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,311

Original Poster
Rep: Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591
Update:

No, there is no separate power setting for the screen. It is not in Desktop, not in Power Settings, not in Display.

The question whether or not Presentation was selected as default profile makes sense. There is a choice When Running on Power Adapter which let you select a profile. This choice is the only one where a profile can be selected, so I assumed that this would actually select the Presentation profile. How naive

Searching thru other forums I discovered that with Alt-F2 you can start a pop-up where you can enter a command. Entering Power Profile shows a list with profiles to select. How obvious!I selected Presentation. From the system tray a notice popped up that Presentation power profile is selected. Cool!

But the screen still blanks after 10 minutes

Sure I can install xte as suggested by PJValdez (thanks), but isn't it too weird that I cannot prevent the screen from blanking? At this moment I am not even sure that it is KDE4 which kicks in the blanking, but can I expect that when I adjust screen saver settings in a desktop environment, the DE takes care of controlling the underlying layers? In 2011, after 2 years of KDE4 development, releasing one crippled version after the other?

jlinkels

jlinkels
 
Old 02-22-2011, 08:39 AM   #4
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,636
Blog Entries: 29

Rep: Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901Reputation: 901
It may be dumb but what I am getting from your posts is that your display goes to "sleep" after 10 minutes!
 
Old 02-22-2011, 09:02 AM   #5
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,993

Rep: Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347
You should run:
Code:
xset -dpms s off
 
1 members found this post helpful.
Old 02-22-2011, 09:18 AM   #6
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,311

Original Poster
Rep: Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591
Quote:
Originally Posted by Anisha Kaul View Post
It may be dumb but what I am getting from your posts is that your display goes to "sleep" after 10 minutes!
It certainly goes to sleep but not by itself. The monitor (it is a CRT) doesn't have that option. On the previous OS installation (Linspire or so with KDE 3.5) the monitor didn't blank. This also precludes smart BIOS settings.

jlinkels
 
Old 02-22-2011, 12:52 PM   #7
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,311

Original Poster
Rep: Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591
Quote:
Originally Posted by bathory View Post
You should run:
Code:
xset -dpms s off
Yes, you are right, that did it.

What is the most appropriate place to put this command so it will be executed at startup of the desktop? /etc/X11/Xsession?

Thanks, this was very helpful.

jlinkels
 
Old 02-22-2011, 01:39 PM   #8
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,684

Rep: Reputation: 124Reputation: 124
I presume the Xorg config file. I have a similar issue (on Gnome) and found that when the xscreensaver daemon is running, and with the screensaver itself disabled, no blanking occurs.
 
Old 02-22-2011, 04:33 PM   #9
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,993

Rep: Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347Reputation: 1347
Quote:
What is the most appropriate place to put this command so it will be executed at startup of the desktop? /etc/X11/Xsession?
I'm not familiar with gnome but from what I've read you can use Xsession, or create a script and
Quote:
login into a normal gnome session.
In Gnome Control Center->Session->Startup Programs you can add programs or scripts to run when Gnome starts
Also you can set these options in xorg.conf as Dutch Master mentioned above (see Option "BlankTime" and Option "DPMS").

Regards
 
Old 02-24-2011, 12:36 PM   #10
//////
Member
 
Registered: Nov 2005
Location: Land of Linux :: Finland
Distribution: Dual boot :: Slackware 14.1 64bit multilib | Kali linux 64bit multi lib
Posts: 193

Rep: Reputation: 43
Quote:
Originally Posted by bathory View Post
You should run:
Code:
xset -dpms s off
Thanks alot.
 
Old 04-08-2011, 10:39 PM   #11
rshimmel
LQ Newbie
 
Registered: Mar 2011
Posts: 1

Rep: Reputation: 0
Fedora KDE4 Screen Blanking PITA

# Rick: Created 03-29-2011.
# Last Modified: 04-08-2011
# Put this in something like ~/.kde/Autostart/killscreenblanking.sh

#!/bin/sh

# Kill monitor screen after 30 minutes.
xset dpms 1800 1800 1800
# Kill Screen 'blanking'.
xset s noblank

# Then make it executable when 'your user' X environment starts with (minus pound sign and space):
# chmod 754 ~/.kde/Autostart/killscreenblanking.sh
# You only need to do this command when you intially create this file.

# see: "man xset" for options available.
# For example setting "xset dpms 0 0 0" 'should' kill power maagement altogether.
# i.e. not tested by me.
 
Old 07-05-2011, 11:53 AM   #12
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,311

Original Poster
Rep: Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591Reputation: 591
Follow-up:

I think the right place to execute this command is in /etc/X11/Xsession.d.
I created a file 95dpms-set in this directory with the command
Code:
xset -dpms s off
And that works.

However: lately I have been setting up yet another computer which should never blank the screen, and I forgot to set also in KDE Control panel Power Settings that the screen should not be blanked.

So, to avoid screen blanking you have to set up both xset and Power Settings

KDE4 never stops to amaze me. You can set anything from within the GUI, but some settings are overruled by settings in system config files, some are overruled by the GUI settings, some you have to set in both places to make them work.

jlinkels
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screensaver Install Issue [F10 & KDE4] Lnx805 Fedora 0 08-08-2009 03:34 PM
zsnes && logitech dual action gamepad && dpad woes John5788 Linux - Games 5 10-29-2008 10:56 PM
AOL UK && BT Voyager 100 && Slackware 10.2 && RP-PPPoE pitt0071 Linux - Networking 3 01-17-2006 07:10 AM
Japanese canna won't work : Warning: かな漢字変&am OrganicOrange84 Debian 3 06-30-2005 03:28 PM
Phục hồi dữ liệu bị mất???, cứ pollsite General 1 06-27-2005 01:39 PM


All times are GMT -5. The time now is 12:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration