LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Does someone REALLY know how to disable the &&(#_)@(**&%*%#@# screensaver in KDE4? (http://www.linuxquestions.org/questions/debian-26/does-someone-really-know-how-to-disable-the-and-and-_-%40-%2A%2A-and-%2A-%40-screensaver-in-kde4-864104/)

jlinkels 02-21-2011 02:11 PM

Does someone REALLY know how to disable the &&(#_)@(**&%*%#@# screensaver in KDE4?
 
OK, I am frustrated. Installed Debian Squeeze. I use this system as monitor for a security camera. The screensaver continues to kick in after 10 minutes.

Sure, it's jlinkels again with his non-functioning Linux bs. Not nice to hear.

This is what I did:

- System settings -> Desktop -> Screen saver: disabled
- System settings -> Power Save: Presentation
- System settings -> Power Save -> Profiles -> Presentation: after 280 minutes: do NOTHING
- Deleted xscreensaver*

These were the options I found in several Google results. Still I am getting a black screen after 10 minutes. That is too weird, isn't it?

Now what do I have to do to get NO BLACK SCREEN EVER??

Thanks anyone who knows how to do this in Debian

jlinkels

Edit: in Squeeze it's KDE4.4, right?

pljvaldez 02-21-2011 03:16 PM

I'm not in front of my squeeze box right now, but I feel like there is a separate power setting for the Display only.

And did you remember after changing the power settings to set that as the default power profile?

EDIT: Also, if you just wanted a hack, you could install the xautomation package and create a script that automatically moves the mouse with xte 'mousemove 250 250' or the like.

jlinkels 02-22-2011 07:14 AM

Update:

No, there is no separate power setting for the screen. It is not in Desktop, not in Power Settings, not in Display.

The question whether or not Presentation was selected as default profile makes sense. There is a choice When Running on Power Adapter which let you select a profile. This choice is the only one where a profile can be selected, so I assumed that this would actually select the Presentation profile. How naive

Searching thru other forums I discovered that with Alt-F2 you can start a pop-up where you can enter a command. Entering Power Profile shows a list with profiles to select. How obvious!I selected Presentation. From the system tray a notice popped up that Presentation power profile is selected. Cool!

But the screen still blanks after 10 minutes

Sure I can install xte as suggested by PJValdez (thanks), but isn't it too weird that I cannot prevent the screen from blanking? At this moment I am not even sure that it is KDE4 which kicks in the blanking, but can I expect that when I adjust screen saver settings in a desktop environment, the DE takes care of controlling the underlying layers? In 2011, after 2 years of KDE4 development, releasing one crippled version after the other?

jlinkels

jlinkels

TheIndependentAquarius 02-22-2011 07:39 AM

It may be dumb but what I am getting from your posts is that your display goes to "sleep" after 10 minutes!

bathory 02-22-2011 08:02 AM

You should run:
Code:

xset -dpms s off

jlinkels 02-22-2011 08:18 AM

Quote:

Originally Posted by Anisha Kaul (Post 4267258)
It may be dumb but what I am getting from your posts is that your display goes to "sleep" after 10 minutes!

It certainly goes to sleep but not by itself. The monitor (it is a CRT) doesn't have that option. On the previous OS installation (Linspire or so with KDE 3.5) the monitor didn't blank. This also precludes smart BIOS settings.

jlinkels

jlinkels 02-22-2011 11:52 AM

Quote:

Originally Posted by bathory (Post 4267274)
You should run:
Code:

xset -dpms s off

Yes, you are right, that did it.

What is the most appropriate place to put this command so it will be executed at startup of the desktop? /etc/X11/Xsession?

Thanks, this was very helpful.

jlinkels

Dutch Master 02-22-2011 12:39 PM

I presume the Xorg config file. I have a similar issue (on Gnome) and found that when the xscreensaver daemon is running, and with the screensaver itself disabled, no blanking occurs.

bathory 02-22-2011 03:33 PM

Quote:

What is the most appropriate place to put this command so it will be executed at startup of the desktop? /etc/X11/Xsession?
I'm not familiar with gnome but from what I've read you can use Xsession, or create a script and
Quote:

login into a normal gnome session.
In Gnome Control Center->Session->Startup Programs you can add programs or scripts to run when Gnome starts
Also you can set these options in xorg.conf as Dutch Master mentioned above (see Option "BlankTime" and Option "DPMS").

Regards

////// 02-24-2011 11:36 AM

Quote:

Originally Posted by bathory (Post 4267274)
You should run:
Code:

xset -dpms s off

Thanks alot.

rshimmel 04-08-2011 09:39 PM

Fedora KDE4 Screen Blanking PITA
 
# Rick: Created 03-29-2011.
# Last Modified: 04-08-2011
# Put this in something like ~/.kde/Autostart/killscreenblanking.sh

#!/bin/sh

# Kill monitor screen after 30 minutes.
xset dpms 1800 1800 1800
# Kill Screen 'blanking'.
xset s noblank

# Then make it executable when 'your user' X environment starts with (minus pound sign and space):
# chmod 754 ~/.kde/Autostart/killscreenblanking.sh
# You only need to do this command when you intially create this file.

# see: "man xset" for options available.
# For example setting "xset dpms 0 0 0" 'should' kill power maagement altogether.
# i.e. not tested by me.

jlinkels 07-05-2011 10:53 AM

Follow-up:

I think the right place to execute this command is in /etc/X11/Xsession.d.
I created a file 95dpms-set in this directory with the command
Code:

xset -dpms s off
And that works.

However: lately I have been setting up yet another computer which should never blank the screen, and I forgot to set also in KDE Control panel Power Settings that the screen should not be blanked.

So, to avoid screen blanking you have to set up both xset and Power Settings

KDE4 never stops to amaze me. You can set anything from within the GUI, but some settings are overruled by settings in system config files, some are overruled by the GUI settings, some you have to set in both places to make them work.

jlinkels


All times are GMT -5. The time now is 07:22 PM.