LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-06-2004, 11:32 PM   #1
davidas
Member
 
Registered: Mar 2004
Distribution: Debian 'Sarge'
Posts: 168

Rep: Reputation: 30
Does Debian use initrd.img to bootup?


Before doing a kernel upgrade, my /boot directory has

System.map-2.4.18-bf2.4
config-2.4.18-bf2.4
vmlinuz-2.4.18-bf2.4

however, after using apt-get install kernel-image-2.6.3-1-686-smp, the directory now has initrd.img-2.6.3-1-686-smp in addition to the usual System.map-xxx, config-xxx and vmlinuz-xxx files. During the installation, I was prompted if I want to create a symbolic link to initrd.img-2.6.3-1-686-smp, of which I say No.

What does this new additional initrd.img file do and is it needed in Debian. Also, in Grub's menu.lst, there is no reference to initrd.img in the section of the original kernel (2.4)

New kernel bootup problem:

Kernel panic cos it tries to load root from (hd0,0), even though my root has been properly configured to be (hd0,2) in menu.lst. Asks me to correct my "root=". Is this related to initrd.img issue above?


Thanks !
 
Old 04-07-2004, 03:32 AM   #2
sims
Member
 
Registered: Mar 2004
Location: Australia
Distribution: Debian, Ubuntu
Posts: 55

Rep: Reputation: 15
I'm not sure about this, but I think initrd creates a small ramdisk before it loads filesystems and so forth. The precompiled kernel which you installed uses initrd, but you can compile one yourself which don't. Anyway, you need to specify where the initrd.img file is located in your menu.lst:
Code:
#Example
title  Debian GNU/Linux (2.6.3)
root (hd0,2)
kernel /vmlinuz root=/dev/hda3
initrd /initrd.img
Hope this was of some help.. =)
 
Old 04-07-2004, 03:45 AM   #3
Spheerke
LQ Newbie
 
Registered: Apr 2004
Location: Belgium
Posts: 5

Rep: Reputation: 0
I've had the same problem just a few days ago. It seems that you configured your ide or scsi support as a module instead of static into the kernel. When it tries to boot and you have them compiled as modules, you need aan initial ram disk.
The image then contains the necessary modules to boot your disks.

Other option: Also check if you configured the correct support for the filesystem. I only chose ext2 support, no extra attributes. After creating the image it gave me the size of it, and also mentioned : root filesystem (3,5). After installing that image i could boot.

Third option is to use the append option in the boot-loader.
append="root=x1x2" where x1 = major number in hex and x2 minor number of the root part.

In my case it was append="root=0305". But i solved it by compiling ide support static and only picking ext2 options (don't have ext3 so why compile )

Hope this helps...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
initrd.img nessaray? shanenin Linux - General 2 02-25-2005 09:42 AM
Initrd.img spaguzz Slackware 4 12-16-2004 03:35 AM
Initrd.img spaguzz Linux - Software 1 12-09-2004 03:21 PM
What's an initrd.img? hotel-lima Linux - Newbie 2 06-11-2004 05:50 PM
initrd.img php_rocks Linux - Newbie 1 08-31-2003 11:20 PM


All times are GMT -5. The time now is 01:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration