LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   dist-upgrade giving errors (http://www.linuxquestions.org/questions/debian-26/dist-upgrade-giving-errors-369482/)

ekdya 10-03-2005 04:32 PM

dist-upgrade giving errors
 
Hello

Note: if you are following another thread of mine, problems I am posting are in different partitions, so donít mix them up.



I am having a problem, here it is
# apt-get dist-upgrade (to finish off a session which get cut off)

Reading Package Lists...
Building Dependency Tree...
The following packages have been kept back:
autogen x-window-system
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
2 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue? [Y/n]

Setting up xserver-xorg (6.8.2.dfsg.1-7) ...
xserver-xorg config warning: Migrating xserver-xfree86 debconf values to
xserver-xorg.
Can't call method "choices" on an undefined value at /usr/share/perl5/Debconf/Question.pm line 85, <GEN1> line 115.
dpkg: error processing xserver-xorg (--configure):
subprocess post-installation script returned error exit status 9
dpkg: dependency problems prevent configuration of x-window-system-core:
x-window-system-core depends on xserver-xorg; however:
Package xserver-xorg is not configured yet.
dpkg: error processing x-window-system-core (--configure):
dependency problems - leaving unconfigured

Received signal. Aborting xserver-xorg package config script.

Errors were encountered while processing:
xserver-xorg
x-window-system-core
E: Sub-process /usr/bin/dpkg returned an error code (1)


thanks

victorh 10-03-2005 05:48 PM

It seems that dpkg is complaining that it can't migrate automatically from xfree86 to xorg.

When changing from Sarge to Etch or Sid you must do this migration first, this problem arises since Debian has changed the X11 Window system from xfree86 to xorg for Etch and Sid.

So first thing before upgrading, follow this instructions:

http://www.debian-administration.org/articles/185

and then you can do

apt-get dist-upgrade


All times are GMT -5. The time now is 06:02 AM.