LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Direct Rendering Lost after full etch upgrade (http://www.linuxquestions.org/questions/debian-26/direct-rendering-lost-after-full-etch-upgrade-551875/)

kushalkoolwal 05-07-2007 03:21 AM

Direct Rendering Lost after full etch upgrade
 
Hi,

Before etch became the stable version, I was using a mix of stable(sarge) and then testing(etch) on my Debian system. The primary reason to use mix was to have Xorg instead of Xfree 86. At that time, I had 3D direct rendering working on my system i.e. when I use to give the command glxinfo, I used to get:

Code:

Direct Rendering:Yes
Last month when etch was moved to stable, I did an upgrade to etch completely i.e. no more mix system: just the stable etch. The upgrade went fine, but I lost my 3D direct rendering.

I installed the packages:
Code:

apt-get install xlib-mesa xlib-mesa-dri
but I Was not able to enable the Direct rendering. Has something changed wrt direct rendering packages? How do I enable it?

My kernel version 2.6.15, I have not upgraded my kernel version. It is same as the one on the older system before the upgrade.

I am using i810 dirvers.

Thanks

kstan 05-07-2007 05:02 AM

Hi kushalkoolwal,
Have you check the kernel-image and the linux-restricted-modules whether in same version?

Good luck!
Ks

kushalkoolwal 05-10-2007 02:46 AM

Quote:

Originally Posted by kstan
Hi kushalkoolwal,
Have you check the kernel-image and the linux-restricted-modules whether in same version?

Good luck!
Ks

What does that mean? Can you explain in detail? How do I check version of linux-restricted-modules?

Thanks

kstan 05-10-2007 04:09 AM

Hi kushalkoolwal,
1. the direct rendering depends on proprietary driver, whether from nvidia or ati.
2. If I not mistaken the intel driver inside restricted module
3. to let your intel driver work properly, the driver must compile with exactly same version with your current kernel
4. Normally debian/ubuntu had compile for you and keep inside the repository, so just make sure you'd install same version of kernel, kernel-module.
5. finally, you can reconfigure your X server setting with
dpkg-reconfigure xserver-xorg

check your current kernel version with
uname -r

check the kernel module and restricted module in your computer
dpkg --list | grep kernel

check what is exactly name of the restricted module using this:-
apt-cache search restricted

Regards,
Ks

DeanLinkous 05-10-2007 08:34 AM

linux-restricted-modules on debian?????
I dont think so.....

kstan 05-10-2007 10:29 AM

don't have? probably I wrong because few month ago I still have a dreamlinux (it use debian repository).

acerimusdux 05-10-2007 10:30 AM

i915 driver
 
You may need to use the newer i915 driver.

My machine is an i845. It used to use the i830 driver. Now I can only get DRI with the newer i915 driver. If I do:

modprobe -r i830
modprobe i915

it works.


All times are GMT -5. The time now is 06:59 PM.