LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-16-2007, 03:12 PM   #1
greenphreak
LQ Newbie
 
Registered: Jul 2007
Posts: 22

Rep: Reputation: 15
Desktop clock not synced with system clock


Hello.

I'm having problems syncing my system clock with the clock displayed on the desktop on a gnome (2.18.3) & debian etch system. For reference, I'm running ntp in the background, and I'm located in New York (UTC -4).

When I bring up a terminal and type 'date', it responds with the proper time:

Thu Aug 16 16:03:06 EDT 2007

However, the clock program sitting on the upper right corner of my desktop that comes with gnome displays the incorrect time. It shows:

Thu Aug 16 20:03

So, I right click on the desktop clock and select "Adjust Date & Time". This brings up a window that allows me to change the current time and time zone information. It shows that the time zone is set to America/New York, as it should be. It also shows that the time is set to 16:03!?!

I'm quite confused. The only place that is misdisplaying the time is the desktop, and when I go to adjust it, it gives me the correct time. For whatever reason, it seems to be displaying the UTC, as opposed to EDT, which is what I'm telling it to display.

When I right click on the desktop time, and go to preferences, there is a checkbox for "Use UTC". It doesn't matter if it is checked or unchecked, it always displays the UTC time in the window, 4 hours ahead of the local time.

What do you guys think? Everything seems to be working ok, except for this gnome clock app displaying UTC time instead of the real time. I cannot imagine that I'm the only person to experience this problem. Any ideas?

Thank you in advance!
 
Old 08-16-2007, 04:17 PM   #2
gamewolf
Member
 
Registered: Jun 2007
Distribution: Debian Sid, Slackware 13.37
Posts: 204

Rep: Reputation: 16
Try this:

Open up a terminal.
cd to /etc/default
type nano rcS
see if UTC = yes
if so, then change it to no

Let me know how that works out.
 
Old 08-17-2007, 01:08 PM   #3
greenphreak
LQ Newbie
 
Registered: Jul 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by gamewolf View Post
Try this:

Open up a terminal.
cd to /etc/default
type nano rcS
see if UTC = yes
if so, then change it to no

Let me know how that works out.
I opened up /etc/default/rcS, found the line UTC = yes, and changed it to NO. No change occurred in my gnome clock. Then I rebooted the machine, and there was still no change in the behavior. Thanks for the suggestion, though! This is such a strange problem, I've never heard of people encountering it before.

Any other ideas?
 
Old 08-17-2007, 01:39 PM   #4
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 624

Rep: Reputation: 32
Quote:
Originally Posted by greenphreak View Post
I opened up /etc/default/rcS, found the line UTC = yes, and changed it to NO. No change occurred in my gnome clock. Then I rebooted the machine, and there was still no change in the behavior. Thanks for the suggestion, though! This is such a strange problem, I've never heard of people encountering it before.

Any other ideas?
it has always worked properly for me without adjustment
 
Old 08-17-2007, 03:01 PM   #5
greenphreak
LQ Newbie
 
Registered: Jul 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by utanja View Post
it has always worked properly for me without adjustment
That is the strange thing. This is not a new install. One day a few weeks ago, it spontaneously started behaving like this. It had always worked prior to this. I have no idea what I did to change its behavior.
 
Old 08-22-2007, 01:32 PM   #6
greenphreak
LQ Newbie
 
Registered: Jul 2007
Posts: 22

Original Poster
Rep: Reputation: 15
I discovered the error, at least, I think I have. As I was running apt-get upgrade today, I looked up and my clock was mysteriously working again!!!

I checked, and sure enough, among the packages upgraded was tzdata:

Code:
(Reading database ... 119324 files and directories currently installed.)
Preparing to replace tzdata 2007f-10 (using .../tzdata_2007f-11_all.deb) ...
Unpacking replacement tzdata ...
Setting up tzdata (2007f-11) ...

Current default timezone: 'America/New_York'
Local time is now:      Wed Aug 22 14:17:31 EDT 2007.
Universal Time is now:  Wed Aug 22 18:17:31 UTC 2007.
Run 'dpkg-reconfigure tzdata' if you wish to change it.
So I guess it was some error in the 2007f-10 version of tzdata. I don't know, but at least it is fixed. Thanks to everyone for the suggestions!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 07:19 PM
Failed to set system clock to hardware clock jrtayloriv Linux - Newbie 2 09-25-2008 07:06 AM
Slow system clock and stray hardware clock, pleas help! Epox Linux - General 6 01-02-2007 02:43 PM
system clock,hardware clock varunbihani Linux - Newbie 2 07-23-2005 09:04 AM
system clock vs. CMOS clock dtamajka Linux - General 7 12-11-2003 05:56 PM


All times are GMT -5. The time now is 09:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration