LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-11-2010, 12:41 AM   #1
captkrill
Member
 
Registered: Mar 2009
Location: Texas
Distribution: Slack64 14.1 + Win7 x64
Posts: 62

Rep: Reputation: 18
Dependencies unmet - Handbrake-gtk


I am having an issue when trying to install handbrake-gtk via Synaptic, terminal (apt-get and .deb file).

Code:
ebian:/home/pyrocide/Desktop# apt-get install handbrake-gtk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
handbrake-gtk is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  handbrake-gtk: Depends: libdbus-glib-1-2 (>= 0.78) but 0.76-1 is to be installed
                 Depends: libfaad2 but it is not installable
                 Depends: libgtk2.0-0 (>= 2.16.0) but 2.12.12-1~lenny1 is to be installed
                 Depends: libnotify1 (>= 0.4.5) but 0.4.4-3 is to be installed
                 Depends: libsoup2.4-1 (>= 2.27.92) but 2.4.1-2 is to be installed
                 Depends: libtheora0 (>= 1.0) but 1.0~beta3-1 is to be installed
                 Depends: libwebkit-1.0-2 (>= 1.1.1) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Code:
debian:/home/pyrocide/Desktop# dpkg -i handbrake-gtk_0.9.4-0.0_i386.deb 
(Reading database ... 158107 files and directories currently installed.)
Preparing to replace handbrake-gtk 0.9.4-0.0 (using handbrake-gtk_0.9.4-0.0_i386.deb) ...
Unpacking replacement handbrake-gtk ...
dpkg: dependency problems prevent configuration of handbrake-gtk:
 handbrake-gtk depends on libdbus-glib-1-2 (>= 0.78); however:
  Version of libdbus-glib-1-2 on system is 0.76-1.
 handbrake-gtk depends on libfaad2; however:
  Package libfaad2 is not installed.
 handbrake-gtk depends on libgtk2.0-0 (>= 2.16.0); however:
  Version of libgtk2.0-0 on system is 2.12.12-1~lenny1.
 handbrake-gtk depends on libnotify1 (>= 0.4.5); however:
  Version of libnotify1 on system is 0.4.4-3.
 handbrake-gtk depends on libsoup2.4-1 (>= 2.27.92); however:
  Version of libsoup2.4-1 on system is 2.4.1-2.
 handbrake-gtk depends on libtheora0 (>= 1.0); however:
  Version of libtheora0 on system is 1.0~beta3-1.
 handbrake-gtk depends on libwebkit-1.0-2 (>= 1.1.1); however:
  Package libwebkit-1.0-2 is not installed.
dpkg: error processing handbrake-gtk (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 handbrake-gtk
From Synaptic
Code:
handbrake-gtk:
  Depends: libdbus-glib-1-2 (>=0.78) but 0.76-1 is to be installed
 Depends: libfaad2  but it is not installable
  Depends: libgtk2.0-0 (>=2.16.0) but 2.12.12-1~lenny1 is to be installed
  Depends: libnotify1 (>=0.4.5) but 0.4.4-3 is to be installed
  Depends: libsoup2.4-1 (>=2.27.92) but 2.4.1-2 is to be installed
  Depends: libtheora0 (>=1.0) but 1.0~beta3-1 is to be installed
 Depends: libwebkit-1.0-2 (>=1.1.1) but it is not installable
What exactly am I doing wrong here?

this is the repo i have found for it; could this be the problem?

#Handbrake
deb http://www.debian-multimedia.org sid main

Last edited by captkrill; 01-11-2010 at 12:43 AM.
 
Old 01-11-2010, 02:11 AM   #2
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 483

Rep: Reputation: 109Reputation: 109
It seems you are on debian stable (from the info below your name) and you are trying to install the handbrake version of unstable (sid), thus you get unmet dependencies.

Handbrake-gtk is available for lenny, so change your debian multimedia line in sources.list.

http://debian-multimedia.org/dists/s...dbrake-gtk.php
 
Old 01-11-2010, 02:25 AM   #3
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Debian, SL
Posts: 5,319

Rep: Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142
Quote:
Originally Posted by captkrill View Post
this is the repo i have found for it; could this be the problem?

#Handbrake
deb http://www.debian-multimedia.org sid main
As jim_p, pointed out, that is indeed the problem. Just to be explicit, change that line to:

Code:
deb http://www.debian-multimedia.org lenny main
Evo2.
 
Old 01-11-2010, 09:24 AM   #4
captkrill
Member
 
Registered: Mar 2009
Location: Texas
Distribution: Slack64 14.1 + Win7 x64
Posts: 62

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by evo2 View Post
As jim_p, pointed out, that is indeed the problem. Just to be explicit, change that line to:

Code:
deb http://www.debian-multimedia.org lenny main
Evo2.
great, thanks you two. Worked perfectly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unmet dependencies fof3 Debian 11 10-27-2008 02:08 PM
Help with unmet dependencies landysaccount Linux - Newbie 2 10-11-2008 10:44 AM
unmet dependencies lumix Linux - Newbie 2 06-10-2008 10:04 PM
Unmet dependencies. maikie Debian 7 09-04-2007 05:30 PM
unmet dependencies Josephus Ross Linux - General 10 08-21-2007 12:49 PM


All times are GMT -5. The time now is 07:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration