LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Dependencies unmet - Handbrake-gtk (http://www.linuxquestions.org/questions/debian-26/dependencies-unmet-handbrake-gtk-781396/)

captkrill 01-11-2010 12:41 AM

Dependencies unmet - Handbrake-gtk
 
I am having an issue when trying to install handbrake-gtk via Synaptic, terminal (apt-get and .deb file).

Code:

ebian:/home/pyrocide/Desktop# apt-get install handbrake-gtk
Reading package lists... Done
Building dependency tree     
Reading state information... Done
handbrake-gtk is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  handbrake-gtk: Depends: libdbus-glib-1-2 (>= 0.78) but 0.76-1 is to be installed
                Depends: libfaad2 but it is not installable
                Depends: libgtk2.0-0 (>= 2.16.0) but 2.12.12-1~lenny1 is to be installed
                Depends: libnotify1 (>= 0.4.5) but 0.4.4-3 is to be installed
                Depends: libsoup2.4-1 (>= 2.27.92) but 2.4.1-2 is to be installed
                Depends: libtheora0 (>= 1.0) but 1.0~beta3-1 is to be installed
                Depends: libwebkit-1.0-2 (>= 1.1.1) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Code:

debian:/home/pyrocide/Desktop# dpkg -i handbrake-gtk_0.9.4-0.0_i386.deb
(Reading database ... 158107 files and directories currently installed.)
Preparing to replace handbrake-gtk 0.9.4-0.0 (using handbrake-gtk_0.9.4-0.0_i386.deb) ...
Unpacking replacement handbrake-gtk ...
dpkg: dependency problems prevent configuration of handbrake-gtk:
 handbrake-gtk depends on libdbus-glib-1-2 (>= 0.78); however:
  Version of libdbus-glib-1-2 on system is 0.76-1.
 handbrake-gtk depends on libfaad2; however:
  Package libfaad2 is not installed.
 handbrake-gtk depends on libgtk2.0-0 (>= 2.16.0); however:
  Version of libgtk2.0-0 on system is 2.12.12-1~lenny1.
 handbrake-gtk depends on libnotify1 (>= 0.4.5); however:
  Version of libnotify1 on system is 0.4.4-3.
 handbrake-gtk depends on libsoup2.4-1 (>= 2.27.92); however:
  Version of libsoup2.4-1 on system is 2.4.1-2.
 handbrake-gtk depends on libtheora0 (>= 1.0); however:
  Version of libtheora0 on system is 1.0~beta3-1.
 handbrake-gtk depends on libwebkit-1.0-2 (>= 1.1.1); however:
  Package libwebkit-1.0-2 is not installed.
dpkg: error processing handbrake-gtk (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 handbrake-gtk

From Synaptic
Code:

handbrake-gtk:
  Depends: libdbus-glib-1-2 (>=0.78) but 0.76-1 is to be installed
 Depends: libfaad2  but it is not installable
  Depends: libgtk2.0-0 (>=2.16.0) but 2.12.12-1~lenny1 is to be installed
  Depends: libnotify1 (>=0.4.5) but 0.4.4-3 is to be installed
  Depends: libsoup2.4-1 (>=2.27.92) but 2.4.1-2 is to be installed
  Depends: libtheora0 (>=1.0) but 1.0~beta3-1 is to be installed
 Depends: libwebkit-1.0-2 (>=1.1.1) but it is not installable

What exactly am I doing wrong here?

this is the repo i have found for it; could this be the problem?

#Handbrake
deb http://www.debian-multimedia.org sid main

jim_p 01-11-2010 02:11 AM

It seems you are on debian stable (from the info below your name) and you are trying to install the handbrake version of unstable (sid), thus you get unmet dependencies.

Handbrake-gtk is available for lenny, so change your debian multimedia line in sources.list.

http://debian-multimedia.org/dists/s...dbrake-gtk.php

evo2 01-11-2010 02:25 AM

Quote:

Originally Posted by captkrill (Post 3822086)
this is the repo i have found for it; could this be the problem?

#Handbrake
deb http://www.debian-multimedia.org sid main

As jim_p, pointed out, that is indeed the problem. Just to be explicit, change that line to:

Code:

deb http://www.debian-multimedia.org lenny main
Evo2.

captkrill 01-11-2010 09:24 AM

Quote:

Originally Posted by evo2 (Post 3822124)
As jim_p, pointed out, that is indeed the problem. Just to be explicit, change that line to:

Code:

deb http://www.debian-multimedia.org lenny main
Evo2.

great, thanks you two. Worked perfectly


All times are GMT -5. The time now is 05:35 AM.