LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Default screen resolution not sticking (http://www.linuxquestions.org/questions/debian-26/default-screen-resolution-not-sticking-249415/)

nakko 10-31-2004 07:12 AM

Default screen resolution not sticking
 
Not quite sure if this should go under Debian specifically, but here goes:
I want my desktop to only ever boot up at 800x600, period. (MythTV box, no CRt monitor -- I like to browse the web and do other stuff too, so 640x480 just doesn't cut it.)

I've set up my /etc/X11/XF86Config-4 file to have "800x600" as the first mode listed on any and all lines. For some reason, whenever I log in, it will change from 800x600 to 640x480 anyway. So, I removed all modes but "800x600" and it still kicks me to 640x480.

Some other file? Something else I gotta configure? It's getting to be a pain in the butt to manually switch to 800x600 every time I login or reboot or what have you.

Any help here, thanks... let me know if you need my XF86Config-4 or whatever. =)

corbintechboy 10-31-2004 07:15 AM

Yes please, if you would please post you XF86Config-4 that would give us a place to start.

sterrenkijker 10-31-2004 07:43 AM

Also show your /var/log/XFree86.0.log. Such problems are often because of wrong vertical/horizontal refresh rates etc.

nakko 11-06-2004 09:45 PM

Unfortunately I now have yet a new problem! I made the foolish mistake of trying to recompile my kernel to add in newer Bluetooth support with the patch from Bluez.org.

Anyway, having built a custom kernel, I figured I would need a new NVidia kernel module. I grabbed the newest one, 6699, installed it, and it seemed to go without a hitch! ...And now it bombs whenever I try to start X.

ftp://subrosa.ath.cx/meef/XF86Config-4
ftp://subrosa.ath.cx/meef/XFree86.0.log

What I see when I boot the machine up is it will usually show the NVidia splash screen, then again, then one more time, then show me an error (containing this log) and just dump me to a command prompt.

I didn't try to do anything fancy, but I am frustrated, and close to just formatting and re-installing Debian...

macondo 11-07-2004 10:41 AM

For your resolution problem do:

#dpkg-reconfigure xserver-xfree86

take the Advanced option for your monitor, from the resolutions list just select the one you like, erase the others, say Yes to the creation of a new Config-4 file, get out, reboot.


All times are GMT -5. The time now is 03:22 PM.