LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-06-2007, 03:03 PM   #1
sylvaticus
Member
 
Registered: Apr 2006
Posts: 49

Rep: Reputation: 15
Unhappy Debian VPS... without APT !!


I had a bad surprise on the VPS I just aquired: the firt thing I do when I order a new Debian VPS is apt-get update.. well.. this time I got "command not found" !!!

How can I install from remote apt ...without apt????

Is this normal?? Is the first time I got no apt in a Debian based xen image...

cheers,
Antonello
 
Old 07-06-2007, 03:12 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Were you root?
 
Old 07-06-2007, 03:17 PM   #3
sylvaticus
Member
 
Registered: Apr 2006
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pljvaldez
Were you root?
yes:
Code:
ppb11 / # su
ppb11 / # apt-get
bash: apt-get: command not found
 
Old 07-06-2007, 03:23 PM   #4
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
You can look around /usr/bin to see if it's there but not in your $PATH. Or try using dselect (which should also live in /usr/bin) to install apt.
 
Old 07-06-2007, 03:23 PM   #5
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,673

Rep: Reputation: 122Reputation: 122
Try if dpkg is available, that way you can download the proper version of apt, install it with dpkg and away you go!
 
Old 07-06-2007, 03:31 PM   #6
sylvaticus
Member
 
Registered: Apr 2006
Posts: 49

Original Poster
Rep: Reputation: 15
Unhappy

not apt-get, dselect, nor dpkg in any position

does I have to change VPS provider ???
 
Old 07-06-2007, 04:00 PM   #7
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
you did 'su' instead of 'su -' are you sure the path was set properly ?
 
Old 07-06-2007, 04:02 PM   #8
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Quote:
Originally Posted by sylvaticus
not apt-get, dselect, nor dpkg in any position

does I have to change VPS provider ???
I would certainly contact them. Maybe they don't allow you to add packages to the VPS? Maybe they'll do it for you...
 
Old 07-06-2007, 04:09 PM   #9
sylvaticus
Member
 
Registered: Apr 2006
Posts: 49

Original Poster
Rep: Reputation: 15
Unhappy

Quote:
Originally Posted by pljvaldez
I would certainly contact them. Maybe they don't allow you to add packages to the VPS? Maybe they'll do it for you...
It seems that they setup me a gentoo box instead of a Debian one.. the warriest thing is that it is made automatically from a control panel, so they have a bug in theys XEN management... we are starting well...

This is my control panel (with Debian correctly selected):

My Virtual Private Servers
account id name xen image disk memory bandwidth account status vps status
S-60423207PY546134P ppb11.vpsfarm.com debian.4.x86_64 [modify] 10 256 1550 ACTIVE ONLINE

And this is the console-login output:
Code:
Bootdata ok (command line is  ip=:1.2.3.4::::eth0:dhcp root=/dev/sda1 ro)
Linux version 2.6.16-xen (root@ppb) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)) #1 SMP Fri Mar 16 15:51:59 EDT 2007
No mptable found.
Built 1 zonelists
Kernel command line:  ip=:1.2.3.4::::eth0:dhcp root=/dev/sda1 ro
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 65536 bytes)
Xen reported: 1795.496 MHz processor.
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode-cache hash table entries: 32768 (order: 6, 262144 bytes)
Software IO TLB disabled
Memory: 252008k/270336k available (2368k kernel code, 17992k reserved, 908k data, 160k init)
Calibrating delay using timer specific routine.. 3592.08 BogoMIPS (lpj=17960412)
Security Framework v1.0.0 initialized
Capability LSM initialized
Mount-cache hash table entries: 256
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
Brought up 1 CPUs
migration_cost=0
DMI not present or invalid.
Grant table initialized
NET: Registered protocol family 16
Initializing CPU#1
migration_cost=799
migration_cost=799
Initializing CPU#2
migration_cost=799
Brought up 4 CPUs
Initializing CPU#3
PCI: setting up Xen PCI frontend stub
ACPI: Subsystem revision 20060127
ACPI: Interpreter disabled.
xen_mem: Initialising balloon driver.
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: System does not support PCI
PCI: System does not support PCI
IA-32 Microcode Update Driver: v1.14-xen <tigran@veritas.com>
IA32 emulation $Id: sys_ia32.c,v 1.32 2002/03/24 13:02:28 ak Exp $
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered (default)
io scheduler deadline registered
io scheduler cfq registered
rtc: IRQ 8 is not free.
i8042.c: No controller found.
isa bounce pool size: 16 pages
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
Xen virtual console successfully installed as tty1
Event-channel device installed.
blkif_init: reqs=64, pages=704, mmap_vstart=0xffff88000fc00000
netfront: Initialising virtual ethernet driver.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
Registering block device major 8
ide-floppy driver 0.99.newide
register_blkdev: cannot get major 8 for sd
usbmon: debugfs is not available
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
mice: PS/2 mouse device common for all mice
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 3, 32768 bytes)
TCP established hash table entries: 16384 (order: 6, 262144 bytes)
TCP bind hash table entries: 16384 (order: 6, 262144 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT2-fs warning (device sda1): ext2_fill_super: mounting ext3 filesystem as ext2
VFS: Mounted root (ext2 filesystem) readonly.
INIT: version 2.86 booting

Gentoo Linux; http://www.gentoo.org/
 Copyright 1999-2006 Gentoo Foundation; Distributed under the GPLv2

Press I to enter interactive boot mode

 * Mounting proc at /proc ...                                             [ ok ]
 * Mounting sysfs at /sys ...                                             [ ok ]
 * Mounting /dev for udev ...                                             [ ok ]
 * Seeding /dev with needed nodes ...                                     [ ok ]
 * Setting up proper hotplug agent ...
 *   Using netlink for hotplug events...
                                                                          [ ok ]
 * Starting udevd ...                                                     [ ok ]
 * Populating /dev with existing devices through uevents ...              [ ok ]
 * Letting udev process events ...                                        [ ok ]
 * Finalizing udev configuration ...                                      [ ok ]
 * Mounting devpts at /dev/pts ...                                        [ ok ]
 * Checking root filesystem .../dev/sda1: clean, 271243/1310720 files, 612887/2621440 blocks
                                           [ ok ]
 * Remounting root filesystem read/write ...                              [ ok ]
 * Checking all filesystems ...                                           [ ok ]
 * Mounting local filesystems ...                                         [ ok ]
 * Mounting USB device filesystem (usbfs) ...                             [ ok ]
 * Activating (possible) swap ...                                         [ ok ]
 * Setting system clock using the hardware clock [xen] ...                [ ok ]
 * Caching service dependencies ...                                       [ ok ]
 * Setting hostname to ppb11 ...                                          [ ok ]
 * Configuring kernel parameters ...                                      [ ok ]
 * Updating environment ...                                               [ ok ]
 * Cleaning /var/lock, /var/run ...                                       [ ok ]
 * Cleaning /tmp directory ...                                            [ ok ]
 * Loading key mappings ...                                               [ ok ]
 * Setting user font ...                                                  [ ok ]
 * Starting lo
 *   Bringing up lo
 *     127.0.0.1/8
                                                                          [ ok ]
 *   Adding routes
 *     127.0.0.0/8 ...                                                    [ ok ]
 * Initializing random number generator ...                               [ ok ]
INIT: Entering runlevel: 3
 * Starting eth0
 *   Bringing up eth0
 *     dhcp
 *       Running dhcpcd ...                                               [ ok ]
 *       eth0 received address 209.9.228.149/27
 * Mounting network filesystems ...                                       [ ok ]
 * Generating Hostkey...
Generating public/private rsa1 key pair.
Your identification has been saved in /etc/ssh/ssh_host_key.
Your public key has been saved in /etc/ssh/ssh_host_key.pub.
The key fingerprint is:
41:5c:52:ad:10:3d:c6:2b:ea:a7:33:64:6e:5e:9a:3f root@ppb11
 * Generating DSA-Hostkey...
Generating public/private dsa key pair.
Your identification has been saved in /etc/ssh/ssh_host_dsa_key.
Your public key has been saved in /etc/ssh/ssh_host_dsa_key.pub.
The key fingerprint is:
7b:bd:f1:6f:0a:94:9d:08:66:42:64:cc:a5:f8:9d:18 root@ppb11
 * Generating RSA-Hostkey...
Generating public/private rsa key pair.
Your identification has been saved in /etc/ssh/ssh_host_rsa_key.
Your public key has been saved in /etc/ssh/ssh_host_rsa_key.pub.
The key fingerprint is:
6b:36:be:6f:85:8d:94:51:55:3d:64:7b:65:9e:30:76 root@ppb11
 * Starting sshd ...                                                      [ ok ]
 * Starting local ...                                                     [ ok ]
 
Old 07-06-2007, 04:24 PM   #10
sylvaticus
Member
 
Registered: Apr 2006
Posts: 49

Original Poster
Rep: Reputation: 15
Thumbs up

OK.. I reinstalled the VPS image and this time I got Debian...

Thanks to all...

Sylvaticus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Debian on a Virtuzzo Vps Cheza Debian 2 09-20-2006 01:46 PM
Where can I download UML VPS or Xen VPS to make a virtual private server? abefroman Linux - Software 3 12-09-2005 10:00 AM
apt-get update errors since Debian released ( bad /etc/apt/sources.list ?) forgox Debian 10 06-13-2005 12:28 PM
Apt-get debian Cybercool Linux - Newbie 3 04-20-2004 07:57 AM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration