LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian VM unable to get IP address from DHCP (http://www.linuxquestions.org/questions/debian-26/debian-vm-unable-to-get-ip-address-from-dhcp-847154/)

knottygal 11-29-2010 02:25 AM

Debian VM unable to get IP address from DHCP
 
I have a Debian VM on Windows that is not getting an IP address assigned by the DHCP. I tried, ifdown eth0 and then ifup eth0 and still no IP address. my interfaces file looks like this:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
# The loopback network interface

auto lo

iface lo inet loopback

# The primary network interface

allow-hotplug eth0

iface eth0 inet dhcp

I am totally new to VM and linux. I don't know what to do about this issue. any help will be appreciated.

-Jocelyn

acid_kewpie 11-29-2010 02:43 AM

OK, you've not said anything about what kind of VM this is, or what networking model is being used. Where is the DHCP service for the machine? Are you expecting the virtualization system to provide this? If so, is it configured?

knottygal 11-29-2010 03:11 AM

Thank you Chris for responding. This VM file was given to me by the customer as a .vmx and .vmdk file. Basically, I need to find out the IP address of the VM for my testing purposes and when I ran ifconfig -a, I realised that there is no ip address assigned to eth0. Its a vmware VM and I am using VM Player to play it.The ip address is supposed to be assigned by my network's DHCP.

-Jocelyn

acid_kewpie 11-29-2010 03:18 AM

ok, well if I remember right vmplayer uses nat networking, so it's not on the same network as the phsyical network your box is connected to. You can probably change that in the vmware player settings though.

knottygal 11-29-2010 04:21 AM

Quote:

Originally Posted by acid_kewpie (Post 4174380)
ok, well if I remember right vmplayer uses nat networking, so it's not on the same network as the phsyical network your box is connected to. You can probably change that in the vmware player settings though.

That did it.. I changed the network adapter to NAT in the VM settings. thank you so much for the help,Chris.

-Jocelyn


All times are GMT -5. The time now is 05:24 PM.