LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-28-2005, 08:00 PM   #1
hutch
LQ Newbie
 
Registered: Sep 2005
Posts: 7

Rep: Reputation: 0
Question Debian usb ntfs hard drive problem


ok, to be fair i am a nubie. very smart in windows, not so much linux yet (fnigers crossed) ok, i just installed debian 3.1 got most everything up and running, installed kernel source for my nvidia video card, yada yada... my problem now is i have a Segate120 g externel usb2 hard drive formated NTFS. I looked in fstab, and it is showing up as

/dev/sda /media/usb0 auto rw,user,noauto 0 0

so i read some manuals online, and tried changing auto to ntfs, and rw to ro, but still no mount... I tried mount -f ntfs /media/usb0 but it still didn't go... i have tried just about everything i can think of, but i know there is an answer out there.. i don't know if it is a usb problem or a ntfs problem...

Please! Thanks in advanced!
 
Old 09-28-2005, 08:18 PM   #2
debianmike
Member
 
Registered: Sep 2005
Posts: 115

Rep: Reputation: 15
is the output of your error: filesystem not supported by kernel?

if so, guess what? Your kernel doesn't support ntfs.

i use debian, but never tried ntfs...but i know that there are (gulp) rpm's out there to allow this to work.


but wait....your fstab says /dev/sda? and not /dev/sda1?? sda refers to the whole drive, not a partition on the drive.

Last edited by debianmike; 09-28-2005 at 08:19 PM.
 
Old 09-28-2005, 08:32 PM   #3
hutch
LQ Newbie
 
Registered: Sep 2005
Posts: 7

Original Poster
Rep: Reputation: 0
well if i leave fstab alone i get

hutch1:/media/usb0# mount /media/usb0
mount: you must specify the filesystem type

and if i use

hutch1:/media# mount -f ntfs /media/usb0
hutch1:/media#
just acts like it's mouned, but it's not... and i can try to mount it like 1000 times... if i change it in fstab to ntfs and change it to read only instead of rw it gives the error

hutch1:/etc# mount /media/usb0
mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

hutch1:/etc#

and dmesg | tail gives me

hutch1:/etc# dmesg |tail
Additional sense indicates Medium not present
sda : READ CAPACITY failed.
sda : status = 1, message = 00, host = 0, driver = 08
Current sd00:00: sense key Not Ready
Additional sense indicates Medium not present
sda : block size assumed to be 512 bytes, disk size 1GB.
sda: test WP failed, assume Write Enabled
/dev/scsi/host1/bus0/target0/lun0: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
unable to read partition table
hutch1:/etc#


but you made a good point, it isn't recognizing the partitions... it should show up as sda1 since the hd has only one partition... huh..
Anymore ideas? Thanks again
 
Old 09-28-2005, 09:00 PM   #4
debianmike
Member
 
Registered: Sep 2005
Posts: 115

Rep: Reputation: 15
well, fdisk /dev/sda -l will list what it thinks it has for partitions...if it doesn't see what is there, you got bigger problems.

also, it shouldn't "show up as" sda1, it is sda1...do this:

# mount -t ntfs /dev/sda1 /media/usb (or usb0)

did that work? if so, change fstab accordingly

you cant mount an entire drive, you have to mount a partition, so always adress it as /dev/sda1.

Last edited by debianmike; 09-28-2005 at 09:02 PM.
 
Old 09-28-2005, 09:33 PM   #5
hutch
LQ Newbie
 
Registered: Sep 2005
Posts: 7

Original Poster
Rep: Reputation: 0
thanks dude.... changed it to sda1 in fstab, changed some options around and boom... thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't change root ownership of NTFS USB hard drive rrrssssss Mandriva 14 07-10-2006 04:42 PM
user ntfs hard drive access problem Th3_J3st3R Slackware 4 08-28-2005 09:59 PM
Installing Debian on a (fat32) USB hard drive nagromo Debian 7 01-05-2005 12:33 AM
mounting usb pen drive; ntfs problem ShamitSoneji Fedora 20 12-01-2004 02:19 AM
USB hard disk drive, using NTFS Barney_cc Linux - Hardware 1 09-02-2003 02:53 AM


All times are GMT -5. The time now is 01:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration