LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian Testing + XP Multiboot 2 HD's (http://www.linuxquestions.org/questions/debian-26/debian-testing-xp-multiboot-2-hds-526829/)

whitster 02-08-2007 04:11 PM

Debian Testing + XP Multiboot 2 HD's
 
Hey y'all.

Success! So thought I'd let y'all know how. I have had Debian Testing going for months and love it. But now have a need/requirement to use W XP to try to make a little money. So I have two boxes but only one new and fast enough to use XP so I needed to multiboot on separate drives. I've played w. "hotswap" kits and swapped out drives after shutting down but they have little fans in them and I am afraid a fan motor might go out and I'm left w. a damaged drive so again, multiboot.

Here's how I did it.

AMD Sempron 2800+ 1G Ram, two WD hd's. Debian on 20G XP on 15 G.

Debian Testing originally installed on Cable 1 middle connector w. CD on Cable 2. WD allows for no jumper settings if no master/slave situation exists. At Debian install that was the case.

XP, set WD jumper to Master and CD to slave and installed on Cable 1 after disconnecting the Linux drive. So when I installed XP it was the only drive hooked up.

After installation and successful reboots I changed hookups.

Debian Testing WD 20G set to Master on Cable 1 middle connector.
W XP WD 15 G set to slave on Cable 1 end connector.

CD set to Master on Cable 2 on middle connector.

Boot up Linux and as SU, go to /boot/grub and use gedit to add: "hd1 /dev/hdb" w.i quotes to device.map file. It already had "hd0 /dev/hda" listed. No fd0 listed but it works anyway. Just for safety sake you might want to cp device.map to device.mapold prior to changing it just in case. And do the same w. the next change.

Now we do the menu.lst change. For safety sake make cp to menu.lstold before you edit this file.

Using gedit again, at point in file just above where the AUTOMAGIK info starts, enter the following:

title Windows XP
map (hd0) (hd1)
map (hd1) (hd0)
root (hd1,0)
rootnoverify (hd1,0)
makeactive
chainloader +1

Make sure there is a space between the map coordinates, (hd0) and (hd1 on both map lines. That drove me nuts for a while.

Anyway, save the menu.lst after adding those lines, reboot and see if it works for you. It did for me. I have not messed around w. W XP much yet, I was so happy and surprised that it came up in the first place but it came up and I fooled around and then rebooted to Linux just fine. Haven't checked the CD access yet but hopefully it will work fine.

Hope that helps. And have fun. I had looked all over looking for Debian multiboot setups w. XP and hoping to find one that worked for Testing and found basically nothing Debian distro specific so wanted to get this up here if anyone else was looking. Enjoy.

Whit

whitster 02-08-2007 04:19 PM

Note: after I submitted the post I see it formatted my code a little.

After the word "title" there is a "tab" space before "Windows XP."

After the word "map" on both lines there is a "tab" space and again, make sure there is a space in between the (hd0) and (hd1) on those same lines.

And after "chainloader" there is also a "tab" space before the "+1".

I don't know if the tab spaces make a difference but the space sure did so that is why I wanted to make note of it here.

Again, have fun.
Whit


All times are GMT -5. The time now is 08:00 AM.