LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-17-2010, 09:21 PM   #1
lowlux
Member
 
Registered: May 2005
Posts: 56

Rep: Reputation: 15
Debian testing? no desktop?


I installed debian testing but it didn't come with a desktop? I have no internet support.

The site is hard as hell to use.. hard to find anything... where do i find the Debian testing with the gnome desktop?
 
Old 09-17-2010, 09:36 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,598

Rep: Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516
Select Desktop System when you go through the install next time? It gave you the choice..

Or plug yourself in wired and apt-get install gdm

Last edited by AlucardZero; 09-17-2010 at 09:38 PM.
 
Old 09-17-2010, 09:40 PM   #3
jbasement
LQ Newbie
 
Registered: Feb 2004
Location: LaCrosse, WI USA
Distribution: Debian
Posts: 15

Rep: Reputation: 0
#tasksel and select[*]Desktop Environment
 
Old 09-18-2010, 03:55 PM   #4
alioop
Member
 
Registered: Mar 2004
Location: Houston,Texas
Distribution: Via Debian!!!
Posts: 113

Rep: Reputation: 21
I don't know what options you choose but the next time you install - and you'll fine it easier to do so - go with the default options. I've never had a problem doing so. Go slow and take the options offered. Other wise you'll have to do some things that might leave your scratching you head. So start from scratch and say yes to the default options.

Why reinstall? Well, first of all, it doesn't take that long to do so. And second... Well, there is no second. Just do it. You'll like it, your mother will like it and your children will like it. Plus it's easier. Go with the default options.

Last edited by alioop; 09-18-2010 at 04:06 PM.
 
Old 09-18-2010, 04:04 PM   #5
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,474

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Quote:
I installed debian testing but it didn't come with a desktop? I have no internet support.
Did you tried startx?

Kind regards
 
Old 09-18-2010, 04:53 PM   #6
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,057

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
if you want debian testing on liveusb thats installable see here
http://live-helper.debian.net/cgi-bin/live-helper

put the iso on usb with dd or with unetbootin
if usb already has recent version of syslinux installed
just extract iso somewhere, rename isolinux folder to syslinux
rename isolinux.cfg to syslinux.cfg
 
Old 09-18-2010, 05:30 PM   #7
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware 14.1, Slackware64-current, OpenBSD 5.5
Posts: 4,122

Rep: Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518
lowlux,

At the command line as root run:

# aptitude install xorg gnome

Make sure you have a wired Internet connection (DHCP is easiest). That command will pull down the gnome desktop and all the needed xorg libraries. You don't need to re-install. It sounds like you just selected a base system when you first installed.
 
Old 09-19-2010, 08:31 PM   #8
flipjarg
Member
 
Registered: May 2010
Distribution: Debian & Backtrack
Posts: 58

Rep: Reputation: 2
I had the same thing happen and I chose to install a desktop environment. As stated above, if you plug directly in via ethernet you can get an internet connection and type:

Code:
sudo aptitude update && sudo aptitude install gnome
If you only have wireless access then you'll have to manually configure your wifi card. You'll have to edit /etc/network/interfaces

My wifi card is set to be my main NIC so it was called eth1. I edited my /etc/network/interfaces file to have this in it:
Code:
# The primary network interface
allow-hotplug eth1
iface eth1 inet dhcp
	# wireless-* options are implemented by the wireless-tools package
	wireless-essid MY_ROUTER_NAME
Then you have to activate the wifi card by typing:
Code:
ifup -a
Hope that gives you some insight or the solution. If you need more info on connecting to wifi when you only have the command line to deal with, do a search for: connect to wifi linux terminal. It turned up a few good answers.

Last edited by flipjarg; 09-19-2010 at 08:36 PM. Reason: added link
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Desktop Environment (GNOME) doesn't initiate after daily update (Debian Testing 64B) Mortuus Linux - Desktop 4 08-03-2010 06:06 AM
debian testing desktop pc beginner user 1986courage Debian 1 10-17-2009 03:08 PM
debian testing vs debian stable with testing repositories? wanas Debian 5 02-28-2009 10:23 PM
LXer: What Linux distribution do you use as a desktop? Debian Testing and Unstable LXer Syndicated Linux News 1 02-19-2006 07:01 PM
Setup as getting debian testing files from ftp - will it stay with testing BrianHenderson Debian 2 09-02-2004 06:06 PM


All times are GMT -5. The time now is 10:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration