LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-20-2012, 05:20 PM   #1
caa1980
Member
 
Registered: Aug 2004
Location: Salt Lake City, UT
Distribution: Ubuntu 10.04
Posts: 124

Rep: Reputation: 15
Debian testing as Guest in Virtualbox gets no Sound


I installed Debian testing onto Virtual box on my windows 7 machine using business card CD. Everything seems to work just fine but I am getting no sound. Sound driver appears to be installed and alsa is being loaded on boot up (Get an error if I switch virtual boxes sound card so I know it sees it on the one I am using). Using the intel HD audio card. How can I get the sound to work in my virtual box?
 
Old 07-20-2012, 07:05 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,891
Blog Entries: 2

Rep: Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808
Run alsamixer and check if your sound is muted.
 
Old 07-20-2012, 11:01 PM   #3
caa1980
Member
 
Registered: Aug 2004
Location: Salt Lake City, UT
Distribution: Ubuntu 10.04
Posts: 124

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by TobiSGD View Post
Run alsamixer and check if your sound is muted.
I have already run alsamixer and the sound is not muted.
 
Old 07-21-2012, 01:05 AM   #4
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 479

Rep: Reputation: 108Reputation: 108
Are you in the audio group?
 
Old 07-21-2012, 11:17 AM   #5
caa1980
Member
 
Registered: Aug 2004
Location: Salt Lake City, UT
Distribution: Ubuntu 10.04
Posts: 124

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jim_p View Post
Are you in the audio group?
Yes my user is in the audio group.
 
Old 07-27-2012, 11:36 AM   #6
caa1980
Member
 
Registered: Aug 2004
Location: Salt Lake City, UT
Distribution: Ubuntu 10.04
Posts: 124

Original Poster
Rep: Reputation: 15
I have tried different install methods of Debian in Virtual Box. The stable Live CD has sound but the Test version of Debian installed from Business Card CD (Net type Install) has no sound. Is there a way to copy the sound settings from a working Debian system on the same computers Virtual Box?
 
Old 07-27-2012, 12:15 PM   #7
62chevy
Member
 
Registered: Mar 2002
Location: West (By God) Virginia
Distribution: Debian Squeeze - Sid
Posts: 281

Rep: Reputation: 44
Quote:
Originally Posted by caa1980 View Post
I have tried different install methods of Debian in Virtual Box. The stable Live CD has sound but the Test version of Debian installed from Business Card CD (Net type Install) has no sound. Is there a way to copy the sound settings from a working Debian system on the same computers Virtual Box?

Maybe and that's a big maybe. Try running ' alsactl init ' first then check the mixer again.
 
Old 07-31-2012, 09:06 AM   #8
caa1980
Member
 
Registered: Aug 2004
Location: Salt Lake City, UT
Distribution: Ubuntu 10.04
Posts: 124

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by 62chevy View Post
Maybe and that's a big maybe. Try running ' alsactl init ' first then check the mixer again.
Code:
Found hardware: "ICH" "SigmaTel STAC9700,83,84" "AC97a:83847600" "0x8086" "0x0000"
This seemed to fix it how strange. Looks like I have to type that in after each reboot. Is there a way to add that to the start up?

Last edited by caa1980; 07-31-2012 at 09:45 AM.
 
Old 07-31-2012, 05:04 PM   #9
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Slackware
Posts: 14,891
Blog Entries: 2

Rep: Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808Reputation: 3808
Put it in /etc/rc.local
 
Old 07-31-2012, 05:08 PM   #10
caa1980
Member
 
Registered: Aug 2004
Location: Salt Lake City, UT
Distribution: Ubuntu 10.04
Posts: 124

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by TobiSGD View Post
Put it in /etc/rc.local
That did absolutely nothing for me. The problem seems to only exist in the Debian Testing branch. Doesn't happen in Stable or Unstable branch. I have decided to use the unstable branch then as it still gives me Gnome 3 but with out the problems found in testing.
 
Old 07-31-2012, 07:21 PM   #11
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
before boot up I prefer, on linux host to set sound as

alsa audio driver.....others include oss etc

hardware set as ....ac97.....others are intel and sb16

Last edited by aus9; 09-25-2013 at 06:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to check version of virtualbox guest additions currently installed in guest syste masuch Linux - Virtualization and Cloud 3 09-03-2012 01:05 AM
[SOLVED] Debian v6.0 - squeeze host with VirtualBox - run Windows XP as guest? larrym82 Linux - Virtualization and Cloud 6 12-26-2011 11:52 AM
Host Fedora14, Windows 7 is running as Virtualbox guest- Mic is not working on Guest mwaheed Linux - Virtualization and Cloud 1 10-20-2011 12:51 PM
VirtualBox (windowsxp guest) sound problem Kristian2 Slackware 13 03-13-2010 04:19 PM
[SOLVED] Debian as VirtualBox guest ursusca Linux - Virtualization and Cloud 3 01-20-2010 06:42 AM


All times are GMT -5. The time now is 09:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration