LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian testing as Guest in Virtualbox gets no Sound (http://www.linuxquestions.org/questions/debian-26/debian-testing-as-guest-in-virtualbox-gets-no-sound-4175417862/)

caa1980 07-20-2012 05:20 PM

Debian testing as Guest in Virtualbox gets no Sound
 
I installed Debian testing onto Virtual box on my windows 7 machine using business card CD. Everything seems to work just fine but I am getting no sound. Sound driver appears to be installed and alsa is being loaded on boot up (Get an error if I switch virtual boxes sound card so I know it sees it on the one I am using). Using the intel HD audio card. How can I get the sound to work in my virtual box?

TobiSGD 07-20-2012 07:05 PM

Run alsamixer and check if your sound is muted.

caa1980 07-20-2012 11:01 PM

Quote:

Originally Posted by TobiSGD (Post 4734154)
Run alsamixer and check if your sound is muted.

I have already run alsamixer and the sound is not muted.

jim_p 07-21-2012 01:05 AM

Are you in the audio group?

caa1980 07-21-2012 11:17 AM

Quote:

Originally Posted by jim_p (Post 4734279)
Are you in the audio group?

Yes my user is in the audio group.

caa1980 07-27-2012 11:36 AM

I have tried different install methods of Debian in Virtual Box. The stable Live CD has sound but the Test version of Debian installed from Business Card CD (Net type Install) has no sound. Is there a way to copy the sound settings from a working Debian system on the same computers Virtual Box?

62chevy 07-27-2012 12:15 PM

Quote:

Originally Posted by caa1980 (Post 4739510)
I have tried different install methods of Debian in Virtual Box. The stable Live CD has sound but the Test version of Debian installed from Business Card CD (Net type Install) has no sound. Is there a way to copy the sound settings from a working Debian system on the same computers Virtual Box?


Maybe and that's a big maybe. Try running ' alsactl init ' first then check the mixer again.

caa1980 07-31-2012 09:06 AM

Quote:

Originally Posted by 62chevy (Post 4739541)
Maybe and that's a big maybe. Try running ' alsactl init ' first then check the mixer again.

Code:

Found hardware: "ICH" "SigmaTel STAC9700,83,84" "AC97a:83847600" "0x8086" "0x0000"
This seemed to fix it how strange. Looks like I have to type that in after each reboot. Is there a way to add that to the start up?

TobiSGD 07-31-2012 05:04 PM

Put it in /etc/rc.local

caa1980 07-31-2012 05:08 PM

Quote:

Originally Posted by TobiSGD (Post 4742516)
Put it in /etc/rc.local

That did absolutely nothing for me. The problem seems to only exist in the Debian Testing branch. Doesn't happen in Stable or Unstable branch. I have decided to use the unstable branch then as it still gives me Gnome 3 but with out the problems found in testing.

aus9 07-31-2012 07:21 PM

before boot up I prefer, on linux host to set sound as

alsa audio driver.....others include oss etc

hardware set as ....ac97.....others are intel and sb16


All times are GMT -5. The time now is 03:58 AM.