LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian Squeeze grub doesn't detect windows partition on install (http://www.linuxquestions.org/questions/debian-26/debian-squeeze-grub-doesnt-detect-windows-partition-on-install-830836/)

Cultist 09-07-2010 03:04 PM

Debian Squeeze grub doesn't detect windows partition on install
 
I've installed Lenny with no problem, but I tried switching to Squeeze, and grub for some reason didn't pick up on the Windows partition this time - it just shows the two Linux options (debian and debian single-user). Someone suggested that I check the menu.lst file (which I've edited under Lenny with no issues), but for some reason it doesn't exist at all in this install. Is it in a different location with Squeeze maybe?

Any idea why grub didn't pick up on my Windows install?

the trooper 09-07-2010 03:26 PM

Try the following as root:

Code:

aptitude install os-prober
update-grub

Hopefully you can now boot your Windows partition.

Cultist 09-07-2010 05:57 PM

haven't rebooted yet but it said that it found win7, so that seems to be what I needed. Thanks a ton

lugoteehalt 05-17-2011 04:26 PM

Quote:

Originally Posted by the trooper (Post 4090704)
Try the following as root:

Code:

aptitude install os-prober
update-grub

Hopefully you can now boot your Windows partition.

Yes, but you need to run os-prober. Sorry to be simple minded. This solved the problem for me.


All times are GMT -5. The time now is 01:26 PM.