LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-07-2010, 03:04 PM   #1
Cultist
Member
 
Registered: Feb 2010
Location: Chicago, IL
Distribution: Slackware64 14.1
Posts: 777

Rep: Reputation: 102Reputation: 102
Debian Squeeze grub doesn't detect windows partition on install


I've installed Lenny with no problem, but I tried switching to Squeeze, and grub for some reason didn't pick up on the Windows partition this time - it just shows the two Linux options (debian and debian single-user). Someone suggested that I check the menu.lst file (which I've edited under Lenny with no issues), but for some reason it doesn't exist at all in this install. Is it in a different location with Squeeze maybe?

Any idea why grub didn't pick up on my Windows install?
 
Old 09-07-2010, 03:26 PM   #2
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Try the following as root:

Code:
aptitude install os-prober
update-grub
Hopefully you can now boot your Windows partition.
 
1 members found this post helpful.
Old 09-07-2010, 05:57 PM   #3
Cultist
Member
 
Registered: Feb 2010
Location: Chicago, IL
Distribution: Slackware64 14.1
Posts: 777

Original Poster
Rep: Reputation: 102Reputation: 102
haven't rebooted yet but it said that it found win7, so that seems to be what I needed. Thanks a ton
 
Old 05-17-2011, 04:26 PM   #4
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by the trooper View Post
Try the following as root:

Code:
aptitude install os-prober
update-grub
Hopefully you can now boot your Windows partition.
Yes, but you need to run os-prober. Sorry to be simple minded. This solved the problem for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrom-detect in Debian Squeeze godzillarama Debian 4 02-21-2010 06:00 PM
Debian Squeeze: Grub not working (XP removing grub) wearetheborg Debian 10 02-16-2010 05:33 PM
Grub does not see windows partition after full Puppy install. Pearci Linux - Newbie 6 06-04-2008 07:02 PM
Lost Windows partition after using install-grub command viperflyer Linux - Newbie 3 09-05-2007 04:30 AM
In desperate need... Grub wont detect my windows partition... psyklops Linux - General 4 08-20-2003 12:34 AM


All times are GMT -5. The time now is 07:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration