LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian Squeeze - Cannot connect to network (http://www.linuxquestions.org/questions/debian-26/debian-squeeze-cannot-connect-to-network-923766/)

qkzoo 01-14-2012 11:01 AM

Debian Squeeze - Cannot connect to network
 
I installed Debian Squeeze to a partition on my HP Mini 110 netbook. On the other partition, I have Lubuntu installed, and it works fine. On The debian install, I was finally able to get wicd installed, it sees my network, but won't connect. Initially, it said that I was entering the wrong passphrase. Scratching my head, because I verified I entered the wrong one over and over again, I finally made the network open. Now that it's open, it still won't connect. I could use some assistance,

thanks!

Thor_2.0 01-14-2012 02:02 PM

Okay, what does ifconfig say?

tried to ping your box? try this:
Quote:

ping 127.0.0.1
if that works, try to ping the default gateway

Let's see where we end up, it is in the install of Debian, I'm sure...

The usual way I initiate networking is (in the console)

Quote:

ifconfig eth0 [IP address] netmask [netmask, susally 255.255.255.0) broadcast [broadcast IP] up
route add default gw [IP of the default agateway]
vi /etc/resolv.conf - enter the nameservers as "nameserver [IP from the provider]
Good luck

Thor

craigevil 01-14-2012 02:46 PM

Start here: WiFi - Debian Wiki : http://wiki.debian.org/WiFi

qkzoo 01-14-2012 08:46 PM

ifconfig results:

root@andrew-netbook:/home/andrew# ifconfig
eth0 Link encap:Ethernet HWaddr 00:21:cc:47:89:e1
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:26 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:96 errors:0 dropped:0 overruns:0 frame:0
TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8058 (7.8 KiB) TX bytes:8058 (7.8 KiB)

root@andrew-netbook:/home/andrew#

I'll post the output of the pings as soon as I get them, I forgot my router's ip, :o

frankbell 01-14-2012 09:26 PM

Also, please post the contents of your /etc/network/interfaces file.

Please surround them in "code" tags, which become available when you click the "Go Advanced" button at the bottom of the "Quick Reply" window.

Your router's ip address is likely 192.168.1.1 or 192.168.2.1 or something like that. If you have another computer in your network, find out its IP address and replace the last numeral with "1." The odds are that will connect to your router.

qkzoo 01-15-2012 07:48 AM

Ok, here is my /etc/network/interfaces file:

Code:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto wlan0
iface wlan0 inet static
        address 192.168.2.3
        netmask 255.255.255.0
        network 192.168.2.0
        broadcast 192.168.2.255
        gateway 192.168.2.1
        # wireless-* options are implemented by the wireless-tools package
        wireless-mode managed
        wireless-essid Diamond
        wireless-key1 s:12345
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.2.1
        dns-search diamond


frankbell 01-16-2012 07:31 PM

Unless 192.168.2.1 is running a DNS server program such as BIND, I think you need to point to a valid DNS server.

If 192.168.2.1 is a router, as I suspect is likely, it will pass the nameserver to DHCP clients, but not to static IP clients.

Again, if my guess is correct (and I am guessing), you need to enter a valid DNS server address for the dns-nameservers value or remove that line.

Here's my /etc/network/interfaces for comparison:

Code:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
address [ip-address]
netmask 255.255.255.0
gateway 192.168.1.1

auto eth0

And the output of my ifconfig:

Code:

eth0      Link encap:Ethernet  HWaddr 00:11:11:a9:7d:8d 
          inet addr:[ip-address]  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::211:11ff:fea9:7d8d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:72124088 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37311844 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3769889785 (3.5 GiB)  TX bytes:3966764456 (3.6 GiB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:392540 errors:0 dropped:0 overruns:0 frame:0
          TX packets:392540 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:16496768 (15.7 MiB)  TX bytes:16496768 (15.7 MiB)



All times are GMT -5. The time now is 12:33 AM.