LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian server on vmware can't be found after being online several hours (http://www.linuxquestions.org/questions/debian-26/debian-server-on-vmware-cant-be-found-after-being-online-several-hours-828783/)

MortenOnDebian 08-27-2010 03:39 AM

Debian server on vmware can't be found after being online several hours
 
Hi,

Recently I set up a Debian server following this guide:
http://www.howtoforge.org/perfect-se...nny-ispconfig3

However I wasn't able to connect to the internet after the clean install of debian. So I googled and found a fix:

ifconfig eth0 192.168.15.x
route add -net 0.0.0.0 netmask 0.0.0.0 gw 192.168.15.y

Where x is a number not in use by any machine
Where y is the number on the gateway

These commands are appended to /etc/rc.d/rc.local and works fine.

The server is virtual and running on a vmware installation.


The problem, I have, appears randomly after the server has been startet. Sometimes after 20 hours and sometimes after 9 hours only.

I can't connect to the server through the web (server.mydomain.com). However I can reach my computer running vmware at (host.mydomain.com). In vmwares terminal window I can access the debian installation which is running all fine. No errors or so. I can even ping remote ip-adresses from the debian server without problems. Restarting the server fixes the problem. But it then re-appears after some time.

Any ideas how to solve??

Regards
Morten

Dutch Master 08-28-2010 12:47 PM

Things to check/investigate:

1) did you enable the 'keepalive' options?
2) what is the TTL of the DNS entries of the guest machine? (TTL: time to live, i.e. the period for which the data is valid)

MortenOnDebian 08-29-2010 12:47 PM

Well, since I don't know where those options are designed (or the fact that they exists), it sounds like it could be one the reason. Can you help me change these settings?

Regards
Morten

Dutch Master 08-29-2010 05:38 PM

I'm afraid I can't: I'm not familiar with VMWare. However, the TTL is set by the DHCP server (most likely in your router) and you may find a setting for 'keepalive' there too.

MortenOnDebian 09-26-2010 04:56 AM

Well that seemed to solve the problem. Thank you very much for your help!


All times are GMT -5. The time now is 07:09 PM.