LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian Screen resolution..... (http://www.linuxquestions.org/questions/debian-26/debian-screen-resolution-344212/)

Eux 07-18-2005 04:49 AM

Debian Screen resolution.....
 
Sorry guys, I feel ashamed for this silly question.

Recently I have upgraded my distro from Woody to Sarge; everything a-OK eccept that the screen resolution is awfully large. I have run "dpkg-reconfigure
xserver-xfree86" a couple of time and chose the screen resolution to 1278x768 but it does not change.

How can I just adjust the resolution without having to go through all the options of the dpkg-reconfigure?

Also, I have upgraded and installed a new kernel 2.6.12 and I need to install the NVidia drivers.

I have run the command as root: "sh Nvidia-1x-x-x-x blah blah thingy and is says that it cannot complete the installation because it does not find the kernel header.

I remember that before all I needed to do was install the new kernel and run the commmand but now,......I dun'know"!


Thanks for the help"!



Eux

mrog 07-18-2005 06:21 AM

debian display resolution
 
Eux:

I've had the same problem. I don't know why Debian refuses to use the resolution that was asked for during installation. It's a bit silly.

In the file /etc/X11/XF86-Config-4 you'll find sections on the screen/display settings that look something like this: (there will be multiple lines like this but with different depths)

Depth 24
Modes "800x600" "640x480"

Try adding "1278x768" to the modes lines and reboot.

Modes "1278x768" "800x600" "640x480"

I've read, somewhere, where people have had to install additional modules to get higher resolutions working, but I can't recall what it was at this point. For now, try the above as it would be the easiest fix.

darkleaf 07-18-2005 11:04 AM

You also have to install the kernel-headers package then for the nvidia drivers:

"apt-get install linux-kernel-headers"

To make higher resolutions work you have to edit each color depth not only 24. All the lines should be the same.

pradeepyamujala 07-18-2005 01:05 PM

I hope this will work
 
I too got this problem. here my case is

CPU : AMD 64bit (Does't matter)
Graphics: S3 UniChormeII (Matters)
Monitor: Samsung Samtron 56v

Solution:
Reinstal ur distro. when it ask for "AUTODETECTION for ur MONITOR" say so then its next page is What type of setup u want to instal monitor, say ADVANCED.
Now UR VGA driver will be "VESA" and enter ur monitor Sync Range is as follows
Vertical : 50-75
Horizantal: 28-96

now go through remaining setup. and hopefully u get u desired screen.

All the best
Enjoy Debian - The Ultimate

darkleaf 07-18-2005 01:39 PM

You don't need to reinstall for that. Simply edit your /etc/X11/XF86Config (maybe XF86Config-4) file.

Eux 07-19-2005 02:21 AM

Thank you all for your help, you guys"!


I will let you know how it goes"!


Thnx again.



May the Tux be with you!

Tons of Fun 07-19-2005 06:33 AM

I never got the nvidea drivers working, but don't need them as my LCD monitor does just fine with the VESA drivers (I am not a gamer, so this is OK). But when running dpkg-reconfigure xserver-xfree86, I not only chose 1024 x 768, but I removed the other pre-chosen resolutions. This only gives Debian one choice to choose from and it worked.

Good Luck!

:study:

darkleaf 07-19-2005 07:24 AM

Tons of Fun did the installation stop with an erro? It might be that your video card isn't supported anymore by the official nvidia installer. It works however with the nvidia-glx in the debian repositories.

Here's a link to how you can install it:
http://home.comcast.net/~andrex/Debi...tallation.html

Tons of Fun 07-19-2005 08:02 AM

I don't remember what the error code was. It is an old card, a Riva TNT 16 MB card, so it is possible that it's too old. Thanks for the link, I will give it a try and see what happens. If for no other reason, to accomplish another configuration challange.

Thanks,

:study:

darkleaf 07-19-2005 10:55 AM

Yep that's too old. I have a riva 32mb and it was too old too.

Tons of Fun 07-19-2005 12:39 PM

Darkleaf,
Thank you very much for the link in your previous post to me. I followed the instructions on that page, and I now have the nVidia drivers loaded. I was definitely wrong when I said that the VESA drivers were as good. With the nVidia drivers loaded, the screen is much clearer, the text more sharp, and the lines tighter. It looked good before, but this is excellent.

Thanks!

:study:

Tons of Fun 07-19-2005 12:42 PM

Oh yea, one more question; now that the drivers are loaded, do I need to comment out the new address I added to my /etc/apt/sources.list, or do I leave it for updates?

:study:

darkleaf 07-19-2005 01:23 PM

Which address did you add? Cause you could have got it from the testing directory (as I see you're using etch as well). If you added the sid repository for it and you don't want all your packages to go to sid but only nvidia:

Leave the sources.list as it is. Open /etc/apt/preferences and do this nvidia-glx add the nvidia packages to pinning in sid. I don't know which packages you installed but i have these:
Quote:

root@debian:~# dpkg -l | grep nvidia | awk '{print $2}'
nvidia-glx
nvidia-kernel-2.6.11.6
nvidia-kernel-common
nvidia-kernel-source
nvidia-settings
So you can use them with apt-pinning: (under point 3.10)
http://www.debian.org/doc/manuals/ap...pt-get.en.html

I'm not sure if these are upgraded though could be that it's only once when you compile a new kernel.

If you don't want sid at all remove the sid line.

Tons of Fun 07-19-2005 01:36 PM

I added "deb http://http.us.debian.org/debian testing main contrib non-free"

Here are the packages

neuromancer:~# dpkg -l|grep nvidia|awk '{print $2}'
nvidia-glx
nvidia-kernel-
nvidia-kernel-
nvidia-kernel-
neuromancer:~#

It didn't print anything after the -, don't know why. I am running listbugs, so I believe that I will leave it as is. Thanks again for the help.

:study:

darkleaf 07-19-2005 01:39 PM

So from your distro in your profile it says sarge/etch. Did you already have that line but only had to add nonfree? Nonfree is for everything that doesn't fit in debian's policy. It's a closed source part of the driver so the license is wrong to have it in another repository.

If you keep it like this you'll upgrade packages into testing.
edit: unless you pinned everything on sarge but then adding this line wouldn't have had any difference.


All times are GMT -5. The time now is 07:47 AM.