LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-25-2007, 06:26 PM   #1
Gerard_2009
LQ Newbie
 
Registered: Jan 2005
Location: Switzerland
Distribution: debain lenny, slackware 10.0, vectorlinux 4.3, kubuntu feisty
Posts: 23

Rep: Reputation: 15
debian lenny glibc_2.4 missing


Hello,

I installed debian lenny some days ago, everything is working perfectly fine, except NetBeans 5.5.1 complaining:


/.netbeans/5.5.1/emulators/wtk251-lin/emulator/bin/preverify1.1: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found

I checked with apt-cache but couldnt find a package looking to be the right one for this problem.

Someone on this post had GLIBC_2.4 missing for unrar

http://www.linuxquestions.org/questi...d.php?t=553429

I also saw some other threads with apps not running for the same Glib_2.4 not found problem.

As I understand the situation, my libc.so.6 is either the wrong version, or it's not recognized.

Is there any solution to this? would it be possible to install a glibc_2.4 version? (where could i get it) or would it bring major dependency problems if I tried to get the glibc_2.4 libc.so.6 installed?


Thanks for your help
 
Old 05-26-2007, 11:24 AM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
The 2.4 version was not included in any Debian package that I know of they had 2.3 then went directly to 2.5 you should see if you can get a version of the program that works with the newer version.
 
Old 05-26-2007, 02:02 PM   #3
Daws
Member
 
Registered: May 2006
Location: UK
Distribution: Debian, Linux From Scratch
Posts: 416
Blog Entries: 1

Rep: Reputation: 32
2.4 was in experimental for a while before 2.5 was released. It never hit Sid. I have heard that you can get older packages for Debian somewhere, but it is unlikely that these archives contain old experimental packages (even if you do find it, consider that it was too unstable even for Sid).
 
Old 05-26-2007, 03:35 PM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally Posted by Daws
2.4 was in experimental for a while before 2.5 was released. It never hit Sid. I have heard that you can get older packages for Debian somewhere, but it is unlikely that these archives contain old experimental packages (even if you do find it, consider that it was too unstable even for Sid).
Ah then you would want http://snapshot.debian.net/ possibly for it although if it never made it into the archive on the main servers I doubt that I would use it there must have been some reason it never got there.
 
Old 05-26-2007, 04:00 PM   #5
Daws
Member
 
Registered: May 2006
Location: UK
Distribution: Debian, Linux From Scratch
Posts: 416
Blog Entries: 1

Rep: Reputation: 32
Well, it appears snapshot.debian.net does keep track of experimental packages. The last libc6 before 2.5 appeared in experimental was 2.3.999.2-12. Oh and 2.6 is available if you're interested...
 
Old 06-01-2008, 08:14 AM   #6
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Rep: Reputation: 51
Quote:
Originally Posted by Gerard_2009 View Post
Hello,

I installed debian lenny some days ago, everything is working perfectly fine, except NetBeans 5.5.1 complaining:


/.netbeans/5.5.1/emulators/wtk251-lin/emulator/bin/preverify1.1: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found

I checked with apt-cache but couldnt find a package looking to be the right one for this problem.

Someone on this post had GLIBC_2.4 missing for unrar

http://www.linuxquestions.org/questi...d.php?t=553429

I also saw some other threads with apps not running for the same Glib_2.4 not found problem.

As I understand the situation, my libc.so.6 is either the wrong version, or it's not recognized.

Is there any solution to this? would it be possible to install a glibc_2.4 version? (where could i get it) or would it bring major dependency problems if I tried to get the glibc_2.4 libc.so.6 installed?


Thanks for your help

I have the etch and the error as well :
Code:
 /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found
what to do please ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need basic router help (Debian Lenny) Nathan1993 Linux - Server 3 04-21-2007 12:24 PM
Last week Debian Testing is still ETCH or lenny already?? doraimom Debian 1 04-09-2007 07:01 AM
slocate missing 'GLIBC_2.3.4' B33FST3W Slackware 3 12-12-2006 05:59 PM
GLIBC_2.3.2 missing divali Slackware 3 02-26-2006 10:16 AM
Can't login missing GLIBC_2.3.4 not found - required for -bash youngie Slackware 1 12-18-2005 01:41 PM


All times are GMT -5. The time now is 11:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration