LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian Lenny fglrx and scrambled fullscreen problem (e.g. with wine) (http://www.linuxquestions.org/questions/debian-26/debian-lenny-fglrx-and-scrambled-fullscreen-problem-e-g-with-wine-674811/)

kapal 10-07-2008 10:00 AM

Debian Lenny fglrx and scrambled fullscreen problem (e.g. with wine)
 
Hello.

I'm using Debian Lenny Testing on Laptop Lenovo T60.

I've installed fglrx drivers using module-assistant.

The driver works fine with fullscreen applications e.g. googleearth, supertuxcart, mplayer etc.

But it fails with any fullscreen wine application (e.g. Blizzards StarCraft, WarCraft). All I get is a scrambled screen filled with 10px squares. Apart of the display the application works correctly. When exited it goes back to normal.

I think it is the driver issue, because with radeonhd or the built-in Xorg driver the application works correctly on the same system.

Does anyone have a clue about this?

Some info about my system:

Code:

$ uname -a
Linux leniewote60 2.6.26-1-686 #1 SMP Wed Sep 10 16:46:13 UTC 2008 i686 GNU/Linux

Code:

$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400

Code:

$ glxinfo | grep direct
direct rendering: Yes

Code:

$ X -version

X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4.2-6)
Current Operating System: Linux leniewote60 2.6.26-1-686 #1 SMP Wed Sep 10 16:46:13 UTC 2008 i686
Build Date: 15 September 2008  01:25:11AM

        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present

Code:

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1400
OpenGL version string: 2.1.7769 Release

If needed I can post more info.

regards,

radiodee1 10-07-2008 12:04 PM

I had this problem with dvd-shrink on wine and it was solved by downloading a new version of quartz.dll and setting it as the default (I think it should be set to 'builtin' as opposed to 'native'). When you switch to radeonhd you have to switch back to 'native'. I think a good site to get the dll from is http://www.dll-files.com/ but I'm sure there are others.

I don't know if this addresses your problem, but it worked for me. :)

kapal 10-07-2008 12:37 PM

Thanks for reply radiodee1!

Thank you for the clue. I will try to play with wine dlls.
It might be the issue, because I've added some native dlls to wine.
I'll post the results.

kapal 10-08-2008 05:26 AM

I've cleared .wine and reinstalled fglrx driver, this time from ati(amd) official installer and still getting this problem.

Any ideas?

Here is my wine version:
Code:

$ wine --version
wine-1.0


mensch 10-08-2008 09:08 AM

You might want to try a newer version of Wine. I've had the same issues with the checkered screen on resolution change in Crossover Games. There are problems with this on ATI cards and fglrx drivers in the 1.0 Wine version but a fix has been committed in later releases.

Upgrading fglrx to 8.9 and using a nightly build of Crossover Games (which incorporates the latest fixes from the Wine trunk) I can play 3D games again.

The latest Wine version (1.1.5) is in the experimental repositories, so you might want to get it from there.

kapal 10-09-2008 03:02 AM

Thanks!
I guess this is the solution, because here is what I've done:
  • I've reinstalled fglrx drivers using this howto,
  • I've installed wine from experimental repositories.
Fullscreen wine applications which resulted with checkered screen work fine now.

Quote:

Originally Posted by mensch (Post 3304052)
You might want to try a newer version of Wine. I've had the same issues with the checkered screen on resolution change in Crossover Games. There are problems with this on ATI cards and fglrx drivers in the 1.0 Wine version but a fix has been committed in later releases.

Upgrading fglrx to 8.9 and using a nightly build of Crossover Games (which incorporates the latest fixes from the Wine trunk) I can play 3D games again.

The latest Wine version (1.1.5) is in the experimental repositories, so you might want to get it from there.


kapal 10-13-2008 09:08 AM

It turns out, that wine is fine :).

I should have done it with one step at the time, because I've downgraded wine back to wine-1.0 and I'm not getting `scrambled' screen any more.

I guess it was the fglrx driver issue as I suspected from the beggining.
Thank you for your replays.


All times are GMT -5. The time now is 04:50 PM.