LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian KDE XWindow Remaining Open (http://www.linuxquestions.org/questions/debian-26/debian-kde-xwindow-remaining-open-740315/)

bruceam 07-15-2009 02:13 PM

Debian KDE XWindow Remaining Open
 
I have installed KDE 4.x on my Lenny installation of Debian. It was my desire to have the computer boot up to the command line and then allow me to initialize the GUI at my discretion. I succeeded with this setup quite will, but for one thing. See Below

Once I have booted up, logged in, and done whatever else I need/want to do from the command line, I execute the following command:

$ xinit

This starts the X Windows system upon which KDE is layered. Once this finishes, I am presented with ax X Window terminal window where I enter the following command:

$ startkde

KDE now starts and everything runs just fine. The only thing is that the X Window that I had to use to start KDE is still up. When I exit KDE, the original X Window is still there, and it is into this window that I type:

$ exit

to return to the command prompt where the whole process began.



Question: Is there a way of manually launching KDE from the command line, well after the boot up process has completed, that does not leave this residual window open?

rbees 07-17-2009 08:49 PM

Try startx, or maybe kdm/gdm/xdm what ever you use for your display manager. Startx should bring you up to the default (last used) gui.

bruceam 07-18-2009 07:34 PM

rbees,
Thank you for your suggestion. Issuing the "startx" command didn't work the first time I tired it, but it gave me the clue I needed to make the setup work the way I wanted. Here's what I did.

In stead of issue in the xinit command, I went directly to the startx command. This had to be setup in the following manner:

First: I had to create two files, a file called "config" in the /etc/X11 directory which must be done as root, and a file called ".xsession" in my home directory which is done as the regular user.
Second: Edit the "config" file in the /etc/X11 directory to contain the line "allow-user-xsession". The permits the X windows server to use the ".xsession" file for configuration and preamble at start up.
Third: edit the file ".xsession", and change it's premissions so that it becomes executable. Like this: chmod u+x .xsession
Fourth: I put the line "exec kdm" into this file and saved everything.

Just remember that when this script file's process terminates, X will also terminate.

I saved the files, and rebooted just to make certain there was nothing still running.

Once I had logged in, I issued the "startx" command, as you recommended, and everything worked just the way I wanted it!

Thanks again.

rbees 07-18-2009 10:31 PM

Cool :cool:

My setup is form a default install so I never did anything about setting it up to work.

One thing I see from time to time on one of my servers is that the onwership of .Xauthority get changed from time to time. Not sure why this happens. But I think it relates to the fact that I log into the machine through ssh and run root apps and commands. Most of the time the gui is not started. When the onwership gets changed xsession errors show up on my lappy when I run x apps. So I have to go in and change the onwership of the file back.

Anyway glad I was able to help.


All times are GMT -5. The time now is 02:05 AM.