LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-14-2012, 09:53 AM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Rep: Reputation: 53
Debian fails to boot


Hi all,

Fedora 17 64bit
Debian 6.0.6 64bit
Dualboot

On Debian ran;
# apt-get -t squeeze-backports install linux-image-3.2.0-0.bpo.3-amd64 firmware-linux-free

Rebooted
New kernel not found on GRUB prompt only old kernel there
Code:
Linux version 2.6.32-5-amd64 (Debian 2.6.32-46)
Debian still can be booted.

Then on Fedora ran;
$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Rebooted and on GRUB prompt Debian new kernel was still not displayed. The new kernel was found under "Advanced Option" of Debian.

Started Debian with new kernel a black screen displayed finally. Pressed [Ctrl]+[Alt]+/F1/F2/F4 etc with no action.

Then forced-rebooted PC and booted Debian new kernel recovery mode. It was dropped to Shell.

Then I ran;
# blkid
found the device of Debian

# fsck -yf /dev/sda3 (device of Debian)

Rebooted.

Debian is now completely not shown up on GRUB prompt.

Please help. TIA

B.R.
satimis
 
Old 10-14-2012, 09:28 PM   #2
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,675

Rep: Reputation: 122Reputation: 122
I understand you installed Debian first, then put Fedora next to it, correct? If so, this is essentially a Fedora issue Key is that Fedora controls the Grub menu in that case, so when fsck has finished, run the update command for grub:
Code:
update-grub
Then, if you choose to have Grub controlled by Debian, install Grub from Debian with
Code:
grub-install /dev/sda
It's wise (but probably not necessary) to re-run the grub update command again. It reports the entries it has found, so you can take action before rebooting if something goes haywire
 
Old 10-14-2012, 11:07 PM   #3
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by Dutch Master View Post
I understand you installed Debian first, then put Fedora next to it, correct?
Yes,that is correct.

Quote:
If so, this is essentially a Fedora issue Key is that Fedora controls the Grub menu in that case, so when fsck has finished, run the update command for grub:
Code:
update-grub
Now I can't start Debian any more. It is not displayed on GRUB prompt. Where shall I run "update-grub"?

Quote:
Then, if you choose to have Grub controlled by Debian, install Grub from Debian with
Code:
grub-install /dev/sda
It's wise (but probably not necessary) to re-run the grub update command again. It reports the entries it has found, so you can take action before rebooting if something goes haywire
I'll come to this step later.

Thanks

satimis
 
Old 10-15-2012, 03:44 AM   #4
el chapulín
Member
 
Registered: Sep 2012
Posts: 75

Rep: Reputation: 19
In a dual boot scenario only one of the installed OS can control the bootloader, so you don't need to install grub in both - just install it from the first OS on the disk and control it from there.
 
Old 10-15-2012, 03:52 AM   #5
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by el chapulín View Post
In a dual boot scenario only one of the installed OS can control the bootloader, so you don't need to install grub in both - just install it from the first OS on the disk and control it from there.
Please advise how can I correct it. I installed Debian first. I expect Debian to have grub installed there. Thanks

B.R.
satimis
 
Old 10-15-2012, 05:24 AM   #6
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Wallowing in a pit of despair.
Distribution: Slackware, OpenBSD
Posts: 1,217
Blog Entries: 4

Rep: Reputation: 327Reputation: 327Reputation: 327Reputation: 327
Quote:
Originally Posted by satimis View Post
Please advise how can I correct it. I installed Debian first. I expect Debian to have grub installed there.
Dutch Master already gave you the reason.
Quote:
Key is that Fedora controls the Grub menu in that case, so when fsck has finished, run the update command for grub:
When you installed Fedora, you installed GRUB again (correct?). That means, at the moment it is Fedora's GRUB. You need to update it to include both systems.
 
Old 10-15-2012, 05:50 AM   #7
el chapulín
Member
 
Registered: Sep 2012
Posts: 75

Rep: Reputation: 19
Boot into fedora and try doing the following:

Code:
# os-prober
# update-grub
 
Old 10-15-2012, 07:21 AM   #8
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by el chapulín View Post
Boot into fedora and try doing the following:

Code:
# os-prober
# update-grub
# os-prober
Code:
  No volume groups found
/dev/sda5:Debian GNU/Linux (6.0.6):Debian:linux
# update-grub
Code:
bash: update-grub: command not found...
# yum install update-grub
Code:
Loaded plugins: langpacks, presto, refresh-packagekit
No package update-grub available.
Error: Nothing to do
 
Old 10-15-2012, 07:27 AM   #9
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,675

Rep: Reputation: 122Reputation: 122
update-grub is not a program/package, it's part of Grub2, so you can't install it separately.
Code:
yum install grub2
Alternatively, boot a Knoppix CD and install Grub from there.
 
Old 10-15-2012, 07:53 AM   #10
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by Dutch Master View Post
update-grub is not a program/package, it's part of Grub2, so you can't install it separately.
Code:
yum install grub2
Alternatively, boot a Knoppix CD and install Grub from there.
# yum install grub2
Code:
Loaded plugins: langpacks, presto, refresh-packagekit
Package 1:grub2-2.0-0.38.beta6.fc17.x86_64 already installed and latest version
Nothing to do
# update-grub
Code:
bash: update-grub: command not found...
Quite strange ?

Previously I ran;
$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg
Code:
[sudo] password for satimis:
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.6.1-1.fc17.x86_64
Found initrd image: /boot/initramfs-3.6.1-1.fc17.x86_64.img
Found linux image: /boot/vmlinuz-3.5.6-1.fc17.x86_64
Found initrd image: /boot/initramfs-3.5.6-1.fc17.x86_64.img
Found linux image: /boot/vmlinuz-3.3.4-5.fc17.x86_64
Found initrd image: /boot/initramfs-3.3.4-5.fc17.x86_64.img
  No volume groups found
done
 
Old 10-15-2012, 10:15 AM   #11
el chapulín
Member
 
Registered: Sep 2012
Posts: 75

Rep: Reputation: 19
There is probably no "update-grub" script in fedora... so instead do it the manual way:
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
For some other distros it may be
Code:
grub-mkconfig -o /boot/grub/grub.cfg
This will regenerate the config.

Warning: When fiddling with bootloaders it's a good idea to have some kind of livecd handy to enable you to chroot into the system if it becomes unbootable.

Last edited by unSpawn; 10-15-2012 at 10:49 AM. Reason: (..)
 
Old 10-15-2012, 10:30 AM   #12
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by el chapulín View Post
There is probably no "update-grub" script in fedora... so instead do it the manual way:
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
# grub2-mkconfig -o /boot/grub2/grub.cfg
Code:
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.6.1-1.fc17.x86_64
Found initrd image: /boot/initramfs-3.6.1-1.fc17.x86_64.img
Found linux image: /boot/vmlinuz-3.5.6-1.fc17.x86_64
Found initrd image: /boot/initramfs-3.5.6-1.fc17.x86_64.img
Found linux image: /boot/vmlinuz-3.3.4-5.fc17.x86_64
Found initrd image: /boot/initramfs-3.3.4-5.fc17.x86_64.img
  No volume groups found
Found Debian GNU/Linux (6.0.6) on /dev/sda5
done
Debian found

Quote:
For some other distros it may be
Code:
grub-mkconfig -o /boot/grub/grub.cfg
This will regenerate the config.
# ls /boot/grub/
Code:
splash.xpm.gz
No grub.cfg file there


Edit:
Rebooted PC

Debian is NOT showing up at GRUB prompt

Last edited by satimis; 10-15-2012 at 10:37 AM.
 
Old 10-15-2012, 10:43 AM   #13
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by el chapulín View Post
In a dual boot scenario only one of the installed OS can control the bootloader, so you don't need to install grub in both - just install it from the first OS on the disk and control it from there.
Noted. Thank

During installation
- created LVM group
- created LVM partions taking up half HD space leaving the rest unused
- installed Debian
- installed Fedora on the unused space. But I was not allowed to create another LV group. The new LVM partitions still remained in the original LVM group
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Wheezy fails to boot into GUI after POST sj061 Debian 16 05-31-2011 07:45 PM
Debian USB install fails to boot after adding hard drive martinezpt Linux - Hardware 5 11-21-2010 07:21 PM
[SOLVED] Debian upgrade fails 4 packages udev, can only boot into safemode wikapuki Linux - Newbie 6 09-03-2010 12:11 PM
Partition copy from SATA to IDE fails to boot (debian amd-64 rc2) siggma Linux - Server 2 03-01-2008 01:08 PM
New install of Debian Sarge fails to boot Joe4 Linux - Hardware 3 11-18-2005 10:22 AM


All times are GMT -5. The time now is 09:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration