LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian Etch: IceWeasel fonts much fuzzier than Firefox and other apps on the same box (http://www.linuxquestions.org/questions/debian-26/debian-etch-iceweasel-fonts-much-fuzzier-than-firefox-and-other-apps-on-the-same-box-590301/)

masinick 10-08-2007 12:48 PM

Debian Etch: IceWeasel fonts much fuzzier than Firefox and other apps on the same box
 
I have the typical Debian Iceweasel and Icedove (and also IceApe) on my Debian Etch system. They all function fine, but the fonts do not seem to be anywhere near as crisp, (especially with Iceweasel) as they are with Firefox.

Just to be certain this was application specific and not system specific, I also installed Firefox on my Etch partition. When I started Firefox, the display looked comparable to what it does on many other distributions. When I restarted Iceweasel, I still noticed smaller, fuzzier fonts.

I have seen a few topics on this here and there, but so far, I have not stumbled upon a combination that really spruces up the appearance of Iceweasel fonts to make them equivalent to what I see in Firefox.

Any configuration files or other settings that can be established in order to get the appearance of Iceweasel comparable to Firefox and other applications? I do have plenty of crisp, readable fonts available.

Any specific details needed to advise on this?

Suggestions?

war1025 10-08-2007 03:20 PM

Stick with Firefox :) Its the same program, if you are on 32 bit I can't really see a reason not to use it. Especially if it works.

craigevil 10-08-2007 10:58 PM

Have you looked at the font settings that both Firefox and IW are using?
Try adding:
/* Fix the font layout */
user_pref("layout.css.dpi", 0);
to your user.js

and make sure they both use the same font and font size.

4TElevn 10-09-2007 02:54 PM

I just installed Etch last week and noticed the same fuzziness. After installing mstcorefonts and then playing with the fonts in Iceweasel's preferences <edit preferences content advanced> I was able to make it much "prettier". Arial 16 worked well for me. Hope this helps. :)

Deerslayer 10-10-2007 12:29 AM

What I did to fix this was to go to Edit|Preferences|Content|Advanced and uncheck Allow pages to choose their own fonts. Pages that looked awful before, like the LinuxQuestions main forums page, look really good now.

baikonur 10-10-2007 12:19 PM

Code:

aptitude install msttcorefonts
helps

Chili.Willy 01-07-2008 11:28 PM

Thanks, Deerslayer.
 
Your tip worked great for me.

masinick 02-21-2008 10:38 AM

BTW, I did come up with a solution but it was a rather roundabout one! I had been using Debian Etch at the time I was having this issue. I figured nothing ventured, nothing gained, particularly since I have many partitions and many distros (most of them Debian derived), so I pointed my apt sources to Sid and did an "upgrade"! Crazy thing to do perhaps, but it not only worked, it solved my problem. To add "stability" to Sid, I also added sidux repositories, and now I have a very usable and surprisingly stable distro that is based on Debian Sid with sidux tools and repositories added! I am most happy with it!

vpablos 04-30-2010 07:21 AM

The tip here worked for me:
http://support.mozilla.com/en-US/forum/1/586413

it says:



Put about:config into the address bar, Enter, click through any warning page ("I'll be careful") then into the Filter box paste:

layout.css.devPixelsPerPx

Double click the line listing that preference to change the value to 2


All times are GMT -5. The time now is 06:05 PM.