LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian dist-upgrade problem (http://www.linuxquestions.org/questions/debian-26/debian-dist-upgrade-problem-164103/)

m0llbuz_ 03-30-2004 06:09 AM

Debian dist-upgrade problem
 
Hi!

I have a problem with my Debian system. I'm using mostly testing packages, and I tried upgrading my system today:

# apt-get -u dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libxft-dev: Depends: libxft2 (= 2.1.2-5) but 2.1.2-6 is installed
x-window-system-core: Depends: xlibmesa-dri but it is not installed
Depends: xlibmesa-gl but it is not installed
Depends: xlibmesa-glu but it is not installed
E: Unmet dependencies. Try using -f.


I've tried installing the unstable versions:

# apt-get install libxft-dev/unstable xlibmesa-dri/unstable xlibmesa-gl/unstable xlibmesa-glu/unstable
Reading Package Lists... Done
Building Dependency Tree... Done
Selected version 2.1.2-6 (Debian:testing) for libxft-dev
Selected version 4.3.0-7 (Debian:testing) for xlibmesa-dri
Selected version 4.3.0-7 (Debian:testing) for xlibmesa-gl
Selected version 4.3.0-7 (Debian:testing) for xlibmesa-glu
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
xlibmesa-dri: Conflicts: xlibmesa3-gl but 4.2.1-12.1 is to be installed
xlibmesa-gl: Conflicts: libgl1
Conflicts: xlibmesa3-gl but 4.2.1-12.1 is to be installed
xlibmesa-glu: Conflicts: libglu1
Conflicts: xlibmesa3-glu but 4.2.1-12.1 is to be installed
xlibmesa3-gl: Conflicts: libgl1
xlibmesa3-glu: Conflicts: libglu1
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I've tried the specified solution:

# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
libxft-dev xlibmesa-dri xlibmesa-gl xlibmesa-glu
Suggested packages:
libglide3
The following packages will be REMOVED:
xlibmesa3-gl xlibmesa3-glu
The following NEW packages will be installed:
xlibmesa-dri xlibmesa-gl xlibmesa-glu
The following packages will be upgraded:
libxft-dev
1 upgraded, 3 newly installed, 2 to remove and 121 not upgraded.
55 not fully installed or removed.
Need to get 5582kB of archives.
After unpacking 3592kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://kalle.csb.ki.se testing/main libxft-dev 2.1.2-6 [60.2kB]
Get:2 http://kalle.csb.ki.se testing/main xlibmesa-gl 4.3.0-7 [242kB]
Get:3 http://kalle.csb.ki.se testing/main xlibmesa-glu 4.3.0-7 [324kB]
Get:4 http://kalle.csb.ki.se testing/main xlibmesa-dri 4.3.0-7 [4956kB]
Fetched 5582kB in 1s (3445kB/s)
(Reading database ... 55918 files and directories currently installed.)
Preparing to replace libxft-dev 2.1.2-5 (using .../libxft-dev_2.1.2-6_i386.deb) ...
diversion of /usr/X11R6/include/X11/Xft/Xft.h to /usr/X11R6/include/X11/Xft/Xft1.h by libxft-dev
Removing `diversion of /usr/X11R6/include/X11/Xft/Xft.h to /usr/X11R6/include/X11/Xft/Xft1.h by libxft-dev'
dpkg-divert: rename involves overwriting `/usr/X11R6/include/X11/Xft/Xft.h' with
different file `/usr/X11R6/include/X11/Xft/Xft1.h', not allowed
dpkg: error processing /var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 2
Errors were encountered while processing:
/var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can anybody help me?

Kind regards

siddhesh 03-30-2004 11:48 AM

Hi there,

This is what you do now.

Rename Xft.h and Xft1.h to Xft.h.old and Xft1.h.old respectively. And then do 'apt-get -f install'

I'm not too sure why this error comes... I got it on my system too, and it works fine now.

Siddhesh

vincery 11-09-2004 09:34 PM

Thank You
 
Thank you siddhesh!

I've got the same problem with m0llbuz_ and tried your
suggestion. It somehow helped me. Thanks again.










-------------------------------------------------------
Mark Vincent Verallo

macondo 11-10-2004 12:33 PM

I don't know if i'm reading you correctly, you are on Sarge and want to dist-upgrade to Sid?

The usual procedure is :

Edit your /etc/apt/sources.list

and change them to read 'sid'

#apt-get update
#apt-get dist-upgrade

If OTOH, you just want to dist-upgrade WITHIN sarge,:

#apt-get update
#apt-get dist-upgrade

APT-HOWTO
http://www.debian.org/doc/manuals/ap.../index.en.html


All times are GMT -5. The time now is 08:46 AM.