LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Debian Can't Seem To Switch Back To Text Mode! (http://www.linuxquestions.org/questions/debian-26/debian-cant-seem-to-switch-back-to-text-mode-938791/)

Zssfssz 04-08-2012 04:59 PM

Debian Can't Seem To Switch Back To Text Mode!
 
I just finished installing Debian 6.0.4 amd64 and ran update-grub in Ubuntu, found Debian fine. But in grub when I enter Debian, it just goes to that shade of purple Ubuntu has by default, and I know it's there because I can type:
root (enter)
muffins (enter)
shutdown -h now (enter)

And in 30 seconds the computer turns off.
How would I fix this, without turning the gui on?

descendant_command 04-08-2012 05:06 PM

edit the grub line with root=<something> to change kernelmodesetting for your video device, maybe?

Zssfssz 04-08-2012 10:23 PM

Can you explain?
Me + GRUB = Not Good :)

Dutch Master 04-08-2012 10:45 PM

Code:

man grub
:p ;)

TobiSGD 04-09-2012 06:56 AM

To disable the kernel mode setting press E in your bootloader's menu to edit the configuration of the current selected OS. Then add nomodeset to the kernel command line (the one beginning with linux /boot/vmlinuz.... and press Ctrl+x to boot the system. This is a one time solution. to give you better help we need to know which video hardware your machine is using.

Zssfssz 04-09-2012 08:57 AM

Ohh umm, I think it has two cards one nVida and one Intel.
In a recent trip to San fransisco I found out "Intel" means INTergrated ELectronics!

TobiSGD 04-09-2012 09:45 AM

Intel is the manufacturer of your CPU. If you have such a laptop that means you have the intel HD graphics chip that comes integrated in modern Intel CPUs and a dedicated NVidia video chip. NVidia calls this Optimus Technology. This is currently not supported on Linux from NVidia, but you may have luck to get it running with Bumblebee.

Zssfssz 04-09-2012 10:37 AM

What do graphichs cards have to do with this? I dont want to run a GUI/xorg!

TobiSGD 04-09-2012 10:58 AM

The characters on your screen are nonetheless displayed by your graphics card, and newer versions of the driver for your Intel (i915 driver)and your NVidia (nouveau driver) are using kernel mode setting. That means, as soon those drivers are loaded they try to set a display resolution that is appropriate for your display. That is in some configurations not working correctly, especially when you have an older kernel, like in Debian 6, and newer hardware, like the Intel HD graphics. If you don't need a GUI then just add the nomodeset option permanently to your kernel line for Debian. I am not a Grub user, so I don't know how to do that, but this link may be helps: http://www.dedoimedo.com/computers/grub-2.html


All times are GMT -5. The time now is 05:12 AM.