LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-08-2012, 04:59 PM   #1
Zssfssz
Member
 
Registered: Sep 2011
Location: Las Vegas!
Distribution: Ubuntu n' Flavors, ReactOS, MINIX3, FreeDOS, Arch
Posts: 339

Rep: Reputation: Disabled
Debian Can't Seem To Switch Back To Text Mode!


I just finished installing Debian 6.0.4 amd64 and ran update-grub in Ubuntu, found Debian fine. But in grub when I enter Debian, it just goes to that shade of purple Ubuntu has by default, and I know it's there because I can type:
root (enter)
muffins (enter)
shutdown -h now (enter)

And in 30 seconds the computer turns off.
How would I fix this, without turning the gui on?
 
Old 04-08-2012, 05:06 PM   #2
descendant_command
Member
 
Registered: Mar 2012
Posts: 755

Rep: Reputation: 159Reputation: 159
edit the grub line with root=<something> to change kernelmodesetting for your video device, maybe?
 
Old 04-08-2012, 10:23 PM   #3
Zssfssz
Member
 
Registered: Sep 2011
Location: Las Vegas!
Distribution: Ubuntu n' Flavors, ReactOS, MINIX3, FreeDOS, Arch
Posts: 339

Original Poster
Rep: Reputation: Disabled
Can you explain?
Me + GRUB = Not Good
 
Old 04-08-2012, 10:45 PM   #4
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,673

Rep: Reputation: 122Reputation: 122
Code:
man grub
 
Old 04-09-2012, 06:56 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,424
Blog Entries: 2

Rep: Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996
To disable the kernel mode setting press E in your bootloader's menu to edit the configuration of the current selected OS. Then add nomodeset to the kernel command line (the one beginning with linux /boot/vmlinuz.... and press Ctrl+x to boot the system. This is a one time solution. to give you better help we need to know which video hardware your machine is using.
 
Old 04-09-2012, 08:57 AM   #6
Zssfssz
Member
 
Registered: Sep 2011
Location: Las Vegas!
Distribution: Ubuntu n' Flavors, ReactOS, MINIX3, FreeDOS, Arch
Posts: 339

Original Poster
Rep: Reputation: Disabled
Ohh umm, I think it has two cards one nVida and one Intel.
In a recent trip to San fransisco I found out "Intel" means INTergrated ELectronics!
 
Old 04-09-2012, 09:45 AM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,424
Blog Entries: 2

Rep: Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996
Intel is the manufacturer of your CPU. If you have such a laptop that means you have the intel HD graphics chip that comes integrated in modern Intel CPUs and a dedicated NVidia video chip. NVidia calls this Optimus Technology. This is currently not supported on Linux from NVidia, but you may have luck to get it running with Bumblebee.
 
Old 04-09-2012, 10:37 AM   #8
Zssfssz
Member
 
Registered: Sep 2011
Location: Las Vegas!
Distribution: Ubuntu n' Flavors, ReactOS, MINIX3, FreeDOS, Arch
Posts: 339

Original Poster
Rep: Reputation: Disabled
What do graphichs cards have to do with this? I dont want to run a GUI/xorg!
 
Old 04-09-2012, 10:58 AM   #9
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,424
Blog Entries: 2

Rep: Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996Reputation: 3996
The characters on your screen are nonetheless displayed by your graphics card, and newer versions of the driver for your Intel (i915 driver)and your NVidia (nouveau driver) are using kernel mode setting. That means, as soon those drivers are loaded they try to set a display resolution that is appropriate for your display. That is in some configurations not working correctly, especially when you have an older kernel, like in Debian 6, and newer hardware, like the Intel HD graphics. If you don't need a GUI then just add the nomodeset option permanently to your kernel line for Debian. I am not a Grub user, so I don't know how to do that, but this link may be helps: http://www.dedoimedo.com/computers/grub-2.html
 
  


Reply

Tags
boot, debian


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to switch from text mode to graphical mode in solaris 10 linuxjamil Solaris / OpenSolaris 3 07-19-2009 03:55 PM
Need to switch back to high graphics mode ddoublee Linux - Desktop 3 09-21-2007 02:19 AM
Text is garbled when I switch from X back to text mode Dark Jirachi Linux - Laptop and Netbook 18 09-20-2007 09:41 PM
flickering of screen while returning back to GUI mode from Text mode using Ctl+Alt+F7 varun_shrivastava Linux - Newbie 1 03-30-2007 10:12 AM
How to switch back to graphical mode in SUSE 9.2? snjbrian Suse/Novell 2 11-12-2004 11:47 AM


All times are GMT -5. The time now is 08:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration