LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-28-2004, 08:25 PM   #1
ColBond
Member
 
Registered: Oct 2004
Location: Lawrence, KS
Distribution: Fedora/Gentoo/Debian
Posts: 32

Rep: Reputation: 15
Debian Bootsplash


I've been playing with this for a few days now with no luck, hoping somebody here can help.
I think I've done everything necessary to get it to work, but for some reason it won't show up. I used "make xconfig" to make sure the proper modules were installed(framebuffer, vesa vga, bootsplash, initrd, etc) and got that kernel working. I used apt-get to install bootsplash, ran the config, and added the flags it told me to menu.lst. I'm at work and not on that computer at the moment, will post that section of menu.lst when I get home.
It boots in the proper resolution(1024x768) and shows a black screen where the bootsplash would normally show up, makes me think it's not finding the image properly, but I can't tell.
 
Old 10-28-2004, 10:01 PM   #2
ColBond
Member
 
Registered: Oct 2004
Location: Lawrence, KS
Distribution: Fedora/Gentoo/Debian
Posts: 32

Original Poster
Rep: Reputation: 15
Ok, here's the chunk from menu.lst

#title Debian Linux, Kernel 2.6.8-1-386 w/bootsplash
#root (hd0,0)
#kernel /boot/vmlinuz-2.6.8-1-386 root=/dev/hda1 ro vga=791
#initrd /boot/initrd.splash append="splash=verbose"
#savedefault
#boot

I have it commented out because it wasn't working properly and I didn't want to boot it by mistake until I got it working.
The kernel and root are the same as I've booted to right now, so I know they work. It's booting in 1024x768 just fine, the initrd.splash file exists, but it doesn't look like it's loading.
I can see in the boot process that it's starting a ramdisk, but can't tell what it does with it.
 
Old 10-28-2004, 11:38 PM   #3
haimeltjnfg
Member
 
Registered: May 2004
Distribution: debian
Posts: 235

Rep: Reputation: 30
did you do the splash -s -f /etc/bootplash/whatever >> /boot/initrd.splash?

get rid of append="splash=verbose"

and show what dmesg says.
 
Old 10-29-2004, 01:31 AM   #4
ColBond
Member
 
Registered: Oct 2004
Location: Lawrence, KS
Distribution: Fedora/Gentoo/Debian
Posts: 32

Original Poster
Rep: Reputation: 15
ok, ran that, tried booting with this and as soon as it left grub it went to a black screen and did not boot. never saw an error message of any kind.


title Debian Linux, Kernel 2.6.8-1-386 w/bootsplash
root (hd0,0)
kernel /boot/vmlinuz-2.6.8-1-386 root=/dev/hda1 ro vga=791
initrd /boot/initrd.splash
savedefault
boot

last chunk of dmesg:

[fglrx] total Inv = 0
[fglrx] total TIM = 0
[fglrx] total FB = 0
[fglrx] total AGP = 32768
mtrr: 0xd8000000,0x400000 overlaps existing 0xd8000000,0x200000
eth0: no IPv6 routers present
eth1: no IPv6 routers present

(since I couldn't see what it was doing, i left it for about 5 minutes, restarted because it hadn't booted up all the way)

Last edited by ColBond; 10-29-2004 at 01:33 AM.
 
Old 10-29-2004, 09:55 AM   #5
Zambezi
LQ Newbie
 
Registered: Oct 2004
Location: Hedel, Netherlands
Distribution: Debian Sid
Posts: 9

Rep: Reputation: 0
Hmmm... did you put the following in your /etc/apt/sources.list and do an apt-get update; apt-cache search bootsplash?

deb http://www.bootsplash.de/files/debian unstable main
deb-src http://www.bootsplash.de/files/debian unstable main

next, you can apt-get install whatever bootsplash themes you like. After that you must supply a theme to your initrd image. The easiest way to accomplish this is by 'dpkg-reconfigure bootsplash' from the root prompt.

good luck

Last edited by Zambezi; 10-29-2004 at 09:57 AM.
 
Old 10-29-2004, 10:47 AM   #6
ColBond
Member
 
Registered: Oct 2004
Location: Lawrence, KS
Distribution: Fedora/Gentoo/Debian
Posts: 32

Original Poster
Rep: Reputation: 15
I did that, that's how it built the initrd.splash image in /boot. I don't know a lot about it, but it looks like it just can't find or can't load the image when it boots, but I'm not sure how to tell.
 
Old 10-29-2004, 03:43 PM   #7
Zambezi
LQ Newbie
 
Registered: Oct 2004
Location: Hedel, Netherlands
Distribution: Debian Sid
Posts: 9

Rep: Reputation: 0
OK, perhaps you should review a couple of things from scratch

Did you build kernel support for:
Under --> File Systems --> Misc File Systems
Compressed Rom File System Support

Under --> Device Drivers --> Block Devices
Ram Disk Support
Initial RAM Disk (initrd)

Under --> Graphics Support --> Support For Frame Buffer devices
VGA 16 Color Graphics Suport
Vesa VGA Graphics support

Also check any box that matches your video card if there is one.

Under --> Graphics Support --> Console Display Driver Support
Framebuffer Console Support

Under --> Graphics Support --> Bootsplash Configuration
Bootsplash Screen

Note: all the above should NOT be build as modules

Build and install the kernel:
make-kpkg clean
make-kpkg --initrd --append-to-version=.20041029 --revision Custom.1 kernel_image
dpkg -i kernel-image-2.6.8.1.20041029_Custom.1_i386.deb

edit your menu.lst:
title Debian GNU/Linux, kernel 2.6.8.1.20041029
root (hd0,0)
kernel /vmlinuz-2.6.8.1.20041029 root=/dev/hda1 ro vga=794 splash=silent #(or verbose, which is the default)
initrd /initrd.img-2.6.8.1.20041029
savedefault
boot

then install the bootsplash utilities and themes:
apt-get install bootsplash sysv-rc-bootsplash

Add a theme to the new initrd image:
dpkg-reconfigure bootsplash

reboot to the new kernel and have fun

some usefull sources:
http://www.desktop-linux.net/bootsplash.htm
http://www.desktop-linux.net/debkernel.htm

Last edited by Zambezi; 10-29-2004 at 04:15 PM.
 
Old 10-31-2004, 05:09 PM   #8
ColBond
Member
 
Registered: Oct 2004
Location: Lawrence, KS
Distribution: Fedora/Gentoo/Debian
Posts: 32

Original Poster
Rep: Reputation: 15
Did that exactly. As soon as it leaves grub, the screen blacks out and a couple seconds later my monitor gives me a "signal over range" error. Kernel still boots if I leave it long enough, but it won't show the splash.
 
Old 11-01-2004, 12:36 AM   #9
haimeltjnfg
Member
 
Registered: May 2004
Distribution: debian
Posts: 235

Rep: Reputation: 30
try a different resolution. i don't think bootsplash likes 32 bit color. try a diff (smaller) res and 16 bit.
 
Old 11-01-2004, 01:32 PM   #10
Zambezi
LQ Newbie
 
Registered: Oct 2004
Location: Hedel, Netherlands
Distribution: Debian Sid
Posts: 9

Rep: Reputation: 0
In XF86Config-4, be sure to comment off the "Display" subsections in the section "Screen" that you are not going to use anyway. So, if you have a 17" or 19" monitor, you would probably only want to use the modes "1280x1024" and/or "1024x768". You should also check very carefully the horizontal and vertical refresh rates in the "Monitor" section to match exactly the specifications of your monitor's manual.
The "Signal over range" error indicates that a screen mode is used which crashes the X window system.

If both your monitor and the graphic card are capable to support 24 bit colordepth at the resolutions that you want to use, then in my opinion this should be no problem as far as bootsplash is concerned.

earlier i mentioned "vga=794" at the kernel line in menu.lst, which is only correct if the theme you use is for 1280x1024 resolution, but most themes in the bootsplash package are at 1024x768 so in that case the kernel line should read "vga=791".

Last edited by Zambezi; 11-01-2004 at 01:36 PM.
 
Old 11-01-2004, 05:34 PM   #11
ColBond
Member
 
Registered: Oct 2004
Location: Lawrence, KS
Distribution: Fedora/Gentoo/Debian
Posts: 32

Original Poster
Rep: Reputation: 15
Ok, I'll try that, though now I have a new issue. When I boot, grub starts to load and gives me a "Grub Error 17" and won't load. I can boot from SCSI and get to my windows drive, but I can't find a way to make it run grub now.
 
Old 11-02-2004, 07:50 PM   #12
haimeltjnfg
Member
 
Registered: May 2004
Distribution: debian
Posts: 235

Rep: Reputation: 30
try reinstalling grub into the mbr partition.
 
Old 11-03-2004, 03:35 AM   #13
powadha
Member
 
Registered: Nov 2003
Distribution: Debian SID
Posts: 649

Rep: Reputation: 31
I installed the bootloader yesterday and it works fine. I never cared much for it but I needed something to do. I used to compile without --intird (filesystems compiled into the kernel) but I couldn't get the seperate initrd.splash to work. I recompiled the kernel with initrd and appended the splash to it using dpkg-reconfigure bootsplash only thing to add to grub was vga= option. Well, all works fine just one thing doesn't seem to work.
Some splashes come in different resolutions. dpkg-reconfigure bootsplash, but only 1024 seems to work. Adding vgi=791 seems standard. changing it to 794 and only choosing a 1280 splash during install doesn't seem to work. Any ideas on how to fix this? Is an higher refresh rate during boot possible? Like @85 and how to enable this? I saw some options like that online but that was about another distro....

Last edited by powadha; 11-03-2004 at 03:50 AM.
 
Old 11-03-2004, 08:23 AM   #14
Nightfrost
Member
 
Registered: Jun 2004
Location: Sweden
Distribution: ArchLinux
Posts: 201

Rep: Reputation: 30
There are so many bootsplash threads so I thought I'd just post my problem here instead of starting a new thread (I hope that's alright, after all my problem is related).

Well; I can't get the bootsplash to work. I have compiled the kernel according to instructions. I have vesafb-tng compiled in the kernel and set the default to 1024x768@75. I have an ati-card but had strange problems when added the kernels ati-support so that is removed now.

First problem is, I can't pass vga=791 or vga=0x317 or anything else I've tried for that matter, in grub. I'll just get a message that it wasn't recognized and I get to choose to run with the default (which I have compiled as mentioned above). I don't get any error-messages or anything strange. It just doesn't work. I get a normal console boot. Any ideas?

(btw, I've compiled the kernel with the nitro-2 patch)

Thansk
 
Old 11-03-2004, 01:32 PM   #15
Zambezi
LQ Newbie
 
Registered: Oct 2004
Location: Hedel, Netherlands
Distribution: Debian Sid
Posts: 9

Rep: Reputation: 0
Quote:
Originally posted by powadha
Some splashes come in different resolutions. dpkg-reconfigure bootsplash, but only 1024 seems to work. Adding vgi=791 seems standard. changing it to 794 and only choosing a 1280 splash during install doesn't seem to work.
Look in /etc/bootsplash/themes/current/config for the supported resolution(s) for your current bootsplash theme... and yes, most themes come only with one bootsplash-1024x768.cfg file. You could check out http://debblue.debian.net/ though for a nice debian theme with support for several resolutions. To switch the resolution, you not only change the "vga=xxx" in menu.lst, you also need to upload the appropriate bootsplash-????x????.cfg file to your initrd image, for instance:
# splash -s -f /etc/bootsplash/themes/current/config/bootsplash-1280x1024.cfg > /boot/initrd.img-2.6.7

And if french doesn't scare you, you may find some good tips here: http://www.trustonme.net/didactels/286.html
 
  


Reply

Tags
boot loader, bootsplash, debian, kernel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems removing 'bootsplash' package in Debian moistTowelette Linux - Software 8 07-26-2005 09:42 AM
Bootsplash and Debian. A paradox? raid517 Debian 2 05-14-2005 08:15 AM
bootsplash himm Suse/Novell 8 12-07-2004 03:43 AM
bootsplash-3.1.4-2.6.6-debian.diff Bonch Debian 0 11-07-2004 04:25 PM
Bootsplash ski3r Debian 4 10-18-2004 04:48 PM


All times are GMT -5. The time now is 05:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration