LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-17-2008, 10:42 PM   #1
rubber
LQ Newbie
 
Registered: Mar 2006
Location: Braganša - Portugal
Distribution: Suse 10.0 64bit
Posts: 12

Rep: Reputation: 0
debian and black screen on X


Hi!

I've installed the latest debian distribution and when it starts it gives me blank screen. But is working because I do Ctrl+Alt+F2 and it turns to command-line..

I had the same problem with knoppix but in that case I did xmodule=svga in startup and it was working..but in debian I don't have a clue in how to solve this..

I have a Targa 826w mt-34 notebook.
Amd64 Turion processor
graphics card: ATI Radeon X700 128Mb pci-express.

thanks!
reguards,
Rubber. :-}
 
Old 01-18-2008, 07:54 AM   #2
ArchAngeL13
Member
 
Registered: Jun 2006
Location: Groningen
Distribution: SUSE 11 and 10 Enterprise, Fedora 9, Mepis 7.0, Sabayon
Posts: 46

Rep: Reputation: 15
Hi Rubber,

I think I had the same problem as you installing the latest Debian. Looking at your specs you have the same graphics card as I have. I think that is the problem.

When you start up the screens switches off? Have you tried `startx` in commandline? I could also use Ctrl+Alt+F6 or Ctrl+Alt+backspace. Still, in my case `X`-crashed and did not work. Try and look at your `xorg.0.log` file if something is wrong. If it`s not a xorg.conf error it might be a misconfiguration that doesn`t work on your machine (and mine .

I installed something else at the moment that works well with my specs (Sabayon)

hope you have better luck installing Debian!

Arch.
 
Old 01-18-2008, 11:41 AM   #3
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
you could edit the /etc/X11/xorg.conf file directly after escaping X using Ctrl+Alt+F2
Code:
Section "Device"
        Identifier      "ATI Technologies Inc RC410 [Radeon Xpress 200]"
        Driver          "ati"
        BusID           "PCI:1:5:0"
EndSection
Usable options for the driver name are:
vesa - (Very basic driver should work with almost any card)
ati
radeon
fglrx
- (only if you install the proprietary ATI drivers)

you could try different drivers and see if one of them will work.
/etc/init.d/gdm restart to restart X and test the different drivers.


An easy way to Check the X log for errors is..
cat /var/log/Xorg.0.log | grep EE

and warning messages - (usually can be ignored if everything is working)
cat /var/log/Xorg.0.log | grep WW



The command lspci should list your graphics card hardware so you can see if Linux is detecting it properly.

Last edited by farslayer; 01-18-2008 at 11:43 AM.
 
Old 01-24-2008, 10:45 PM   #4
sirmonkey
Member
 
Registered: Dec 2004
Posts: 31

Rep: Reputation: 15
i have the same problem. only once the system move to X its hosed.
if i boot to single use mode its ok, if i try to start X it hoses agian

from what i've been reading, lots of people have this problem and the only 3 things that are the same are
nice graphics card ( ati and nvidia )
the amd64 kernel
starting Xorg

there are no useful errors that i saw in my X log, i will recheck. but more importantly a fix needs to be found and distrubited via debian update becasue this seems to affect alot of people ( just google/yahoo debian blank screen and read when it happens )
 
Old 01-25-2008, 12:17 AM   #5
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 59
Quote:
more importantly a fix needs to be found and distributed via debian update becasue this seems to affect alot of people
No fix needs to be circulated. Debian works fine, but you do need to learn to configure it. Depending on how you organized the installation, you may need to install Xorg, gdm/gnome, kdm/kde, or some combination of them. You may also have to configure xorg.conf either manually, or using dpkg-reconfigure xserver-xorg.

It really is not as complicated as it sounds, but this is Debian. It expects you to take care of yourself a bit rather than hold your hand.
 
Old 01-25-2008, 01:46 AM   #6
sirmonkey
Member
 
Registered: Dec 2004
Posts: 31

Rep: Reputation: 15
every conf is fine, the problem only comes up when i boot the stock debian amd64 bit kernel. i'm in the process of compiling a bland 2.6.18 now. so see if it is a debian patch.
also i've tryed:
vesa
nv
and the most recent drivers from nvidia both 64 and 32 bit
under the 64 bit kernel

the only errors are warnings under the vesa mod. about reslutions being to not supported. and the nv mod. dosen't detect the card (8800 gts g80 core'ed)

changing window mangers has no affect. even starting a raw X session under single user mode fails.
what else?
i've removed and added bus id(s) and tryed a few nvidia options in the xorg.conf

any other ideas?
 
Old 01-26-2008, 08:18 AM   #7
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Rep: Reputation: 30
Rubber,

When you loaded, and I am assuming Lenny here, how did you configure X? If I recall correctly, there should be three options: Basic, Medium and Advanced.

I have run into the same problem before, try running dpkg -reconfigure with the Advanced option enabled. You will need to know you horizontal and vertical range for your monitor, graphic card memory.... This should fix it.

Eric.
 
Old 01-26-2008, 08:46 AM   #8
wraithe
Member
 
Registered: Feb 2006
Location: australia
Distribution: Linux... :-)
Posts: 216
Blog Entries: 1

Rep: Reputation: 30
both rubber and sirmonkey,

while repairing an nvidia laptop i came across the same references of problems for both ati and nvidia, with ati it recommends installing the latest ati drivers from there site..there doc will help there as will nividias..

nvidia drivers from there website, its pretty much a manual install, and do remember that you do that in init3 then startx once finished, not hard but doable
 
Old 01-26-2008, 08:57 AM   #9
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
init 3 in debian is the same as init 2,4 and 5. "/etc/init.d/gdm stop" (or kdm) kills X for display driver installation.
"/etc/init.d/gdm start" gets it going after installation.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 11:52 AM
Booting CentOS 5, logo screen appears, stuff initializes, then screen goes black ctman Linux - Newbie 6 09-22-2007 08:36 AM
Get a black screen when logoff in Debian Etch..same problem with Ctrl+alt+f1 rzs Debian 4 09-05-2007 08:48 PM
Help! Black screen instead of login screen! Intel integrated graphics coolblue Suse/Novell 10 05-03-2007 05:30 PM
Startx results in a black screen with VGA and screen errors kwosource Linux - Newbie 4 03-11-2005 02:58 PM


All times are GMT -5. The time now is 09:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration