LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-23-2006, 06:37 PM   #1
hungrigerhaifisch
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 91

Rep: Reputation: 15
Question Debian-amd64 : Xorg & Ati's fglrx


Hi!

I am trying to install ati's fglrx-driver on my fresh debian-amd64 box.
Sofar I have only installed a very basic X-server (startx works!) but before I move on I want to install ati's driver.

I have been following the instructions on:

http://wiki.cchtml.com/index.php/Deb...allation_Guide

and have succsesfully built the *.deb packages. They fail to install however...(dpkg error)

The reason for this, is that I am apparently running the wrong version of Xorg.
Version 7.0.99 is required, I am running 7.0.22 (thats from etch)

Ati's driver version is: 8.25.18

My question now is, am I doing something completely wrong, or will I have to wait for the required version of Xorg, or can I find the build someother place (I checked with sid, no luck...)

Thanks for any help!

Last edited by hungrigerhaifisch; 06-23-2006 at 06:39 PM.
 
Old 06-23-2006, 06:54 PM   #2
Daws
Member
 
Registered: May 2006
Location: UK
Distribution: Debian, Linux From Scratch
Posts: 416
Blog Entries: 1

Rep: Reputation: 30
You might try an older version of the ati drivers, preferably one that works with xorg 7.0.22.
 
Old 06-23-2006, 08:40 PM   #3
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 59
Quote:
Version 7.0.99 is required...
I'm sure there is no version 7.0.99. You may have to modify a script in the ATI package. These drivers have not worked since xorg 6.8, but I have been hearing rumblings that it's time to try again. In fact it looks like you're making pretty good progress.

Sorry I can't be of specific help, but consider me encouraging, and I'll be watching this thread to see if any real assistance is forthcoming.
 
Old 06-24-2006, 05:50 AM   #4
hungrigerhaifisch
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 91

Original Poster
Rep: Reputation: 15
yes indeed I had been makeing some progress...

I did manage to install the packages (using ubuntus Xorg) but that totally wrecked my system. I ended up with the 'fonts missing' error, tried to reinstall xfonts-base, which screwed it up complety. That was when I rebuilt my debian system, which has led me to my current problem.

I have tried to find older versions of ati's driver, but without any luck. Their website, like their generall support for linux(especially X86_64) is appaling well...

Does anyone know where I can download older versions of the driver? (I did ask google but it said no to me...)

If that doesn't work, I'll try changing some scripts.
 
Old 07-08-2006, 01:29 PM   #5
hungrigerhaifisch
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 91

Original Poster
Rep: Reputation: 15
Exclamation Some Progress...

Well after fiddling around with the 'control-file' in 'fglrx-driver.deb' I have managed to install the fglrx driver. I then built the modules using module-assistant.
I can now load the 'fglrx-module', and
Code:
lsmod | grep fglrx
fglrx                 444404  0
shows that it is loaded. However, X refuses to start, claiming
Code:
...
(II) LoadModule: "fglrx"
(WW) Warning, couldn't open module fglrx
(II) UnloadModule: "fglrx"
(EE) Failed to load module "fglrx" (module does not exist, 0)
...
(EE) No drivers available.
I'm out of ideas...

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ati's latest fglrx driver fglrx_4_3_0-8.10.19-1 crashes redflo Linux - Hardware 1 03-06-2005 02:50 AM
XOrg-6.8.1 problem with ATI's fglrx-8.8.25 driver??? ginobili_20 Linux From Scratch 4 02-16-2005 01:57 PM
ATI's fglrx kernel 2.6.9 and X.org 6.8.1 electronique Slackware 20 02-01-2005 04:11 PM
Yet another issue with ati's fglrx, X and 3D emu_123 Linux - Hardware 5 01-18-2005 06:15 PM
Fedora core 2 vs. ATI's Radeon fglrx driver IgD Red Hat 0 03-14-2004 04:17 AM


All times are GMT -5. The time now is 04:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration