LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 04-28-2007, 04:22 PM   #1
dna9
Member
 
Registered: Nov 2004
Location: Colorado
Distribution: Ubuntu mostly...
Posts: 66

Rep: Reputation: 18
Debian 4 - Safe Graphics Mode


how do i enable safe graphics mode with debian 4? X locks up right after i log in. ubuntu and other distros have an option for this. i can tap "e" to edit commands before boot. isn't it

vesa 1024x768
or
vga 1024x768?

thanks in advance!

ps: i have amd64 and pci-e video card but the OS is 386.
 
Old 04-29-2007, 11:33 AM   #2
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
I'm not familiar with any sort of shortcuts like that, but you can manually edit /etc/X11/xorg.conf and replace the driver with "vesa". I've found this necessary a couple times when either the "nv" or "mga" driver the Debian 4.0 installer installed didn't work properly.

Maybe there are some shortcuts or tricks to do it the way you say, but I'm only familiar with the editing xorg.conf method (which works for any Linux distribution).
 
Old 04-29-2007, 12:58 PM   #3
dna9
Member
 
Registered: Nov 2004
Location: Colorado
Distribution: Ubuntu mostly...
Posts: 66

Original Poster
Rep: Reputation: 18
thanks isaac, but...

how can i edit the xorg.conf if it won't boot up? is it command line before booting, etc...

thanks for the info
 
Old 04-29-2007, 02:47 PM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
When the login prompt comes up, login as root, and at the # prompt, type ... dpkg-reconfigure xserver-xorg

In the course of that conversation, select the vesa driver. That'll probably get you a minimal Xsystem working, but it's not "safe mode." Safe mode is a Windows concept. I suppose Ubuntu or other Windows wannabee distros use the term to help newbies feel comfortable.

You are now dealing with Debian. Are you sure you're ready?
 
Old 04-29-2007, 02:54 PM   #5
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Boot up in single user mode. It should be the second option when the GRUB bootloader starts up. This gives you the option to log in as root before X attempts to start (as well as many other things). After you edit xorg.conf with a command like "pico /etc/X11/xorg.conf", then use the command "exit" to exit and the boot sequence will continue as normal.
 
Old 04-29-2007, 03:40 PM   #6
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Quote:
how do i enable safe graphics mode with debian 4? X locks up right after i log in.
You should be able to hit CTL-ALT-F1 to get to a console. Login as root and fix any problems. If you're running gdm, then after you change xorg.conf, run "/etc/init.d/gdm restart" to restart X.
 
Old 04-29-2007, 04:06 PM   #7
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
That doesn't always work. When I got the blackscreen errors, the graphics card was somehow confused so that ctrl-alt-f1/2/3/4/5/6 had no effect. I could still remotely ssh in and such.
 
Old 05-05-2007, 11:56 AM   #8
dna9
Member
 
Registered: Nov 2004
Location: Colorado
Distribution: Ubuntu mostly...
Posts: 66

Original Poster
Rep: Reputation: 18
that did it!

thanks for all your help, MIKE...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Safe mode... windows XP.. but.. metallicafan_316 General 8 08-26-2005 02:08 AM
Booting in text mode versus graphics mode LChalupa Linux - Newbie 3 01-15-2005 08:53 PM
safe mode elmorgo Linux - Software 1 08-30-2004 08:04 AM
safe mode dazzler Linux - Newbie 4 07-27-2004 02:56 PM
safe mode firedragon Linux - Newbie 2 04-03-2004 05:30 PM


All times are GMT -5. The time now is 04:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration