LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-24-2005, 10:43 AM   #1
abesirovic1
LQ Newbie
 
Registered: Sep 2005
Location: Germany
Distribution: Slackware
Posts: 28
Blog Entries: 1

Rep: Reputation: 6
Post Debian 3.1 (Sarge) + AMD64 + nVidia GeForce 6600GT


Hello, my problem is as follows:

I have an AMD64 Athlon 3000+ with a nVidia GeForce 6600 GT Graphics Card. I've recently installed Debian 3.1 "Sarge" Linux , and upon my first boot the X System won't start. So I opened my $"#!!"$%! Windows and googled/revisited forums. I found out various ways for X to work: NVidia driver package won't do you good on Debian, then I tried to change the "nv" to "vesa" or "vga", didn't work. Eventually I stumbled across the solution - the howto on nVidia driver installation. All is beautifull, but I cannot find the repositories for apt that have nvidia-glx and nvidia-glx-dev and the depending nvidia-kernel thingy.

Does anyone have a repository that has been recently checked and that surely works? Or better - is there an official repository which has this thingy?

Thanx.
 
Old 09-24-2005, 11:09 AM   #2
samael26
Member
 
Registered: Oct 2004
Location: France, Provence
Distribution: Debian
Posts: 848

Rep: Reputation: 30
Hi,
nvidia-glx is in the repositories for etch (debian testing). Add the sources for it (depending on your
country), in your /etc/apt/sources.list, and you'll get your drivers.

This is what my file looks like :

deb ftp://ftp2.fr.debian.org/debian/ testing main contrib non-free
deb-src ftp://ftp2.fr.debian.org/debian/ testing main

Hopes it helps.
Cheers
 
Old 09-24-2005, 12:49 PM   #3
abesirovic1
LQ Newbie
 
Registered: Sep 2005
Location: Germany
Distribution: Slackware
Posts: 28
Blog Entries: 1

Original Poster
Rep: Reputation: 6
Okey, I have done some progress...
Tried to install the nvidia-kernel but I got the
"rivafb" message. How to solve this? I've tried
modprobe -r rivafb but the module isn't found as
the modprobe nvidia does nothing...

Some say that you need to recompile the kernel
and exclude the rivafb module, but how do I do
this? Nobody didn't write a guide they just all
said recompile!

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GeForce 6600GT + Suse 10 + Dual CRT (newbie) aqwabawks Suse/Novell 2 11-04-2005 12:18 PM
Random restarts with 2005 LE and Geforce 6600gt PCI-Express TravisOSF Mandriva 2 05-04-2005 08:17 PM
GeForce 6600GT & Suse 9.2 x86_64? ExoZagNoid Suse/Novell 4 04-07-2005 08:11 PM
Tired of Grub! (Debian Sarge AMD64) ssobeht Debian 4 03-31-2005 07:44 AM
GeForce 6600GT AGP giosue_c Linux - Hardware 3 12-04-2004 10:52 AM


All times are GMT -5. The time now is 02:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration