LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-10-2006, 06:25 AM   #1
coyopil
Member
 
Registered: Oct 2005
Location: Bergen, Norway
Distribution: 2005: Libranet 2.8.1 expanded with Debian Sarge 2012: Kanotix 64 bit, antiX 8.5, Crunchbang
Posts: 139

Rep: Reputation: 14
custom kernel does not boot


I compiled kernel 2.6.15 without initrd, and I get a kernel panic:

kernel panic - not syncing: VFS: unable to mount root fs on unknown-block (3,5)

I have only ext2 partitions so i don't see the reason why this happens.
Any suggestions?
 
Old 01-10-2006, 06:46 AM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
It's not which file system you choose that determines whether you need an initial RAM disk, it's whether the file system support is compiled in the kernel or as a module. This sounds like you don't have initrd set up and you have your kernel set up with ext2 as a module.

The way around this is to either keep your current kernel and re-build your initrd, or you can recompile your kernel with ext2 in the kernel and not as a module.
 
Old 01-10-2006, 06:59 AM   #3
coyopil
Member
 
Registered: Oct 2005
Location: Bergen, Norway
Distribution: 2005: Libranet 2.8.1 expanded with Debian Sarge 2012: Kanotix 64 bit, antiX 8.5, Crunchbang
Posts: 139

Original Poster
Rep: Reputation: 14
You're right. I thought i had it compiled in but missed the dot and looked at the v on extended attributes below it in qtconfig
 
Old 01-10-2006, 01:46 PM   #4
coyopil
Member
 
Registered: Oct 2005
Location: Bergen, Norway
Distribution: 2005: Libranet 2.8.1 expanded with Debian Sarge 2012: Kanotix 64 bit, antiX 8.5, Crunchbang
Posts: 139

Original Poster
Rep: Reputation: 14
Now I have ext2 in the kernel and I get the same kernel panic error at boot.
Anybody understand any of this? I have only ext2 partitions...
 
Old 01-10-2006, 01:51 PM   #5
Aurin
LQ Newbie
 
Registered: Dec 2005
Distribution: Slackware
Posts: 16

Rep: Reputation: 0
Are you using a SATA drive?
 
Old 01-10-2006, 04:41 PM   #6
coyopil
Member
 
Registered: Oct 2005
Location: Bergen, Norway
Distribution: 2005: Libranet 2.8.1 expanded with Debian Sarge 2012: Kanotix 64 bit, antiX 8.5, Crunchbang
Posts: 139

Original Poster
Rep: Reputation: 14
No, an ordinary IDE 40 gb drive. 1 HD, 2 cdroms (DVDreader and CDburner)
 
Old 01-11-2006, 03:57 AM   #7
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Maybe you forgot something with IDE?
Have a look at
make menuconfig
an search (/) for
[^a-z]ide

May help you, I have this:

Code:
BLK_DEV_IDE = y
BLK_DEV_IDEPCI = y
BLK_DEV_IDEDMA_PCI = y
BLK_DEV_IDEDISK = y
BLK_DEV_IDECD = y
 
Old 01-11-2006, 03:15 PM   #8
coyopil
Member
 
Registered: Oct 2005
Location: Bergen, Norway
Distribution: 2005: Libranet 2.8.1 expanded with Debian Sarge 2012: Kanotix 64 bit, antiX 8.5, Crunchbang
Posts: 139

Original Poster
Rep: Reputation: 14
hm, it wasn't in the kernel..

Incredible, this was the config from kernel.org
--how could they not include that?

no more questions about this until I've scrutinized the config file.

Come to think of it i have everything working with 2.4.27...
 
Old 01-11-2006, 04:46 PM   #9
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
If you still have it, copy your old .config file into the source directory for your new kernel after you've run `make mrproper` and then run `make oldconfig`. It will use your old settings and then prompt you for the new settings specific to the new kernel.
 
Old 01-11-2006, 05:24 PM   #10
coyopil
Member
 
Registered: Oct 2005
Location: Bergen, Norway
Distribution: 2005: Libranet 2.8.1 expanded with Debian Sarge 2012: Kanotix 64 bit, antiX 8.5, Crunchbang
Posts: 139

Original Poster
Rep: Reputation: 14
yes, thanks, I could do that.
I'm using the debian 2.4.27-k7 kernel now, thought I would drop the initrd.
 
Old 01-12-2006, 01:01 PM   #11
coyopil
Member
 
Registered: Oct 2005
Location: Bergen, Norway
Distribution: 2005: Libranet 2.8.1 expanded with Debian Sarge 2012: Kanotix 64 bit, antiX 8.5, Crunchbang
Posts: 139

Original Poster
Rep: Reputation: 14
I got 2.6.15 running but went back to 2.4.27 as i still cannot get my tv card working with 2.6.
Thought maybe it would be better with in-kernel support for mppe for instance but newer is just not always better.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot process stops after custom kernel build FuzzyDuc Debian 3 11-28-2004 06:47 AM
Installing MDK 9.1 with custom BOOT kernel n03lm Mandriva 1 09-04-2003 09:07 PM
Custom Kernel Won't Boot!?!?1 martinman Linux - General 1 07-12-2003 01:10 AM
Custom kernel on RedHat9 wont boot zoon64 Linux - Software 5 06-03-2003 10:42 AM
Making custom kernel..but drivers and modules wont load on boot skoal Linux - General 10 12-06-2001 06:59 PM


All times are GMT -5. The time now is 11:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration