LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-18-2003, 07:37 AM   #1
robbow52
Member
 
Registered: Oct 2003
Location: Kentucky, USA
Distribution: Debian "SID"
Posts: 110

Rep: Reputation: 15
Unhappy CUPS problem! "localhost:631, connection refused"!!!


I'm a newbie with Debian (a couple of weeks now) and I'm having a terrible time setting up CUPS printing. I'm trying to print to a printer on a Windows pc on my home network. I've installed and configured SAMBA and I've installed CUPS. I've checked settings everywhere that I can find...

My /etc/hosts file:

127.0.0.1 debian localhost


# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)


::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
debian:/etc#

A section from my /etc/network/interfaces file:

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet DHCP

A section from my /etc/cups/cupsd.conf:

#Port 80
#Port 443
Port 631
Listen 127.0.0.1:631

<Location />
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
</Location>

And finally, the listing from ifconfig:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:3924 Metric:1
RX packets:2697 errors:0 dropped:0 overruns:0 frame:0
TX packets:2697 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:231072 (225.6 KiB) TX bytes:231072 (225.6 KiB)

I've changed various settings in various files, restarted CUPS and still when I try to connect with localhost:631 to administer CUPS (using Mozilla), I receive a "connection refused" error. I'm at my wit's end!!! I "had" it working a few days ago (I could get to the html administration utility, I couldn't get the printer working!), but gave up in frustration! Since then, I've "changed" a number of things (I'm running Woody 3.0r1) and upgraded to Gnome2.2 and xfree86 1.4. I don't "think" this had an effect on things but...

Does anyone have an idea of where I might look?

Thanks in advance for your help!
 
Old 10-20-2003, 04:13 PM   #2
snerfu
Member
 
Registered: Sep 2003
Distribution: Debian/GNU
Posts: 30

Rep: Reputation: 15
It almost sounds like cups is not running. If you run "/etc/init.d/cupsys start" does that fix it?

or

does "ps -auxw | grep cups" show a cupsd process in the background?
 
Old 10-21-2003, 06:07 PM   #3
robbow52
Member
 
Registered: Oct 2003
Location: Kentucky, USA
Distribution: Debian "SID"
Posts: 110

Original Poster
Rep: Reputation: 15
CUPS/Localhost:631 Fixed...

I have fixed my CUPS problem with the "connection refused" when trying to connect with the html CUPS configuration program (localhost:631). I had to enable "hostnamelookups" in the cupsd.conf file.

I have not fixed my printing problem yet but at least I can get to the CUPS HTML administration utility! I was able to set up and configure the printer but print jobs are "aborted"!

My printing problem may be driver related... I have to enable debugging on the CUPS error_log file to get a better idea where the process is failing...

I'm printing to a Windows PC (via SAMBA)... Yes I know I would be better going the other way but this is my "learning" pc!!!! It has been cobbled together from spare parts and does not have USB. I have $22 (US) in it and I don't want to spend an more on it!!

The error is "stopped with status 22!" and I hope to research things a bit more.

I would appreciate any thoughts!
 
Old 03-04-2009, 01:16 AM   #4
johnzoet
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
Quote:
Originally Posted by robbow52 View Post
<Location />
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
</Location>

Have you tried:
<Location />
Order Deny,Allow
Deny From All
Allow From All
</Location>
 
Old 03-04-2009, 01:24 PM   #5
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,644

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Do you bump six year old posts often?
 
Old 03-04-2009, 01:27 PM   #6
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Bah, <kicks self for not looking at date>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection refused at localhost:631 frankieboy Linux - Networking 7 07-18-2012 06:47 PM
"Connection refused by localhost..." but why? anindyanuri Linux - Networking 2 03-18-2005 11:30 AM
Connection Refused http://localhost:631/ mlsbraves Linux - General 12 11-30-2004 05:57 PM
lp filename yields "cannot open connection to localhost - Connection refused" jjge Linux - General 3 12-28-2003 11:02 PM
"connection refused" on port 993, when not coming from localhost spam4scott Linux - Networking 2 07-14-2003 06:35 AM


All times are GMT -5. The time now is 11:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration