LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-22-2005, 01:31 AM   #1
LQboy
LQ Newbie
 
Registered: Aug 2003
Posts: 12

Rep: Reputation: 0
Critical Boot Problem due to Exim


Hi everyone,

Last week I got a severe error during my system startup. My system started booting normally until it began writing down a bunch of exim scripts (I think) on my screen and locked. I am not able to login, change virtual screens or the like. I tried ctrl + Z, ctrl + X, ctrl + C but no good. Nothing got me to the login screen! Thus I am now unable to use my debian system.

I am using debian SID, no pinning, and the problem occured after I did apt-get update & apt-get upgrade & apt-get dist-upgrade. I remember that it did update some exim packages. I actually do not use exim, but the debian installer installs it by default. I use yahoo, gmail for mail.

Since I cannot login to my system, I beleive I have to repair it via knoppix, puppy linux, dam small linux or the like. But I don't know what to repair. As far as I know, the debian system needs an mailing system to at least send admin messages to users and admins. Thats why its installed by default.

I am using kernel 2.6 - k7, and I haven't installed any packages outside the official debian SID repository. Can anyone help me? I stuck with windows. What can I do to fix this problem and get my system to operate properly again?

Thank You in advance ...
 
Old 04-22-2005, 02:28 AM   #2
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
If you can mount your Debian partition from Knoppix or some other live-CD, you can rename /etc/rc2.d/S20exim4 to K20exim4 and do the same in /etc/rc3.d/ . That should prevent Exim from starting during the boot-time.

There's no real harm done if you keep exim disabled. Normal users (who use an external e-mail service like gmail) don't have much use for exim.

If you run Debian Unstable, then you should install the apt-listbugs utility that will warn you before you install any packages with known bugs.
 
Old 04-25-2005, 02:10 PM   #3
LQboy
LQ Newbie
 
Registered: Aug 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
If you can mount your Debian partition from Knoppix or some other live-CD, you can rename /etc/rc2.d/S20exim4 to K20exim4 and do the same in /etc/rc3.d/ . That should prevent Exim from starting during the boot-time.
Worked fine. Thank you very much. Is this like renaming so it won't boot. I looked at rc4.d and saw that there were a bunch of files starting with "K". Are these like backup copies.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot send mail due to exim log file permission zahoo Linux - General 3 11-03-2005 11:42 AM
Fedora Core2 boot problem due to unclean shut down shashikanth Fedora 6 04-25-2005 07:09 PM
Critical HD Problem firas981 Linux - Hardware 0 08-05-2004 02:22 AM
Critical boot problem rundjuling Linux - Software 10 05-25-2004 04:27 AM
Critical problem - can't Login! GloVe Linux - General 3 09-23-2003 06:49 PM


All times are GMT -5. The time now is 08:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration