LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-27-2006, 10:35 PM   #1
lilohatea
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian-Etch
Posts: 26

Rep: Reputation: 15
Thumbs down Couldn't open RGB_DB ' /usr/X11R6/lib/X11/rgb


Hi everyone. I am having a problem and hope that someone here can help.

My system:
Debian Sarge, 3.6.8.2-386, xfree86

What happened:

I ran a long over-due apt-get update, apt-get distro-upgrade last night. I left my box up and running like usual and didn't notice anything wierd until I came home and attempted to open Nautilus. It didn't seem to be able to find any of my files. Since it had been so long since my last re-start, I thought maybe it was just one of those things and rebooted. Upon reboot, I cannot bring up the GUI.

The error:
Message appears after a few failed attempts of bringing up the GUI:

"I cannot start the X server. It is likely that it is not set up correctly. Would you like to view the X server output to diagnose the problem?"

Couldn't open RGB_DB ' /usr/X11R6/lib/X11/rgb'
xf86OpenSerial: Cannot open device /dev/input/mice
Fatal server error: failed to initialize core devices.
Detailed X server output:

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

(II) Module ABI versions: XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6, XFree86 XInput driver: 0.4"

What I have done so far:

I have restored my backup file of XF86Config-4 but it didn't fix the problem.

Questions:
Should I uninstall my updates from last night? If so, how? Should I try to reinstall xconfig? If so, can you please tell me the package to apt-get?

Any help is greatly appreciated.

Thanks!

@lilohatea

Last edited by lilohatea; 01-28-2006 at 09:26 AM.
 
Old 01-29-2006, 11:31 AM   #2
SteveSch
Member
 
Registered: Jul 2003
Distribution: Debian
Posts: 102

Rep: Reputation: 15
Hi,

You mentioned you are running sarge but you did a dist-upgrade. Did you start out with sarge?

What is in your /etc/apt/sources.list

If you are like me, you just left the original testing that came with the install. Then when you did your upgrade you jumped to testing. Just a guess though. I did that then ended up just going from etch to sid to get k3b back. Now my sources.list says "sid".

What happens if you run (as root) apt-get -f install

Did you try running dpkg-reconfigure xserver-xfree86

Steve
 
Old 01-30-2006, 07:57 PM   #3
lilohatea
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian-Etch
Posts: 26

Original Poster
Rep: Reputation: 15
Talking

Steve,

Thanks a lot for the reply.

Quote:
If you are like me, you just left the original testing that came with the install. Then when you did your upgrade you jumped to testing. Just a guess though.
You are correct, that was exactly what I was doing.

Quote:
What is in your /etc/apt/sources.list?
All of my entries are Sid.

Quote:
What happens if you run (as root) apt-get -f install?
Preparing to replace udev 0.056-3 (using .../archives/udev_0.082-1_i386.deb) ... udev requires a kernel ?=2.6.12, upgrade aborted.
dpkg: error proecessing /var/cache/apt/archive/udev_0.082-1_i385.deb (--unpack): subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/udev_0.082-1_i386.deb
E: Sub[process /usr/bin/dpkg returned and error code (1)

That's my problem!

I installed the hotplug, the 2.6.12 kernel, and all is right in the world!

Thanks for your help, Steve!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy defa0009 Linux - General 5 03-02-2014 07:57 AM
ld not finding libraries in /usr/X11R6/lib gustavderdrache Linux - Software 2 01-16-2006 04:34 PM
/usr/bin/X11/ and /usr/X11R6/bin/ the same? linuxtesting2 Linux - Newbie 2 11-16-2004 10:57 AM
Compromised? Files "/usr/lib.hwm", "/usr/lib.pwd", "/usr/lib.pwi" Klaus Pforte Linux - Security 4 09-28-2004 11:33 PM
Installation failed: file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx-glc22-4. witchy2k1 Linux - Newbie 13 01-25-2004 05:26 AM


All times are GMT -5. The time now is 10:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration