LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-13-2005, 01:39 PM   #1
Dazed_75
Member
 
Registered: Oct 2005
Location: Arizona
Distribution: Debian, Ubuntu, Puppy, others
Posts: 36

Rep: Reputation: 16
console text modes (NOT X)


I am experimenting with setting up a router-firewall box using a minimaldebian as described on cyberdogtech.com which seems well described even though he says it is a work in progress.

My issue is that it drive me nuts to have a 24x80 console when the video adapter in the PC can do many higher text modes. I would prefer not to recompile the kernel and do not want to run X on this box. I suspect there may be an easy way to configure to use an svga mode like 60x80 or even ??x132 but the only info I can can that does not seem to require recompiling the kernel or running a GUI seems to require using LILO instead of grub to boot (Lilo will take an argument to set a video mode).

Looking for suggestions. I would prefer known solutions as I have not worked much in Linux or Unix for a long time and and am old and forgetful

------------------------------------ Background
I was a C Developer in the PC world many years ago and later managed a development group in a Unix environment but never had the time to learn Unix beyond dabbling a bit. So I am basicly a noob with enough background to make this harder than it probably is.

The distro in question is debian 3.1 r0a "Sarge" running on a 933 MHz PIII HP Vectra using the onboard video. It was installed following the directions in the link above.
 
Old 10-13-2005, 09:27 PM   #2
fsateler
Member
 
Registered: Jul 2004
Location: Santiago, Chile
Distribution: Debian Unstable
Posts: 107

Rep: Reputation: 15
try adding vga=<mode> to your kernel line in /boot/grub/menu.lst. The mode table is:
Code:
     | 640x480  800x600  1024x768 1280x1024
 ----+-------------------------------------
 256 |  0x301    0x303    0x305    0x307
 32k |  0x310    0x313    0x316    0x319
 64k |  0x311    0x314    0x317    0x31A
 16M |  0x312    0x315    0x318    0x31B
 
Old 10-14-2005, 01:16 AM   #3
Dazed_75
Member
 
Registered: Oct 2005
Location: Arizona
Distribution: Debian, Ubuntu, Puppy, others
Posts: 36

Original Poster
Rep: Reputation: 16
Thanks for the quick reply.

That did not solve the problem, but helped me get a lot closer. Once I realized the vga=xxxx needed to go in as a kernel argument I got an error during bootup telling me it (ox31B) was an invalid value and offered to give me a list of valid ones. As I had expected, the valid values are for text modes, not graphic ones. Specificly:

1 0x0F00 80x25
2 0x0F01 80x50
3 0x0F02 80x43
4 0x0F03 80x28
5 0x0F05 80x30 Note: 0x0F04 was not presented as valid
6 0x0F06 80x34
7 0x0F07 80x60

Using one of these values seems to work during part of the boot process. However, before the boot up finishes the display reverts back to 80x25. The screen flys by so fast (and there appears to be a CLS in there somewhere) that I have not been able to see what is happening when it reverts. Examining the syslog, I suspect it may be associated with a line that says:

localhost kernel: vesafb: probe of vesafb0 failed with error -6

but that is just a guess based on some reading. I have not been able to find any solid evidence or resolution.

SUMMARY: we seem to be on the right track, but still need some help as I am stuck again. Sure was nice to see a 60 line text console though!

Last edited by Dazed_75; 10-14-2005 at 01:18 AM.
 
Old 10-14-2005, 11:47 AM   #4
fsateler
Member
 
Registered: Jul 2004
Location: Santiago, Chile
Distribution: Debian Unstable
Posts: 107

Rep: Reputation: 15
Try using Shift+PageUp. That should let you scroll back a bit and hopefully see any hints.
 
Old 10-14-2005, 06:21 PM   #5
Dazed_75
Member
 
Registered: Oct 2005
Location: Arizona
Distribution: Debian, Ubuntu, Puppy, others
Posts: 36

Original Poster
Rep: Reputation: 16
Once again I thank you for the response and found a clue because of it. I had not realized I could scroll back without logging in. I do wish the buffer were bigger as I have always thought it would be useful and instructive to scroll back through the entire boot process set of messages. Anyway, I found a line that says:

"Setting up general console font ... Setting up per-VC ACM's: /dev/tty1 (iso15), /dev/tty2 (iso15), <repeats thru tty6> , done".

This looks like the culprit to me so I tried just watching the bootup several times and it looks like the reversion to 80x25 mode is about this time though I never actually saw this message except by using your scroll back tip.

I have no clue what component/script/... is causing this message or where I might go to change its defaults. Even if there is no way to do that, if I could find a way to reset the vga mode after that process or even after logging in, I would be happy.

To summarize current questions:
1) Is there any way to issue vga mode commands in a text based (no gui) console after logging in?
2) Is there any way to make the boot process issue them after doing the (Setting up general console fonts phase)?
3) Is there any way to increase the console history?

========================== EDITED: Part of answer found I think
Apparently /etc/init.d/console-screen.sh is doing the "Setting up general console ..." and it looks to get its setup info from /etc/console-tool/config. I have not yet read enough to know exactly how to change it safely but think I am on the right track so wanted to let you know before you went off researching. Would be happy to see anything you have to say though.

Last edited by Dazed_75; 10-14-2005 at 06:53 PM.
 
Old 10-17-2005, 05:17 PM   #6
Dazed_75
Member
 
Registered: Oct 2005
Location: Arizona
Distribution: Debian, Ubuntu, Puppy, others
Posts: 36

Original Poster
Rep: Reputation: 16
Just wanted folks to know I am giving up on this issue. It appears that the console screens are quite reasonably set up as virtual terminals running under some terminal emulation which probably knows nothing whatever about svga display modes except for how the virtual terminal is implemented. The English version is that the terminal definition is probably generic enough to not include numbers of lines other than 24 or 25 except when used in a GUI.

In any case, this is more trouble than it is worth at this time. Thanks for your help.
 
Old 10-19-2005, 06:20 AM   #7
lpd
Member
 
Registered: Nov 2004
Distribution: Debian Unstable
Posts: 77

Rep: Reputation: 15
The vga=0xXXX switch wont work on newer debian kernels as the vga framebuffer only uses the standard text modes (ie 80 characters width). You'd need vesafb or something like rivafb, nvidiafb, matroxfb etc.
Try booting with something like "video=vesafb:800x600".
You can prevent the console-tools from resetting the screen by disableing any screen fonts in /etc/console-tools/config and using the default screen font.
 
Old 10-20-2005, 02:03 AM   #8
Dazed_75
Member
 
Registered: Oct 2005
Location: Arizona
Distribution: Debian, Ubuntu, Puppy, others
Posts: 36

Original Poster
Rep: Reputation: 16
My goal here was simply to not run any GUI on that machine and to make there be more lines of text available on the screen and/or history for the console(s).

Actually, the vga=0xXXX on the kernel invocation in /boot/grub/menu.lst DOES work as long as the 0xXXX is for a character mode (see earlier message). If the code is for a graphic mode (or a resolution like the 800x600 you mentioned), the boot process pauses with a message that I have specified an invalid code and offers me a list of valid ones (the afforesaid text mode codes) or to scan the hardware.

The issue is that when console-tools.sh runs vesafb (X is not configured on that machine), it resets the screen to a mode with only 24 or so lines which is what I was trying to make a higher number. I would like it to show 40-50 lines but found no way to do that. NOTE that I did not want to recompile anything. In any case, it seemed not to admit an easy solution and it was not a big item. I do think there probably is a way to have more history available to scroll back to but I choose not to spend more time looking for it.

In any case, thanks for the reply and the good intentions. I thought this summary might make this clearer for any further readers.
 
Old 10-21-2005, 09:07 AM   #9
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,053

Rep: Reputation: 484Reputation: 484Reputation: 484Reputation: 484Reputation: 484
I posted this same question here about a year ago or so. Same thing, first switching to 132x50, then back to 80x24. Despite of the support I received from helpful people here, I never solved it. I feel sorry about that, because the machine I was working on at that time is used for production and has a screen attached for monitoring and controlling purposes.

I am still wondering where something has gone wrong in the development process of [Debian | Linux] where this decision was made. Too bad, because there are situatuions thinkable where installing X is no option. Text mode is great, and very powerful with virtual terminals and ncurses. Why disable the power?

jlinkels
 
Old 10-21-2005, 04:17 PM   #10
Dazed_75
Member
 
Registered: Oct 2005
Location: Arizona
Distribution: Debian, Ubuntu, Puppy, others
Posts: 36

Original Poster
Rep: Reputation: 16
Oh, I am quite sure the problem is soluable and maybe even through configuration is you can find the right place to do so. The problem is finding the right place/means to fix it in the environment of Unix/Linux development styles which by there very nature are wonderful for the experienced (in the relevant system) developer. Unfortunately, the methods and techniques obfuscate things for the rest of us. I simply decided the desired goal was not important enough to me to invest more time in finding the solution.

That said, let me postulate an answer to your question. I don't think anything has actually gone wrong in the process though I do believe "progress" has left some users behind. The default of a 24x80 screen was simply the lowest common denominator and could be implement for any system even one using an old serial terminal as a console. Some of the other features (like history buffers and multiple consoles on the same display device) implemented reduced the need for other display modes. Then the advent of having a GUI become the common mode of use further reduced the need of most people to use other display modes.

So it is not a surprise to me that the desired configuration is hard to find though I also find it frustrating. My feeling is that the Unix/Linux community has always valued versatility and terseness more than clarity. Most of the documentation seems to be an afterthought and efforts to fix that all seem to stall over time.
 
Old 10-21-2005, 04:31 PM   #11
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
The frame buffer support is something that needs to be included in the kernel to be able to select certain resolutions. It does not mean that you are using a GUI however. It is something that you can do without installing X11. Your problem is that your kernel doesn't include fb support and so certain modes like "vga=791" won't work.
 
Old 10-21-2005, 05:09 PM   #12
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,053

Rep: Reputation: 484Reputation: 484Reputation: 484Reputation: 484Reputation: 484
Dazed_75:

Quote:
The default of a 24x80 screen was simply the lowest common denominator and could be implement for any system even one using an old serial terminal as a console.
I could live with that. You need to have lowest common denominators in order to get things going. But I cannot stand that I actually SEE the 132x50 during 2 seconds before it disappears. It means it IS there. You can switch to it. You cannot use it.I don't call that common denominator, I call that a sort of crippling.

Quote:
My feeling is that the Unix/Linux community has always valued versatility and terseness more than clarity.
Yeah, isn't that great? Especially the versatility.

Quote:
Most of the documentation seems to be an afterthought and efforts to fix that all seem to stall over time.
No one likes writing documentation. Including myself. I am happy that most programmers write a man page, albeit sometimes very terse.

jsciwal:

If you see 132x50 appearing, how can yo have to compile in something additonal to prevent it from disappearing?

jlinkels
 
Old 10-22-2005, 01:59 AM   #13
Dazed_75
Member
 
Registered: Oct 2005
Location: Arizona
Distribution: Debian, Ubuntu, Puppy, others
Posts: 36

Original Poster
Rep: Reputation: 16
It sure is difficult to be understood!!! I apologize if I have not been clear here. The vga TEXT modes work just fine when provided on the kernel invocation command line in /boot/grub/menu.lst. But they only work fine up to the point that console-tools.sh runs vesafb (the aforementioned frame-buffer support) which obviously IS installed since it functions and resets the video mode in order to run its configured console screen emulation.

jschiwal:
All of what you say is true and has been stated here previously. Obviously I did not make it clear enough.

jlinkels:
Similarly, I did not say that 132x50 support is not present for console-tools. Clearly it is available before console-tools run and it disappears when console-tools is run. But that does not mean the mode is there for console-tools since it had not yet run when 132x50 was showing. I do not know whether console-tools can be configured to do the equivalent of 132x50 either by configuration or re-compiling. In either case it would not do it by simply setting the vga display mode to 132x50. It would have to account for it for all six of the virtual consoles it sets up using memory buffers and I suspect it normally uses a graphics mode and font definitions to actually display the virtual console you happen to be using at any given time. BTW, that is only an educated guess but I believe it to be true if somewhat confusing.
 
Old 11-01-2005, 11:32 AM   #14
gnarf
LQ Newbie
 
Registered: Nov 2005
Posts: 1

Rep: Reputation: 0
Maybe This will help?

Found it on google while I found this as well...
 
Old 01-06-2006, 08:26 PM   #15
PhoenixofMT
LQ Newbie
 
Registered: Feb 2004
Location: Pablo
Distribution: Ubuntu, I have tried Debian Sarge 3.1r0a and Fedora Core 2.
Posts: 26

Rep: Reputation: 15
I have been looking for this for some time.
The link above was very helpful but Debian doesn't have '/sbin/setsysfont'. I had to go to '/etc/console-tools' and edit the config file (changing permissions had no effect.) In mine, the very last line is:

Code:
SCREEN_FONT=lat0-sun16
I just changed it to:

Code:
#SCREEN_FONT=lat0-sun16
and now my rows stay how I want them.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I see all text in console? fannymites Linux - General 2 04-15-2005 06:01 PM
How to open up a text console? poler8tor Linux - Newbie 1 01-06-2005 08:18 PM
Console text gamehack Slackware 6 09-25-2004 04:00 AM
(here's a challenge) VGA text console modes with a new kernel. ftgow Linux - Hardware 9 02-12-2004 02:08 AM
Switching between graphical and console modes Panzerfrost Mandriva 14 09-13-2003 01:59 AM


All times are GMT -5. The time now is 07:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration