LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Configuring website permissions on Debian (http://www.linuxquestions.org/questions/debian-26/configuring-website-permissions-on-debian-4175415035/)

takeit 07-05-2012 06:46 AM

Configuring website permissions on Debian
 
Hi,
I'm owning dedicated server with Debian 6 Squeeze 6 LAMP installed.
I pointed my domain (where domain.com is my domain name) to my dedicated server, and now I have some privilages problems and dont know how to solve it.

1. User that runs apache2 is www-data,
2. My domain folder is located in: /var/www/domain.com
3. In /etc/apache2/sites-available/ I have created file domain.com which content is:
Quote:

<VirtualHost *:80>
ServerAdmin admin@domain.com
ServerName domain.com
ServerAlias www.domain.com
# Indexes + Directory Root.
DirectoryIndex index.php
DocumentRoot /var/www/domain.com

<Directory "/">
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/domain.com>
AllowOverride All
Options -Indexes MultiViews
Order Allow,Deny
Allow from all
</Directory>
</VirtualHost>
4. I executed a2ensite domain.com command with success and restarted apache
5. I gave files permissions in /var/www/:
Code:

chmod -R 755 domain.com
  chmod -R 655 domain.com/index.php
  chown -R www-data domain.com

6. In /var/www/domain.com I have folder: test, which has another index.php file. Like /var/www/domain.com/test/index.php

When I open domain.com the content of index.php is displayed
but when I want to go to domain.com/test/ or domain.com/test/index.php it displays me white (blank) page..

How to make whole website content to be accessible by users visiting my website?

Thank you

bathory 07-05-2012 12:05 PM

Hi,

A blank php page means some php problem. Check apache error_log to see if you can find what it is.
Regarding permissions, apache is happy using 755 for directories and 644 for files (regardless the owner, unless you're running a SELinux enabled distro that is not the case here).


Regards

takeit 07-05-2012 01:29 PM

thank you there was an error in file, its working now


All times are GMT -5. The time now is 07:39 AM.